cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Ben88
Fanfold Paper
Posts: 13
Registered: ‎12-20-2017
Location: US
Views: 544
Message 1 of 8

LDAP Authentication with LXCA 2.0

Have an LXCA server on 1.3.2 that is working with LDAP with no problem.  Brought up a new server on 2.0 without migrating anything to it.  Went through the initial setup and then set up the LDAP authentication identically to the old one.  Literally went through the screens one at a time and mirrored them.  Used my own credentials for the binding test, which passed.  But when I try to log in with my account I get an error that the username or password isn't valid.  I know that's not the case, and my account isn't locked out.  The 1.3.2 server is still working with LDAP just fine.  Anyone gotten LDAP to work successfully with 2.0?

Gibon
Token Ring
Posts: 98
Registered: ‎08-08-2017
Location: CZ
Views: 506
Message 2 of 8

Re: LDAP Authentication with LXCA 2.0

For me it works the same as before. No problem at all. 

Did you also remember to create the Role with your AD group name and proper permissions?

 

Otherwise send screens from the configuration.

Regards Leos
Thanks to Mark as Solution or granting Kudos if you find my answer helpful
Ben88
Fanfold Paper
Posts: 13
Registered: ‎12-20-2017
Location: US
Views: 476
Message 3 of 8

Re: LDAP Authentication with LXCA 2.0

Yep, used the same group name, made sure it was spelled correctly, has permissions granted to it, etc.  If I provide credentials (same ones I'm trying to log in with) and click Apply, I get the success message.  Do you happen to be using the Hyper-V VM?  Just wondering if there's a possible problem with that specific build.

 

Untitled.jpg

Capture.JPG

 

 

Gibon
Token Ring
Posts: 98
Registered: ‎08-08-2017
Location: CZ
Views: 464
Message 4 of 8

Re: LDAP Authentication with LXCA 2.0

I have vSphere deployment but I doubt that the hypervisor would be the cause.

Never tried with your setup tbh. I always have static AD server configured, works for me either with GC config or standard LDAP port. I also use specific service account to do the login process (bind parameters).

Also, I have filled the root DN to our domain - dc=xx,dc=yy,dc=zzz

Regards Leos
Thanks to Mark as Solution or granting Kudos if you find my answer helpful
Ben88
Fanfold Paper
Posts: 13
Registered: ‎12-20-2017
Location: US
Views: 454
Message 5 of 8

Re: LDAP Authentication with LXCA 2.0

Yeah, tried it like that, too.  I've got a case open with support, we'll see what they can come up with.

Gibon
Token Ring
Posts: 98
Registered: ‎08-08-2017
Location: CZ
Views: 444
Message 6 of 8

Re: LDAP Authentication with LXCA 2.0

Do you see anything interesting in the log after your failed logon attempt?

Regards Leos
Thanks to Mark as Solution or granting Kudos if you find my answer helpful
Ben88
Fanfold Paper
Posts: 13
Registered: ‎12-20-2017
Location: US
Views: 430
Message 7 of 8

Re: LDAP Authentication with LXCA 2.0

Nope, only thing there is a generic error that the account failed to login, no real details about why.

bigbluemike
Paper Tape
Posts: 2
Registered: ‎06-06-2018
Location: US
Views: 408
Message 8 of 8

Re: LDAP Authentication with LXCA 2.0

Do you log in domain\userid or just userid?

 

Maybe you can try one or the other and see if that helps.

Check out current deals!


Shop current deals

Top Kudoed Authors