English Community

Datacenter Systems ManagementLenovo XClarity
All Forum Topics
Options

20 Posts

04-18-2018

NZ

40 Signins

245 Page Views

  • Posts: 20
  • Registered: ‎04-18-2018
  • Location: NZ
  • Views: 245
  • Message 1 of 3

XClarity Administrator Installation Script Not Running

2018-07-10, 21:28 PM

Hi all!

 

I have an issue where my post install powershell script does not seem to be running after deploying an OS image.

 

I can see that the powershell script successfully copies to the host, and the postinstallscripts.txt log file shows "Executing post-install scripts..." but nothing in the script actually executes. I know for sure that it's not executing as the very first line starts a transcript to log the output, and the second line is a simple powershell cmdlet "Set-Culture" which does not apply.

 

Are there any more verbose logs i can look at? Is there something i may be missing?

 

Any help would be much appreciated!

 

 

Pter.

Reply
Options

41 Posts

04-23-2015

US

83 Signins

1121 Page Views

  • Posts: 41
  • Registered: ‎04-23-2015
  • Location: US
  • Views: 1121
  • Message 2 of 3

Re: XClarity Administrator Installation Script Not Running

2018-07-11, 18:34 PM

Does the job log within LXCA show any details? from LXCA dashboard go to Monitoring>Jobs and find the os deploy job and look at it's steps.

 

Have you tried running the script manually on a new OS deploy? I believe the postinstall scripts run with set-executionpolicy unrestricted currentuser

 

otherwise assuming it's a supported OS

it is a .ps1 extension file?

Group Policy/Domain coming into play?

tried running script on another system?

have you tried adding your own debug to the script? did you make change but not import it into lxca? could be alot of reasons it doesn't work.

 

I'm no expert on this portion of LXCA, so if you continue to have issues, you can always contact support. Here is the LXCA landing page that is all things LXCA.

 

https://support.lenovo.com/us/en/solutions/lnvo-xclaritb

 

 

 

 

 

 

 

Thank You!

Alan Hawkins
ahawkins@lenovo.com
7001 Development Dr Morrisville, NC 27560
Reply
Options

20 Posts

04-18-2018

NZ

40 Signins

245 Page Views

  • Posts: 20
  • Registered: ‎04-18-2018
  • Location: NZ
  • Views: 245
  • Message 3 of 3

Re: XClarity Administrator Installation Script Not Running

2018-07-11, 22:35 PM

Hi Alan,

 

Thanks for your reply!

 

The job log doesn't show anything helpful. Just shows that the script runs:

The script definatelly isn't running correctly as it should take ~15 minutes to complete.

 

The script works perfectly when running manually with the domain\administrator account. Do you know which user account XClarity runs as? I assume local Administrator?

 

The script is a .ps1 on a supported OS (Windows Server 2016 Core).

 

No GPO stuff being applied.

 

The scripts very first line should create a file in a local directly, but it doesn't. This does work fine when i run manually.

 

I haven't had great success creating support cases for XClarity in the past, so hesitant to sink time into it again. The ticket went through to local support who had very limited knowledge of the product.

 

 

Pter.

 

 

 

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms