Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo Yoga Series Notebooks Knowledge Base

Yoga 900 and Ideapad 710S: Linux Only BIOS

In response to customer requests for BIOS with an AHCI option on several Yoga and Ideapad systems, Lenovo has provided Linux Only BIOS for the following models:


YOGA 900-13ISK2:  http://support.lenovo.com/us/en/downloads/DS119354

YOGA 900-13ISK for BIZ: http://support.lenovo.com/us/en/downloads/DS119355

YOGA 900S-12ISK: http://support.lenovo.com/us/en/downloads/DS119356

Ideapad 710S Plus-13ISK: http://support.lenovo.com/us/en/downloads/DS119357

Ideapad 710S-13IKB: http://support.lenovo.com/us/en/downloads/DS119359

Ideapad 710S-13ISK: http://support.lenovo.com/us/en/downloads/DS119360


Please note the following:

  • This BIOS is not intended to be used on machines running Windows operating systems.
  • No official support is provided for this BIOS.
  • The user assumes the risk of any un-intended or performance degradation risks that may be associated with using this BIOS.


Was this information helpful?

Yes No


ginabennett On 2016-10-31, 17:26 PM

This is GREAT! Thanks to Lenovo for responding to user requests.


I am not a beginner Linux user but not an expert either. Has anyone tried out this BIOS with the yoga 900SK? I can see that this BIOS is 'not intended to be used on machines running Windows' but does that mean you CAN'T have a dual boot arrangement? Or just that such an arrangement 'won't be supported'? 

julian165 On 2016-11-05, 10:54 AM

I have dual boot on my Lenovo Yoga 900 13ISK2 following this steps:

Of course I've updated my BIOS


Then I've followed this steps to force windows to work with AHCI configuration 


Then I changed from RAID to AHCI in bios and windows works fine.

Finally I installed Ubuntu as a normal installation and dual boot (with GRUB) works fine!


I hope that the procedure of installing Linux on similar devices is pretty much the same.

chaddjohnson On 2016-11-07, 8:37 AM

Thank you for these BIOS updates.


Is there a plan to also provide an update for the Yoga 910?

vninek On 2016-11-08, 1:39 AM

Yes, thanks for the support on this. I'd also like to know if we can expect a similar release for the Yoga 910. 

ginabennett On 2016-11-08, 4:27 AM

Thanks so much to julian165 for the detailed instructions! I followed your directions to the letter & I got further with the Ubuntu installation than I did before. But I am stuck when I get to the Installation type screen - it says 'This computer currently has no detected operating systems. What would you like to do?' The last option is 'Something else' but I'm nervous about messing around & wiping my Windows OS completely.


When I run gparted, I can see that Ubuntu recognizes the Windows basic data partition & it also lists the unformatted partition I created for linux. If Ubuntu recognizes the main Windows partition I don't know why it can't recognize the OS during the install.


I hate to be a pest ... but do you have any other suggestions?


julian165 On 2016-11-08, 9:01 AM

Yes @ginabennett! That happens because windows partitions are using the whole disk. What I did to solve it is shrink the C: partition in windows. In my case was a 420Gb partition and I shrugged it to 300Gb so that gave me 120 Gb of free space to my ubuntu. I did it in Control Panel > System and Security > administrative tools > create and format hard disk partitions.

After this when I started again the Ubuntu installation, it works perfectly. Start the installation with unallocated space also helps you if you want to manually build your ubuntu partitions.

Sorry for not comment this earlier!


ginabennett On 2016-11-09, 1:44 AM

THANK YOU, julian165! I now have a nice dual boot system, everything working as it should. 

chaddjohnson On 2016-11-09, 3:51 AM

I talked with someone testing Linux on the Yoga 910. He confirmed the option to change from RAID to AHCI is present in the BIOS. Here is what he said about his experience:
    I am using that laptop right now with Fedora 24. The 4.9 kernel
when it comes out will contain my patch. For the time being, I have to
run a kernel that I compiled myself in order to use WiFi.

   In order for Linux to see the hard drive, you'll need to go to the
BIOS and change the hard drive mode to AHCI. You can access the BIOS by
pushing the tiny recessed button next to the power button when the
system is turned off.


   There are two annoying things that I've encountered with the laptop
so far:

1) In order to use the F keys, I need to hold down the Fn key. So in
   order to close a window, I need to press Alt Fn F4. The BIOS does not
   expose a way to change the hotkey behavior. One of my coworkers has
   a Yoga 900 and it has the option to change the hotkey behavior. I
   tried remapping the keys in GNOME, however the keypresses did not
   make it to user space. I tracked it down to the ideapad-laptop
   platform driver in the kernel eating the keypress. I attached a
   patch that I use to allows the F4 keypress to come through to
   userspace. I can then remap the key in GNOME to use Alt F4

2) I sometimes have issues with the laptop locking up when I lock the
   screen. When I come back to it, the fans will be at full speed and
   the system won't respond to any key presses. I haven't tried to see
   if the system is accessible over the network. For the time being,
   I turned off the auto lock screen feature. I can let it sit overnight
   with the lid closed (but not suspended) with no issues.
The battery life hasn't been great under Linux so far since I have the
power management disabled in the BIOS due to the locking up issue. It'll
easily last 3-4 hours like I have it configured right now.
   i915.enable_rc6=0 appears to have fixed the freezing issue
when the laptop screen is locked. I also previously had an issue
with lots of PCI warnings from the kernel. Adding the boot option
'pci=noaer' fixes the issue.

natv On 2016-11-20, 4:25 AM

Anyone got the trackpad working 100% on Linux?  The double-tapping is not working. Otherwise it's working fine but it's annoying having to click the trackpad buttons when you're used to double-tabbing the trackpad.


I installed :






Double tapping is enabled in the synaptics settings.



Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop