cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dcrh86
Blue Screen Again
Posts: 6
Registered: ‎11-01-2016
Location: US
Views: 4,716
Message 1 of 4

BIOS Update failed yoga 910

I have tried to update the Bios to solve the loud noise problem on my yoga 910. But after I downloaded the latest Bios (you can get it from here), I can't run it. it said "the version of ROM file is not newer than that of the bios".. what does it mean, how I can solve the loud noise of Yoga 910?

Lenovo Employee melon
Lenovo Employee
Posts: 58
Registered: ‎10-27-2016
Location: CN
Views: 4,490
Message 2 of 4

Re: BIOS Update failed yoga 910

Hi, It is because the bios version you wan to update is the same as what you have on your device.
We are working on a bios update to opitmize the fan noise. May be it will be published on the official website the next week.
AlexanderP
Paper Tape
Posts: 7
Registered: ‎01-23-2017
Location: AT
Views: 3,464
Message 3 of 4

Re: BIOS Update failed yoga 910

I have the same issue with the loud fan. So, downloaded the last BIOS update from December 2016.

 

As soon as I try to install a new BIOS software, the computer is hanging totally. No time, no mouse move, nothing ...

 

Any recommendation or hint?

Community Moderator
Community Moderator
Posts: 1,322
Registered: ‎12-13-2016
Location: US
Views: 3,454
Message 4 of 4

Re: BIOS Update failed yoga 910

Well, for one, make sure you really need the update.

 

If the fan seems to be running constantly, open Task Manager and see what's hogging the CPU. Specifically look for a line that begins with TODO.  If you see that, it's probably the Qualcomm WLAN Installation program that's hung. Seems that program isn't happy with the Win 10 Anniversary update.  If it's there, go to the control panel and remove the program. That should tone down the fan, considerably. Or at least until you run an intensive program or hit an involved web page. More detailed information is here. Note that you may need to reinstall the WLAN driver and you may start seeing WLAN warnings in your event viewer. The fix for that is to go to power options, select the plan you're using and then click on advanced. Go to PCI Express - Link State Power Management and change it for Battery and Power to OFF. 

 

 


____________________________________
I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo. I love beer.

Check out current deals!


Shop current deals

Top Kudoed Authors