cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Pallamas
Blue Screen Again
Posts: 32
Registered: ‎03-13-2019
Location: US
Views: 222
Message 1 of 4

C930 Cam not working

There seems to be a problem with C930 camera.

 I received my C930 3 months ago and checked everything including the cam.   Everything was fine.  

I don’t use my cam often so I slid the cover and disabled it.  

Today I went to use it.  I enabled it, slid the cover open and activated the app.  Alll I get is the camera with the slash.  The white led light goes on but no image.

I checked here and found multiple posts with the same issue. Following them I went though a complete process (enabling in windows settings, enabling in vantage, check driver in antage and Windows, f8 (only shows the camera slash each time I press it, no ON toggle), delete the device and re add it in Dev Mgr.  No success.  

Opened a chat with Lenovo support and he basicaly stepped through everything I had done. Then he told me to back up my hard drive and to a hard factory reset. 

 

This is is a pretty drastic step but I am out of options.   I’m backing up an image on a 2TB portable drive with Macrium Reflect and will do a reset.  

 

Has anyone else isolated a driver issue or a conflict between Win10 and Vantage?

Pallamas
Blue Screen Again
Posts: 32
Registered: ‎03-13-2019
Location: US
Views: 173
Message 2 of 4

Re: C930 Cam not working

As an afterword, With no other solution I was left with no option but to follow Lenovo instructions to back up, reset and reinstall.  Lenovo helpdesk sought to place the blame on me for installing software that may have impacted the camera.  I had installed Skype.   I had installed multifunction printer scanner drivers.   I had installed Ubuntu in its own partition.  None of these would have corrupted the camera driver.  I believe it much more likely to be a conflict between Vantage and the Microsoft drivers.  I can’t prove it.  But I’m sure.  

mridgely
Fanfold Paper
Posts: 1
Registered: ‎05-07-2017
Location: US
Views: 110
Message 3 of 4

Re: C930 Cam not working

I am having the same issue with no fix. Capture.PNG

Pallamas
Blue Screen Again
Posts: 32
Registered: ‎03-13-2019
Location: US
Views: 103
Message 4 of 4

Re: C930 Cam not working

I didn't get the error dialogue box you have,  just a black screen and a slash/camera.

 

In the end I had no choice but to wipe and reinstall from a Macrium backup.

 

Check out current deals!


Shop current deals

Top Kudoed Authors