cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
thinksinc
What's DOS?
Posts: 1
Registered: ‎03-23-2018
Location: US
Views: 564
Message 1 of 1

Cannot get Gigabit speed from DisplayLink USB3.0 Docking Stations

I have tried two different DisplayLink-driven USB 3.0 Docking Stations with my Yoga 700, and neither of them can achieve Gigabit Ethernet speeds.

 

The docks I've tried are the Besthing USB 3.0 Docking Station, and the Sabrent USB 3.0 Docking Station, both of which use DisplayLink as driver software, and both feature Gigabit Ethernet ports.

 

I have 1Gbps WAN access from Comcast, and if I use a plain Gigabit-to-USB adapter plugged into the Yoga, I get expected speeds in the neighborhood of 950Mbps. However, if I connect through one of the DisplayLink docking stations, my speed immediately drops to about 100Mbps.

 

This leads me to believe that there is an issue with DisplayLink or their drivers, which is why I bought a second docking station to troubleshoot, but so far DisplayLink Support has been unable to provide a solution, and are shifting the blame to the dock manufacturers.

 

I've tried uninstalling and reinstalling the DisplayLink driver software several times, including trying the latest Beta versions, and have tried plugging the Docking Stations in to both of the Yoga 700's USB 3 ports, with the same results.

 

Has anyone had any luck getting Gigabit speeds when connecting a Yoga to a DisplayLink-enabled USB 3.0 Docking Station?

 

Are there any other troubleshooting steps I can take?

 

Thanks,

R

 

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors