cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BobSter2
Paper Tape
Posts: 4
Registered: ‎11-13-2016
Location: GB
Views: 609
Message 1 of 3

Disappearing wifi Network Adaptor Y2P Software or Hardware. Alone? Fix?

Hi

 

I'm having wifi problems with my Yoga2Pro's wifi, but I can't figure-out whether it is hardware or software.

 

There is evidence to suggest that recent versions of Windows 10 have been causing wifi problems. If the problem _is_ with Windows and they are going to fix it, then I can stop worrying about trying to fix the hardware (I am travelling abroad and it is near-impossible to find expertise/parts/tools and out of warranty).


Gory Details:

System: Levono Yoga2 Pro laptop. Intel Core i7-4500U. 8GB RAM. Windows 10 64 bit.
I have been using Windows 10 since it came out without any problems. I have been keeping it updated.

 

Precursor to this problem: On 4th November 2016, apropos of nothing, my wifi stopped seeing the wifi network it was connected to; or any other wifi networks. (My phone could see plenty). This was evident in the Taskbar, Action centre, Settings dialogs of the PC. The Windows version was upto date at the time, but downloading the next week's Microsoft Patch Tuesday updates (9th Nov) fixed the problem. System working AOK. Yay.
(MS update KB3200970 "Addressed issue with the system tray showing no Wi-Fi connection even when Wi-Fi is present")

 

System fixed - I made a system-restore point.

 

The "fix" held for 24 hours, then a new, more severe problem started occurring (='the current problem').

Current problem: After 3 to 5 hours of normal, troublefree operation, the PC stops seeing the wifi entirely. Any menu options associated with wifi networking disappear entirely. The Device Manager can no longer see the Network Adapter (Intel Wireless-N 7260) or its driver software. (That statement is somewhat summmarised - see Note 1 at the bottom of this post for more details).

 

I can't see any Events in Event Viewer which would explain the disappearing Network Adapter.

 

If I do a (whole) system restore back to my restore point, then everything is fine-and-dandy for a few hours, then the Network Adapter disappears again.

 

System Restore consistently fixes it for a few hours. Then the Network (adapter) consistently disappears again.

 

- - -

So, is that hardware or software?

 

One might think it is temperture/overheating related, but the problem also once occurred overnight when the PC was switched off (it was fine when I went to bed and switched it off, but was 'broken' when I switched it on again in the morning).

 

One might think it is Virus related, but everything shows-up clean in MBAM and Avast.

 

If it is a hardware problem, why would a system restore (to a point a few days ago) fix it?

 

I'm thinking/hoping that the problem is caused by recent versions of Windows 10 (f,g below). But I can't see examples of other people suffering.

 

If it _is_ caused by the OS, how does one inform Microsoft about it? (I don't want to join their 'Insiders Community').


Any ideas?

 

TIA


-----------------------------------------
p.s. I have done as much diagnostics as possible - gory details here:

 

Note: the text "Result: FAIL" means that after a few hours of normal operation, AOK, the Intel Wireless-N 7260 Network Adapter can suddenly not be detected and any wifi activity/option becomes unavailable. Restart doesn't help. Restoring the system to a previous state fixes the problem (for a few hours).

Scenarios a-e all have the wifi switched on and connected to a wifi network.

 

a) System status up-to-date at 10 Nov. Result: FAIL

 

b) System status reverted to a Restore Point made in OCTOBER 2016: Result: FAIL

 

c) System status up-to-date at 10 Nov. Updated Network Adapter DRIVER to a newer version found by Device Manager 18.33.3.2 (3 May 2016) (but is not listed in the Levono' list of drivers). Result: FAIL

 

d) System status reverted to a Restore Point made in AUGUST. Retained old NA driver. Downloaded and applied November 9th MS Updates and updated Browser (Firefox) Version and Virus definitions: Result: FAIL

 

e) System status reverted to a Restore Point made in August. Retained old NA driver. Update Browser (Firefox) Version and Virus definitions, but DID NOT download/apply November 9th MS Update: Result: RUNS FINE FOR THE 4 HOURS UNTIL MS FORCES THE LATEST MS OS UPDATES TO BE APPLIED, then runs OK for a few hours then FAILs.

.

Scenarios f-g have the wifi switched OFF; or switched on but not connected to a wifi network; so that Automatic Updates can't be forced onto the computer.

f) System status reverted to a Restore Point made in August. Wifi switched OFF. Result: RUNS FINE FOR THE 14 hours I tested it. (i.e. the Network Adapter appears to be fine, as reported by the Device Manager)

...

g) (follows on from (f))... Wifi now switched ON but options set to "forget" known wifi networks, (so wifi is ON and polling nearby networks, but is not connected to any of them). Result: RUNS FINE FOR THE 8 hours I have (so far) tested it. (i.e. the Network Adapter appears to be fine as reported by the Device Manager)


Conclusion: f and g seem to suggest that the problem arises from later (current) versions of Windows 10. But this is inconclusive, because in scenario (f), the wifi card is not being used and and (g) it isn't being used for sending/receiving internet traffic

 

(N.B. I am abroad and using my hotel's wifi network(s) to try and use the internet. I have no control over the network itself).

----------------------

 

Note 1:

When I say "The device manager can no longer see the Network Adapter" - this is a _summary_ of what happens - infact, it seems to go through 4 separate stages:

 

1) normal operation - everything AOK.
2) The PC reports it is still seeing the wifi connnection that it is/was connected to, but is seeing no other wifi networks. The wifi network it connected to can no longer send/receive any data
3) The Device Manager shows a yellow warning triangle on Network adapters> Intel Wireless-N 7260, and 'Properties' shows "No drivers are installed for this device."
4a) The Device Manager shows a yellow warning triangle on Network adapters> Intel Wireless-N 7260 and Properties shows "This device cannot start. (Code 10). This device does not exist."
or
4b) Device Manager, Network adapters> doesn't show Intel Wireless-N 7260 at all.

 

A few minutes pass between each step through the stages occurring. Other apps running on the PC (e.g. mp3 player) freeze up for a couple of seconds when each stage changes to the next.

BobSter2
Paper Tape
Posts: 4
Registered: ‎11-13-2016
Location: GB
Views: 561
Message 2 of 3

Re: Disappearing wifi Network Adaptor Y2P Software or Hardware. Alone? Fix?

just found these in the event log immmediately before the latest fail

 

6 of these:

[quote]Warning: The network interface "Intel Wireless N 7260" has begun resetting. There will be a momentary disruption in network connectivity while the hardware resets. Reason: The network driver requested that it be reset. This network interface has reset 6 times since it was last initialized.

 

EventData
IfGuid {CC4AA2FA-DC52-4D03-AC11-154DFA0B5C13}
IfIndex 19
IfLuid 19985273102270464
AdapterName Intel(R) Wireless-N 7260
ResetReason 3
ResetCount 6[/quote]


followed by two of these:

[quote]Error: WLAN AutoConfig detected limit connectivity, performing Reset/Recover.adapter.
Code: 2 0xDEADDEED 0xEEEC

System
- EventData
ErrorCode 2
Reason 0xdeaddeed
IpFamily 0xeeec
PortType 0x0 [/quote]

 

... then FAIL

Landes
Paper Tape
Posts: 1
Registered: ‎01-03-2018
Location: SE
Views: 324
Message 3 of 3

Re: Disappearing wifi Network Adaptor Y2P Software or Hardware. Alone? Fix?

I have the same problem. Any updates on this?

Check out current deals!


Shop current deals

Top Kudoed Authors