cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bborzucki
Fanfold Paper
Posts: 7
Registered: ‎01-21-2019
Location: PL
Views: 181
Message 1 of 3

Lenovo Y530 - BSOD after unsleep

Hi,
I have a huge problem with my laptop Lenovo Y530 Legion: Y530 i7-8750H 15.6" / 16GB DDR4 / OS 256GB SSD M.2 PCIe + 1TB HDD / GTX1050 / Win10P.
I cannot un-sleep my laptop. After un-sleeping I have always a BSOD with one of these errors: memory management, kernel in page error, `critical process died` and maybe more because BSOD disappears very quickly so I can never be sure if I've missed something.
The laptop has up-to-date drivers. I updated it using driver booster 6 and Lenovo vantage. Windows 10 Professional is up-to-date too.
I tried:
* disabled/enabled intel virtualization on bios options
* I updated my bios (I have up-to-date bios)
* My drivers are up-to-date (nothing helps)
* I used Lenovo diagnostic tools and each report finished with success
* I used the memtest (test was OK)
* I checked my hard drive (test OK; smart OK)
* I tried sleep/un-sleep on battery mode and power mode - the same situation
*enabled/disabled fast boot

I'm also attaching a few minidumps and log events. Maybe these files can help. You can find them here: https://www.dropbox.com/sh/ddua7d7qahie81y/AACZn5-VJBdtQwcqyg-eIqOTa?dl=0
I have this problem from the beginning.

 

Could you help me? It is really annoying ;/ 

bborzucki
Fanfold Paper
Posts: 7
Registered: ‎01-21-2019
Location: PL
Views: 125
Message 2 of 3

Re: Lenovo Y530 - BSOD after unsleep

Hi, 

 
I found why I have a BSOD after unsleep mode. I found these two articles: https://xtreem.pl/blog/usypianie-systemu-problemy-w-lenovo-legion-y530-oraz-ideapad-330/ and https://www.forumpc.pl/topic/467943-bsod-przy-wychodzeniu-z-u%C5%9Bpienia-nowy-laptop-lenovo-win10/. Y530 has a problem with unsleep mode so you need to enabled hybrid sleep - after that everything works .... except Hyper-V Smiley Sad Smiley Sad Smiley Sad. Hyper-v is incompatible with Hybrid sleep so you need to choose between hyper-v or sleep mode. I hope that some engineer from Lenovo can read it and help me how to fix my problem. This is very import for me. 
Ra-V
Fanfold Paper
Posts: 11
Registered: ‎02-14-2019
Location: PL
Views: 86
Message 3 of 3

Re: Lenovo Y530 - BSOD after unsleep

In my case, the BSOD problem on waking up was caused by an incompatible SSD PCIE M.2 hard drive.

I had an ADATA SX6000 drive installed that work on the Realtek RTS5760 controller and it caused problem with waking and other small software problems. 

I try everything: reinstall, change drivers, zarządzenie energią and nothing helped.

In other forum i have read that realtek controller may be incompatible with Legion y530

 

Next i changed drive to ADATA SX8200 PRO with controller  Silicon Motion SM-2262EN and no problems occur anymore.

Check out current deals!


Shop current deals

Top Kudoed Authors