cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
chapapak
Token Ring
Posts: 62
Registered: ‎03-01-2016
Location: GR
Views: 1,429
Message 1 of 8

Mouse cursor jumps when working in background - Yoga 500-15ISK

Hello everyone,

 

I would like to report a problem. My original post is in Microsoft community forums, here:

https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/mouse-cursor-jumps-when-workin...

 

At a random time, when the cursor changes from "normal" to "working in background" it becomes pixelated and jumps away a few centimeters and then returns back to original position when loading is complete.

The only way to work around this is if I make a change in mouse settings, like "enable pointer shadow" and then revert it back as it was.

 

Other users have confirmed the issue as you can see and one of them suggests uninstalling System Interface Foundation. By uninstalling it, I tested it and the problem disappears, so this must be the issue, but in that case Lenovo apps no longer work.

 

Maybe an update is needed.

 

I have Lenovo Yoga 500-15ISK and using Windows 10 x64 Home, build 15063.332

Retired Support Specialist
Posts: 3,772
Registered: ‎12-24-2015
Location: IN
Views: 1,396
Message 2 of 8

Re: Mouse cursor jumps when working in background - Yoga 500-15ISK

Hi there, Chapapak -  

 

Thank you for writing in to the Lenovo Forum - happy to have you here today.

 

Open the Control Panel, double click on the "Mouse" icon, then the "Pointer Options" tab, then UNCHECK the box next to "Enhance pointer precision", then apply, then OK.

 

Update us how it goes.

 

 

 

 

Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented

Martijn1
Fanfold Paper
Posts: 8
Registered: ‎06-29-2017
Location: NL
Views: 1,378
Message 3 of 8

Re: Mouse cursor jumps when working in background - Yoga 500-15ISK

I had this exact same problem on my Lenovo ideapad 510S-14ISK and unchecking the box "enhance pointer precision" did not work.

 

I uninstalled Lenovo System Interface Foundation and this seems to have fixed the problem for me as well. So thank you for letting us know chapapak!

 

The only problem is that Lenovo Companion now no longer works, so let's hope an update will come out that fixes the issue with system interface foundation.

 

EDIT: Never mind, the problem returned after a day. I will probably open a new thread.

Retired Support Specialist
Posts: 3,772
Registered: ‎12-24-2015
Location: IN
Views: 1,363
Message 4 of 8

Re: Mouse cursor jumps when working in background - Yoga 500-15ISK

Great that all goes well

Please feel free to utilize our forums at any time.

 

 

 

 

Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented

chapapak
Token Ring
Posts: 62
Registered: ‎03-01-2016
Location: GR
Views: 1,346
Message 5 of 8

Re: Mouse cursor jumps when working in background - Yoga 500-15ISK

Hello Shashi_Lenovo,

 

The box was already unchecked and the problem still persists.

chapapak
Token Ring
Posts: 62
Registered: ‎03-01-2016
Location: GR
Views: 1,198
Message 6 of 8

Re: Mouse cursor jumps when working in background - Yoga 500-15ISK

Any update for this issue please?

PCPrincipal
What's DOS?
Posts: 1
Registered: ‎11-27-2017
Location: US
Views: 851
Message 7 of 8

Re: Mouse cursor jumps when working in background - Yoga 500-15ISK

I cannot find the "System Interface Foundation" program to uninstall on my laptop... I've looked everywhere for it. What should I do next?

tgalos
What's DOS?
Posts: 3
Registered: ‎01-06-2018
Location: US
Views: 682
Message 8 of 8

Re: Mouse cursor jumps when working in background - Yoga 500-15ISK

 

Solved (kinda) in another thread: Maybe try changing the aspect settings before full on disabling it though:

 

If you don't need neither Caps Lock on-screen indicator nor Flight mode hotkey, you may just disable (I did it) Lenovo Utility. Press Ctrl + Alt + Delete, go to Task manager, open the Startup tab, find Lenovo Utility, select it and click Disable, then reboot your notebook. Now everything should be fine, but remember Caps Lock on-screen indicator will not show and Flight mode hotkey will not work (little airplane one the F7 key).

Top Kudoed Authors