English Community

Lenovo NotebooksLenovo Yoga Series Notebooks
All Forum Topics
Options

3 Posts

09-05-2014

United States

5 Signins

13 Page Views

  • Posts: 3
  • Registered: ‎09-05-2014
  • Location: United States
  • Views: 13
  • Message 1 of 196

Re: Yoga 2 pro sound problem

2014-10-31, 6:11 AM

Hi Amy. We have a Yoga 2 Pro with the headset problem. It's a second computer so we can live without it for a time for the cause. The sound only plays through the headsets, when we take them out, nothing. We've been using a Bluetooth speaker as a work around.

Let me know if you still need one. We're in SoCal.

Best,
Mari


10/31 EDIT: Removed email address to prevent mischief. Amy_Lenovo
11/4 EDIT: Moved post to use for escalation. Amy_Lenovo

Solved! See the solution
Reply
Options

1 Posts

11-04-2013

Gainesville

6 Signins

68 Page Views

  • Posts: 1
  • Registered: ‎11-04-2013
  • Location: Gainesville
  • Views: 68
  • Message 2 of 196

Yoga 2 pro sound problem

2013-11-04, 18:04 PM

Bought Yoga 2 pro a week ago from Lenovo Web-site.

Perfect device I thought. But now I have strange sound issue.

 

I have no sound through integrated speakers. It perfectly works with connected headphones but when i plugged them out from jack looks like it still think they are connected.

So if I have no headphones plugged I see message "You just plugged a device into the audio jack". But there are nothing plugged there. And sometimes (once in an hour or something like that) it shows message "You just unplugged a device..." and in a moment immediately again  "You just plugged a device into the audio jack". Tried to reinstall realtek drivers using one provided with laptom and also with the latest from Lenovo web-site.

Tried to recovery system to its original state - the same problem.

I have only one sound device showed on "Control panel -> Sound" window even switching to "Show disabled devices" and only one speaker in Realtek HD Manager also.

 

Is anyone faced the same problem? Any idea how this can be fixed?

Thanks

 

Reply
Options

1 Posts

11-05-2013

Cincinnati, OH

1 Signins

12 Page Views

  • Posts: 1
  • Registered: ‎11-05-2013
  • Location: Cincinnati, OH
  • Views: 12
  • Message 3 of 196

Re: Yoga 2 pro sound problem

2013-11-05, 21:24 PM

I'm having the same issue. Everything worked perfectly last night. I get home from class, grab my laptop, and I have no sound. Headphones work just fine, but the speakers are not doing anything. I've also noticed that I no longer get the "device has been plugged in" or "device has been unplugged" popup upon plugging or unplugging anything.

I've installed the latest realtek drivers offered by Lenovo to no avail. 

I'm currently running antivirus/antimalware scans in a likely hopeless attempt to figure out what's up. Anyone with any info or ideas would be most appreciated.

Reply
Options

4 Posts

11-08-2013

Carolina

8 Signins

46 Page Views

  • Posts: 4
  • Registered: ‎11-08-2013
  • Location: Carolina
  • Views: 46
  • Message 4 of 196

Re: Yoga 2 pro sound problem

2013-11-08, 1:52 AM

I have a very similar but opposite problem. My sound will not come out of the headphones. It sees that I have plugged them in but it won't play any sound. I had this problem a few nights ago and it resolved itself but it has returned. Please help. 

Reply
Options

4 Posts

11-08-2013

Carolina

8 Signins

46 Page Views

  • Posts: 4
  • Registered: ‎11-08-2013
  • Location: Carolina
  • Views: 46
  • Message 5 of 196

Re: Yoga 2 pro sound problem

2013-11-08, 14:02 PM

Rebooting the system resolved the problem for me. Not a great fix but at least I have sound from the headphones and would seem to be a software rather than hardware issue. Does anyone know how to prevent this from happening?

Reply
Options

6 Posts

11-19-2013

United States

11 Signins

46 Page Views

  • Posts: 6
  • Registered: ‎11-19-2013
  • Location: United States
  • Views: 46
  • Message 6 of 196

Re: Yoga 2 pro sound problem

2013-11-19, 5:20 AM

Has anyone actually found a fix for this??  I'm having the EXACT same issue and I have tried everything!  I've lost count of how many times I uninstalled and re-installed the Realtek Audio Driver. I've made registry changes, even tried to find a setting in my BIOS that seemed to work for other people with this problem but is apparently non-existant on my Yoga 2.

 

I've Googled every combination of this problem I could think of and despite coming across thread after thread of people trying to solve the problem in a myriad of ways (and none of them working for me or most of the other people who tried the suggestions.)   I finally broke down and called Lenovo Support and of course they were no help!  How frustrating to TELL support people that you know what you're doing and you've ALREADY tried all these things then have to sit there and watch them fumble around doing the EXACT same things you already told them didn't freaking work!

 

Sorry for the rant but this is frustrating.  To spend $1K on a new machine and have such a stupid simple problem is ridiculous!  Now I have to go to Best Buy and see if THEY can fix this.  This is my work machine and I can't afford to be without it for weeks at a time.  GRRRR!  :smileymad:

 

Does anyone know what the hell is wrong here?  Do I actually have a hardware issue on a brand new machine?

Reply
Options

11 Posts

11-22-2013

bensheim

11 Signins

105 Page Views

  • Posts: 11
  • Registered: ‎11-22-2013
  • Location: bensheim
  • Views: 105
  • Message 7 of 196

Re: Yoga 2 pro sound problem

2013-11-22, 10:00 AM

i ran into this exact problem now, too. everything worked fine until popups appeard telling me that i plugged/unplugged a headphone (which i did not, no headphones were connected).

 

no I do hear sound only via headphones, integrated speaker stopped working. when i plug/unplug headphones there is no notification.

 

i seems that the drivers are now always in headphone mode.

 

rebooting does not solve the issue.

 

i hope this is not a hardware defect :(

 

 

Reply
Options

11 Posts

11-22-2013

bensheim

11 Signins

105 Page Views

  • Posts: 11
  • Registered: ‎11-22-2013
  • Location: bensheim
  • Views: 105
  • Message 8 of 196

Re: Yoga 2 pro sound problem

2013-11-22, 10:20 AM

ok ... found out that if I plug / unplug a headphone many times (10-20) and I am lucky the drivers detect the correct state and i can hear sound via the internal speakers.

 

so i guess the headphone jack does not signal the state correctly.

 

however if i do not hear the speakers i wont't hear  them after a reboot, too. so the illegal headphone jack state stays even after a reboot. 

 

this may be a hardware defect of the headphone jack? how does a driver know if a headphone is plugged in? is there some kind of switch in the headphone jack? plugging/unplugging headphones takes more 'force' on my yoga 2 pro than i'm used to from other jacks ...

 

can anybody from lenovo comment on this?

 

 

Reply
Options

142 Posts

10-21-2013

Illinois, USA

288 Signins

2542 Page Views

  • Posts: 142
  • Registered: ‎10-21-2013
  • Location: Illinois, USA
  • Views: 2542
  • Message 9 of 196

Re: Yoga 2 pro sound problem

2013-11-22, 15:07 PM

wrote:

ok ... found out that if I plug / unplug a headphone many times (10-20) and I am lucky the drivers detect the correct state and i can hear sound via the internal speakers.

 

so i guess the headphone jack does not signal the state correctly.

 

however if i do not hear the speakers i wont't hear  them after a reboot, too. so the illegal headphone jack state stays even after a reboot. 


Cool, the trying it lots of times thing was something I wanted to suggest, since the problem sounds like a mechanically bad jack where there's a physical "switch" where inserting the plug pushes a contact away opening a circuit that signals the system. The fact that it survives a reboot pretty much confirms this.

 

It sounds like inserting the plug pushes the contact away, but when you remove it, it's not springing back and/or making solod contact to indicate the jack is empty again.

 

Since a few people have reported this problem it sounds like a bad batch of jacks or an assembly issue.

 

There's a chance the problem will get better/worse with use I guess.

 

Looking at the Hardware Maintenance Manual, the jack is on the "audio board" and it looks sealed so there's probably not much you could do by taking it apart. You also have to remove a bunch of stuff to get to it. But it is a small replacable unit, so if you have the at-home warranty it might not be too painful if you can talk them into sending someone out with one.

 

Z.

Reply
Options

6 Posts

11-19-2013

United States

11 Signins

46 Page Views

  • Posts: 6
  • Registered: ‎11-19-2013
  • Location: United States
  • Views: 46
  • Message 10 of 196

Re: Yoga 2 pro sound problem

2013-11-22, 16:59 PM

Well I'll be **bleep**!  That actually worked!! :smileyvery-happy:   Thank you so much!

 

Wow, maybe there actually was a bad batch of them or something.  Alll that time screwing around with drivers and settings and what it really needed was a brute force kick in the pants.  Hilarious.

 

I've got the Best Buy plan so if it happens again I'll stroll up there and see about getting it fixed or swapped out.

Reply
Options

6 Posts

11-19-2013

United States

11 Signins

46 Page Views

  • Posts: 6
  • Registered: ‎11-19-2013
  • Location: United States
  • Views: 46
  • Message 11 of 196

Re: Yoga 2 pro sound problem

2013-11-22, 17:22 PM

Hmm... I may take it in anyway. 

 

It's playing through the speakers now, but as I listen to music, every so often there's a little touch of static like I've plugged something in, but I haven't actually touched anything.  Probably related to whatever sensor is off in the jack.

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete