cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Eddie511R
Paper Tape
Posts: 2
Registered: ‎11-05-2018
Location: US
Views: 508
Message 1 of 3

Realtek Thunderbolt Ethernet Adapter Doesn't Install

Hi,

I'm trying to connect a USB Type-C (Thunderbolt 3 compatible) ethernet adapter to my new 730-151IKB.

If I have the Device Manager window open I see the adapter added to the list of adapters, but with the yellow triangle against it.  A couple of seconds later, the device drops from the list.

I've tried re-installing the Windows driver and also installing the latest Realtek drivers, to no avail.

Any ideas as to why it doesn't install.

Cheers.

 

Social Support Agent
Social Support Agent
Posts: 570
Registered: ‎08-02-2018
Location: US
Views: 490
Message 2 of 3

Re: Realtek Thunderbolt Ethernet Adapter Doesn't Install

Hi Eddie511R!

 

Welcome to the Community,

 

You may try downloading the Intel Thunderbolt (TBT) Driver below,

 

https://pcsupport.lenovo.com/us/en/products/LAPTOPS-AND-NETBOOKS/YOGA-SERIES/YOGA-730-15IKB/download...

 

Update us how it goes.

 

Regards,



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Eddie511R
Paper Tape
Posts: 2
Registered: ‎11-05-2018
Location: US
Views: 452
Message 3 of 3

Re: Realtek Thunderbolt Ethernet Adapter Doesn't Install

Sorry, I meant to reply earlier, but RL got in the way.

Updating the Thunderbolt driver made no difference.  I still got the same results, in that the ethernet adapter appears in Device Manger for a few seconds and then disappeared.

I actually found the solution while fixing another issue.

It appears that the Check Point VPN software, which I had loaded, stops any other modification to any ethernet adapter.  To fix the other issue I had, I removed the CP VPN and then as part of that fix had to re-boot.  After re-booting, the ethernet adapter for the Thundebolt adapter was present and working.  Of course, now the adapter is there, I could re-load the CP VPN and everything still works.

Cheers.

 

Check out current deals!


Shop current deals

Top Kudoed Authors