English Community

Lenovo NotebooksLenovo Yoga Series Notebooks
All Forum Topics
Options

11 Posts

12-17-2019

US

16 Signins

74 Page Views

  • Posts: 11
  • Registered: ‎12-17-2019
  • Location: US
  • Views: 74
  • Message 1 of 12

Realtek audio device stops working

2019-12-30, 0:23 AM

I have a practically brand new C940, but every once in a while have a red X by my sound icon on the bottom right hand corner, and lose audio.  A restart will normally fix it, but it happens quite frequently.

 

Under the device manager, the Realtek Audio device shows: 

 

This device cannot start. (Code 10)

STATUS_DEVICE_POWER_FAILURE

 

Again, a reboot will generally fix the issue, but not sure why there is a power failure to the audio device?

Reply
Options

337 Posts

11-26-2019

HK

138 Signins

2803 Page Views

  • Posts: 337
  • Registered: ‎11-26-2019
  • Location: HK
  • Views: 2803
  • Message 2 of 12

Re: Realtek audio device stops working

2019-12-30, 1:32 AM
Try uninstall "Realtek Audio device" in "device manager" and reboot your devices.

If you are using Windows 10, it should automatically use the generic driver. See do you get any sound from the speaker (e.g. play a video). It will sound awful, but as soon as you get some sound, it will most likely be driver issue.

If that's the case, find the driver from Lenovo's web site and install it.

If not, it should be a hardware issue, contact the technical support for that. Your warranty should cover that.
Reply
Options

11 Posts

12-17-2019

US

16 Signins

74 Page Views

  • Posts: 11
  • Registered: ‎12-17-2019
  • Location: US
  • Views: 74
  • Message 3 of 12

Re: Realtek audio device stops working

2019-12-30, 23:23 PM

Removed and reinstalled Realtek audio drivers, and the issue still persists.  Just opened my laptop from sleep and saw the red X on my audio device.  Will be contacting Lenovo support.

Reply
Options

2 Posts

01-06-2020

NL

3 Signins

24 Page Views

  • Posts: 2
  • Registered: ‎01-06-2020
  • Location: NL
  • Views: 24
  • Message 4 of 12

Re: Realtek audio device stops working

2020-01-06, 22:55 PM

Hi,

 

I'm facing exactly the same problem. Uninstalled, reinstalled, stopped and started drivers, services and who knows what, but only a reboot seems to fix the problem :-(

 

Did you manage to get a fix?

 

Thx

Ed

Reply
Options

11 Posts

12-17-2019

US

16 Signins

74 Page Views

  • Posts: 11
  • Registered: ‎12-17-2019
  • Location: US
  • Views: 74
  • Message 5 of 12

Re: Realtek audio device stops working

2020-01-06, 23:47 PM

Not sure if it's a permanent fix, but I haven't had the issue since:

 

Uninstall the drivers, but DO NOT restart.  If you restart it will automatically install the ones from the computer and the problem will persist.  After the uninstall, open up Lenovo Vantage and run the automatic updater - it should say it needs to redownload the Realtek Audio drivers, so do so and let it install.  Now, reboot.

 

Haven't had the red X since I did this, but can't guarantee it will work for everyone.

 

Nathan

Reply
Options

2 Posts

01-06-2020

NL

3 Signins

24 Page Views

  • Posts: 2
  • Registered: ‎01-06-2020
  • Location: NL
  • Views: 24
  • Message 6 of 12

Re: Realtek audio device stops working

2020-01-07, 8:36 AM

Hi Nathan,

 

I've uninstalled all bloatware so Vantage is not an option for me.

But, because of your suggestion, I uninstalled and deleted the driver and ran the batchfile located in C:\Drivers\Audio and did a reboot hoping to achieve the same effect ;-)

 

Since then I've suspended teh laptop, put it in sleepmode and still no red X :-)

 

Thx and keep you posted when anything changes!

 

Gr

Edgar

Reply
Options

11 Posts

12-17-2019

US

16 Signins

74 Page Views

  • Posts: 11
  • Registered: ‎12-17-2019
  • Location: US
  • Views: 74
  • Message 7 of 12

Re:Realtek audio device stops working

2020-04-25, 15:12 PM

Unfortunately, the problem has returned.  I am attempting the same solution as before and will see what happens.  It seems to go away for a while then slowly creep back as now it does it nearly every time I wake the laptop up from sleep.  Very strange.  Any more updates from anyone?

Reply
Options

1 Posts

05-29-2020

US

1 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎05-29-2020
  • Location: US
  • Views: 0
  • Message 8 of 12

Re:Realtek audio device stops working

2020-05-29, 5:14 AM

I'm having the same issue... on the x1 c7! So frustrating as I bought this thinking it would be reliable. Speakers cut out during a conference. FFS

Reply
Options

4 Posts

05-04-2020

PH

4 Signins

25 Page Views

  • Posts: 4
  • Registered: ‎05-04-2020
  • Location: PH
  • Views: 25
  • Message 9 of 12

Re:Realtek audio device stops working

2020-05-30, 4:35 AM

same issue for me and i also had posted it here: https://forums.lenovo.com/t5/Lenovo-Yoga-Series-Notebooks/C940-14-Sound-Not-Working-After-Sleep/m-p/5013371

 

did you guys find a fix? support will be coming hopefully next week to replace parts so i hope that resolves the issue

Reply
Options

4 Posts

09-25-2019

US

2 Signins

23 Page Views

  • Posts: 4
  • Registered: ‎09-25-2019
  • Location: US
  • Views: 23
  • Message 10 of 12

Re:Realtek audio device stops working

2020-07-02, 15:58 PM

This happens to me frequently as well. It used to be every few months, but now it is every few days. Each time I have to update the sound drivers and do a restart. It's super frustrating and I'm starting to wonder if there is a hardware issue or if it could be affected by a virus?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete