cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
AmeerHM
Paper Tape
Posts: 3
Registered: ‎03-27-2016
Location: UK
Views: 4,610
Message 1 of 8

[SOLVED] Yoga 900 not automatically going into tablet mode or showing touch keyboard!

Hi,

 

I was wondering if anyone else is experiencing some of the below issues, how long you may have been experiencing them and if you've found a fix and would like to share it, haha:

 

  1. Laptop not automatically going into tablet mode when folded back or put into the tent orientation (with the relevant settings in the system->tablet area selected).
  2. Touch keyboard not automatically popping up when selecting a text field in google chrome or Microsoft office products (especially when they were before, but I can't tell you when it stopped working).
  3. Touch pad still active in tablet mode, when manually selected. This didn't always seem to be the case - when I first got my hands on the laptop, I did extensively try out all of the marketed orientations and this never happened (I even tested to see if it would happen and I was quite impressed with the results, but not anymore!). UPDATE: after updating the bios for the device, this issue resolved itself. I have no idea how or why but ok.

 

An important post-script to note: a lot of people are complaining of the above issues and are also experiencing a rotation-locked screen that is unresponsive to any tinkering! I am not one of those people. The "accelerometer", if that even is it's real name!, seems to work perfectly fine.

 

Please hit me up with any relevant responses as soon as possible, I will try to respond and weigh in with my further investigations.

 

Guru
Posts: 1,412
Registered: ‎06-08-2013
Location: BE
Views: 4,522
Message 2 of 8

Re: Yoga 900 (and possibly others) not automatically going into tablet mode or showing touch keyboar

  1. Click the START button.
  2. Open the Settings application.
  3. Click System, it should be at the top left.
  4. In the menu on the left, choose Tablet Mode, which is the 5th entry in the list.
  5. Verify that the setting 'When this device automatically switches tablet mode on or off' is not set to 'Don't ask and don't switch'

In Desktop Mode, the virtual keyboard will never appear automatically. To show the keyboard, click the keyboard icon in the system tray or task bar.


Warm regards,
Jonas Hendrickx

Lenovo Insider - Windows Insider MVP

Personal website: ThinkScopes

AmeerHM
Paper Tape
Posts: 3
Registered: ‎03-27-2016
Location: UK
Views: 4,517
Message 3 of 8

Re: Yoga 900 (and possibly others) not automatically going into tablet mode or showing touch keyboar

Hi Jonas,

 

The "when this device automatically switches tablet mode on/off" setting is and always has been set to "always ask me before switching". However, I do not recieve any prompts upon folding the laptop into the tablet mode.

 

Also, in regards to the touch keyboard, I was referring to whilst already being in tablet mode.

 

I appreciate the suggestions but I've already covered those bases, thank you regardless though, man. 

 

Bit off-topic but how do I unselect a post in the thread as a solution? update: worked it out, lol.

Community Moderator
Community Moderator
Posts: 1,060
Registered: ‎07-13-2010
Location: CA
Views: 4,507
Message 4 of 8

Re: Yoga 900 (and possibly others) not automatically going into tablet mode or showing touch keyboar

Have you tried reinstalling the Lenovo Mode Control driver? 

 

http://support.lenovo.com/ca/en/products/laptops-and-netbooks/yoga-series/yoga-900-13isk/downloads/D...

←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗
Tap that kudos button if I helped ^^
←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗
AmeerHM
Paper Tape
Posts: 3
Registered: ‎03-27-2016
Location: UK
Views: 4,495
Message 5 of 8

Re: Yoga 900 (and possibly others) not automatically going into tablet mode or showing touch keyboar

That worked!

 

I am mystified! Why would the laptop all-of-a-sudden require the driver after working for months perfectly fine without it.

 

This is really unusual and a little terrifying, I don't know what I'd do if something similar like this happens again. :/

 

Regardless though, the bottom line is... That worked! Thank you for the suggestion, my friend. 

 

 

Community Moderator
Community Moderator
Posts: 1,060
Registered: ‎07-13-2010
Location: CA
Views: 4,492
Message 6 of 8

Re: Yoga 900 (and possibly others) not automatically going into tablet mode or showing touch keyboar

Always glad to help Smiley Happy.

 

The driver was released late January, so it's possible the system had a pre-release, or Windows did something funny with a system update.

←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗
Tap that kudos button if I helped ^^
←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗←↑→↓↘↙↖↗
wulfloh
Paper Tape
Posts: 1
Registered: ‎11-19-2016
Location: DE
Views: 4,092
Message 7 of 8

Re: [SOLVED] Yoga 900 not automatically going into tablet mode or showing touch keyboard!

Hi everyone,

 

I'm having the same issue, but installing, deinstalling, and reinstalling the Mode Control Driver does not solve unfortunately. The driver seems to be running, at least that's what Task Manager says. And since Win 10 switches to tablet mode when I fold it back I assume that the hardware is working (however the Yoga detects that it is folded back). I have this problem for 4 weeks now and it is starting to really get on my nerves. Any suggestions are really appreciated!

 

Thanks in advance!

theking2
Token Ring
Posts: 266
Registered: ‎10-25-2012
Location: AF
Views: 606
Message 8 of 8

Re: Yoga 900 (and possibly others) not automatically going into tablet mode or showing touch keyboar

Unfortunately that didn't help me. even when I just move the tablet sideways when lying flat on a table it activates and askes if I want to rotate or exit tablet mode.

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors