cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
zepnik
Paper Tape
Posts: 1
Registered: ‎09-11-2014
Location: Israel
Views: 2,200
Message 1 of 2

SSL authentication using client certificate failing on a fresh new Yoga 2 Pro

I am a doctor and using a laptop to login into an SSL server for secure communication.
I was using an old asus with win 8.1 without a problem. 2 weeks ago I got my new Y2P installed the certificate I got from the IT guys and all worked like a charm! What a wonderful laptop.

And then, my SSD vanished suddently from the system could not boot, so I replaced the first Yoga with and identical one from the store. This time- win 8.1 an IE cannot recognize the newly issued ceertificte and getting an SSL error so cannot open the htpps website. 

Tried onekey recovery, isntalling all windows updates, using a new user nothing works. Back to the old ASUS all working fine. The IT guys said they never had such a problem, after hundreds of certificates issued the same way.

First Y2P worked without a glitch second one does not.

 

Any ideas?

 

 

softwaredevelop
What's DOS?
Posts: 1
Registered: ‎02-05-2015
Location: Chicago
Views: 1,694
Message 2 of 2

Re: SSL authentication using client certificate failing on a fresh new Yoga 2 Pro

I had the same problem with my new Yoga Pro 2 when trying to connect to some https sites that worked fine with my previous computer.  I asked a friend that's a systems administrator for help and he had me look for marketing / adware type software that came pre-installed on my machine.  He warned me that more and more new computers are coming pre-loaded with this type of software that many people would consider malware.  He said that such software can cause this type of problem because of how it sits inbetween you and the sites you visit (how your information passes through it).

 

I found Superfish Visual Discovery, which fits this description, was pre-installed on my machine.  As soon as I uninstalled it my https connection problems went away.  You should check your list of installed programs (go to your Control Panel > Progams > Programs and Features).  If you see "Superfish Inc. VisualDiscovery" in your list of installed programs, that is likely the casue of the problem (at least it was for me).  Hope this helps...

 

Admin edit - please make use of the superfish uninstall tool on the lenovo support site here.

Holiday Deals
HAPPENING NOW!

Get the best deals on PCs and tech now during the Holiday Sale
Shop the sale

Top Kudoed Authors