cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dkalbach
Not applicable
Posts: 3
Registered: ‎03-01-2019
Location: US
Views: 240
Message 1 of 3

Touchpad not working - Pointer Absent - Yoga 3 Pro

Well, genuinely frustrated now.

 

I've been working this issue for several hours this morning to no avail.

 

A few days ago I noticed my touchpad wasn't working on wake.  Solution had been to restart.  This worked several times.  When I saw it happening with more frequency, I went in and made sure I didn't have any viruses, or unwanted software.  I also ran a sweep of my system (sfc /scannow), and a similar scan in the common files area.  No issues detected anywhere, from there I went to look at my start up options, and basically made sure nothing was running.  I even turned off Garmin Express Tray just in case.

 

--- ISSUE ---

 

On start up I have no mouse pointer, it used to be in the Upper Right hand corner, now it seems to be middle of screen (I can only view via the (CTRL function mouse finder) as there is no visible pointer on my screen.  Touch Pad is not working.  

 

Device Manager shows: 12c HID Driver with the Yellow Explamation point.  Tried updating (all up to date) tried the remove and re-install, reboot.

 

  • Tried BIOS F9 Load Defaults, F10 Save, Restart
  • Tried re-installing Synaptics Pointer software and drivers
  • Tried Lenovo's support page and reinstalled current driver from there.
  • When I enable via Lenovo Vanatage, it immiediately goes grey and shifts back to disabled 
  • Read all of the google searches I could find, and tried most everything I could think of

All of this failed to correct the problem

 

Before I crack the case open and look for a bad ribbon cable, or connection does anyone have any ideas??

 

On last item to note: Windows 10 Boots up slightly odd.  On Boot the Lock Screen displays, I used to simply click the touchpad (not working) or the space bar to bring up the PIN Login page.  This isn't working either.  Occassionally I can ESCAPE to the login page, and now that doesn't seem to work either, I'm forced to CTRL ALT DEL to get to the login page.

 

These oddities lead me to think this may be a Windows Update issue more than a Hardware fault.

 

However the intermittent failure over a short span of time to complete failure leads me back to hardware.  Thinking if the ribbon to the touchpad is bad, it would likely cause the exclamation point on the 12c HID Device Driver.

 

Very last bit of information - Under Settings Mouse Advanced I no longer see the Synaptic Info, nothing listed for touchpad at all.  Again think a bad cable might be the cause.  If the computer isn't detecting the hardware, perhaps its not loading the software.

 

Ideas???

 

-- Dave

Lenovo Yoga 3 Pro Y1370

Windows 10 Update 1830

Jonopt
Not applicable
Posts: 1
Registered: ‎05-19-2019
Location: GB
Views: 95
Message 2 of 3

Re: Touchpad not working - Pointer Absent - Yoga 3 Pro

Dear Sir,

i have the exact same model, and the exact same problem. Happened about a week ago for no apparant reason. I have also tried installing driver from support site, tried reinstalling windows via recovery. So far nothing has worked and I am at a loss. please advise if you find a solution,  I will do the same.

regards.

dkalbach
Not applicable
Posts: 3
Registered: ‎03-01-2019
Location: US
Views: 91
Message 3 of 3

Re: Touchpad not working - Pointer Absent - Yoga 3 Pro

Actually I did find a fix.

 

Trying to remember exactly what I did though.  After opening the case and finding nothing wrong with the hardware I went back through all of the posts and found some discussion on software changes and Anti-Virus.

 

I went in to the driver setup and removed the bad driver.  I un-installed McAfee Anti Virus, and reinstalled the driver.  It has been working fine ever since.

 

I think McAfee does something to the registry creating the second driver which then conflicts with the original driver causing the issue.

 

So, in short check and see if McAfee is installed.  If so, uninstall it, then the touchpad driver (I think it was intellipoint), restart and if the driver doesn't load automatically - reinstall driver manually.

 

Last note (sorry worked on this a couple of months ago) while looking at this issue, I found a Lenovo Driver Support center (product) that automatically keeps your drivers up to date.  I downloaded it, but didn't like it at all, so I immiediately removed the software package and constinued to work the problem own my own.  It didn't fix my problem, and I didn't like giving up the control of my computer.

 

Just my two cents.

 

Good luck, and please post if this fixes your problem.

 

Dave

 

PS - Switched to all Mac after this issue occurred.

Check out current deals!


Shop current deals

Top Kudoed Authors