cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
IdeaPad11sDude2
Paper Tape
Posts: 3
Registered: ‎03-24-2014
Location: Colorado
Views: 17,575
Message 1 of 37

Turn off virtual keyboard in laptop mode of Yoga Pro 2

Hello All.

 

Wow!

The more I mess with these things (trying an 11s and a 13" yoga pro 2) the more I find that they are choc full o' glitches.

I really wanna like one of them but...

 

I use Chrome in laptop mode on both and every time I enter a text field the virtual keyboard pops up.

Yes, this would be appropriate if in tablet mode, but completely unnecessary and counterproductive in laptop mode.

 

Can this be disabled somehow?

 

Thanks

B

indest
Bit Torrent
Posts: 1,639
Registered: ‎08-14-2011
Location: USA
Views: 17,489
Message 2 of 37

Re: Turn off virtual keyboard in laptop mode of Yoga Pro 2

  • Windows key + R > services.msc > "Touch screen keyboard and handwriting panel" > double-click and change it from "Automatic" startup to "Manual".

This will mean that when in tablet mode, you will need to click the keyboard icon on the taskbar, when you want it.

 

You can also make a startup script that uses the sensor to stop and enable the service when in laptop/tablet mode. Look into ahk.

IdeaPad11sDude2
Paper Tape
Posts: 3
Registered: ‎03-24-2014
Location: Colorado
Views: 17,480
Message 3 of 37

Re: Turn off virtual keyboard in laptop mode of Yoga Pro 2

Okay.

Thanks but it didn't work.

 

I stopped the service and set it to manual.


Then when I go into a text field within Google Chrome it resets it to automatic and opens it again.

 

Is this a setting in Chrome perhaps?

 

Thanks

B

Diceman
What's DOS?
Posts: 3
Registered: ‎05-28-2014
Location: upstate NY
Views: 17,287
Message 4 of 37

Re: Turn off virtual keyboard in laptop mode of Yoga Pro 2

i just tried also and it did not help. anyone else have a suggestion? its a real nusiance to have to stop and close that virtual keyboard

indest
Bit Torrent
Posts: 1,639
Registered: ‎08-14-2011
Location: USA
Views: 17,280
Message 5 of 37

Re: Turn off virtual keyboard in laptop mode of Yoga Pro 2

Right click on start button> open cmd (as Admin):

 


net stop TabletInputService

Press Enter
sc config TabletInputService start= disabled

Press Enter

/////////////////////////////////////////////////////////////////////////////////////////////////////////

sc config TabletInputService start= auto

Press Enter
net start TabletInputService

Press Enter

Diceman
What's DOS?
Posts: 3
Registered: ‎05-28-2014
Location: upstate NY
Views: 17,275
Message 6 of 37

Re: Turn off virtual keyboard in laptop mode of Yoga Pro 2

i only want to turn it off in laptop mode. would this disable virtual keyboard in tablet mode?? also, it only is happening with chrome browser.

splus
Token Ring
Posts: 229
Registered: ‎08-20-2011
Location: BA
Views: 17,258
Message 7 of 37

Re: Turn off virtual keyboard in laptop mode of Yoga Pro 2


@Diceman wrote:

i only want to turn it off in laptop mode. would this disable virtual keyboard in tablet mode?? also, it only is happening with chrome browser.


If it's ONLY with Chrome then you have some settings messed up in Chrome.

Have you changed anything in chrome://flags ? If nothing then you might want to check you have Chrome sync turned on for all Chrome settings, extensions, bookmarks and passwords (so it recovers it all after reinstall), and then either reinstall Chrome, or if that doesn't work uninstall it completely, reboot and install it again.

 

But do it all while in laptop mode. Maybe you installed Chrome while in tablet mode, and Chrome got stuck with it, thinking you have a tablet without physical keyboard...

Highlighted
indest
Bit Torrent
Posts: 1,639
Registered: ‎08-14-2011
Location: USA
Views: 17,245
Message 8 of 37

Re: Turn off virtual keyboard in laptop mode of Yoga Pro 2

This will turn the keyboard into manual launch. When in tablet mode, just hit the keyboard icon on the taskbar.

eskim
Paper Tape
Posts: 3
Registered: ‎07-19-2014
Location: Seattle, WA
Views: 16,805
Message 9 of 37

Re: Turn off virtual keyboard in laptop mode of Yoga Pro 2

I own a Twist S230u and have the same problem in Chrome and many of the Office 2013 products (including Word, PowerPoint, and Outlook).  Thus, it seems that it's not just a Chrome issue.

 

Don't know if I want to directly mess with the registry.  I'd think there should be a user-level way to disable the virtual keyboard in laptop mode.  Any other ideas?

DMarie
Fanfold Paper
Posts: 8
Registered: ‎08-22-2014
Location: USA
Views: 16,324
Message 10 of 37

Re: Turn off virtual keyboard in laptop mode of Yoga Pro 2

I have been trying to disable this freakin' on-screen keyboard  for days now!! If anyone's found a fix or workaound, please post. I have a Yoga Pro 2, 13 inch with  8.1.Thanks!

Check out current deals!


Shop current deals

Top Kudoed Authors