cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bmp83
Paper Tape
Posts: 2
Registered: ‎10-10-2015
Location: Cambridge, MA
Views: 243
Message 1 of 3

YP2: Flickering screen, deafening static, and dead 3.5mm port

tl;dr version: do i have a sound card issue, and if so, is there a way to replace it? not afraid of opening 'er up, but don't want to have to solder.

Have had a refurb'd yoga pro 2 for about 15 months, experiencing several deal breaker issues w/in 1 month of warranty expiration.

Wanted to see if anyone had ideas before I threw this thing out and said so-long to a brand I otherwise trust & like (not to be mellodramatic).


system is i7, dual booting win10 educational version & ubuntu 15.04, both 64 bit. all drivers fully up to date.

- screen flickers when on battery power. this is occasional, but screen will go black until I press the 'win' key a few times. When the start menu is up, the screen stays normal. ONLY happens in win10.

- Headphones don't work. before, headphones would go silent if the volume was above 50% and a sound came thru, but muting/unmuting fixed this (per web advice). Now, nothing.

- [much worse] randomly (though seems more likely when i boot up), the speakers emit an AWFUL static noise you can hear from 2 rooms away, even when muted. Volume, mute, etc., does nothing--only way to stop it is to wait it out (sometimes 10-15 minutes) or turn the computer off.

--When it happens, audio doesn't work at all on the computer until I reboot. Sometimes, audio doesn't work period.
--Happens in BOTH Ubuntu and Windows.
--Have tried updating, uninstalling, re-installing audiotek drivers

 

Googled my heart out but came up empty. Too broke to buy another laptop - this thing was my baby. Would love it if someone had ideas.

cnagra
Punch Card
Posts: 20
Registered: ‎08-15-2015
Location: Telford
Views: 125
Message 2 of 3

Re: YP2: Flickering screen, deafening static, and dead 3.5mm port

Did you ever fix this? I have the same issue.

Thanks
bmp83
Paper Tape
Posts: 2
Registered: ‎10-10-2015
Location: Cambridge, MA
Views: 112
Message 3 of 3

Re: YP2: Flickering screen, deafening static, and dead 3.5mm port

No, sorry :/  no amount of reformatting, OS switching, or anything else mitigated it.

 

I ebay'd the YP2 and bought an Asus.  best of luck!

Check out current deals!


Shop current deals

Top Kudoed Authors