cancel
Showing results for 
Search instead for 
Did you mean: 
Views: 92,340

Question

I just recieved my Yoga13 a few days ago and am having trouble with wifi connectivity.  If i am sitting on top of my router the yoga works well and fast however just one room away with the machine on my lap and i am unable to connect at all.  The laptop recognizes my network but is unable to open simple web pages or email.  

 

I was told that it was an issue with the microsoft updates and we restored to factory settings and turned off autmomatic microsoft updates. Unfortunately, I am still having the issue.

 

If I am unable to travel outside of 10 feet of my router, that is certainly affecting my productivity. 

 

What steps can I take to resolve this?

Answer

There are many factors which can affect wireless performance and connectivity.  Updating to the latest Lenovo drivers may resolve the problem.  A prior Windows update may have installed a 3rd party driver. Some settings such as password protection, power management and router channel selection may also be common causes.

 

 

1) Re-install latest Wireless driver

Install updated WIFI & Bluetooth drivers.  Version that is or above v1.04.0213 should be used.

 

Here is the Link for the Windows 8 wifi & bluetooth Yoga 13 driver

 

Here is the Link for the Windows 8.1 wifi and bluetooth Yoga 13 driver.

.

 

2) Turn off Password Protected Sharing
If you still experience limited WiFi problem after connected to router, please follow the steps below.

 

  • Control Panel > Network and Sharing Center > Advanced Sharing Settings > All networks> Password Protected Sharing > Turn off Password Protected Sharing. 

3) Change of channel in router

There are total of 11 channels for you to choose. 1, 6, or 11 are preferrable. Some users found it works best with Channel 7, too.

 

4) Ensure maximum performance setting in power management.   Some customers may also wish to disable Windows power control over wifi.  This may also reduce / eliminate drops while operating on battery.  

  • Open device manager and locate the wifi device
  • Right click and select properties
  • Click the power tab
  • Uncheck the box for "Allow Windows to Manage Power to this device"

Was this information helpful?

Comments
Gordy_Lenovo

Re: Yoga 11s Idea Pad

Wireless connection works flawlessly, except, when on airplane (with Airplane mode off), does not recognize GoGo Network. Other devices (phone, Kindle) do - at the same time.

Anyone run ino this issue (and solution)?

Thanks

Vindfeld

"

4) Ensure maximum performance setting in power management.   Some customers may also wish to disable Windows power control over wifi.  This may also reduce / eliminate drops while operating on battery.  

  • Open device manager and locate the wifi device
  • Right click and select properties
  • Click the power tab
  • Uncheck the box for "Allow Windows to Manage Power to this device"

 

When i do that my wifi connect fast, put when pc wakes from sleep, i get a bluescreen, with tekst that windows detects a fail and must restart... how can i fix that??

 

Sorry for my english

 

Mvh Michael

 

 

westport

Hi Michael, 

 

I have a Yoga13 that has wifi issues only when the keyboard is folded back.  See this video.   If have tried several different network drivers drivers and am currently running this verson: RTL8723AU  1026.5.1118.2013.

 

Please watch this video I uploaded to YouTube which shows the issue. 

https://www.youtube.com/watch?v=yswlK3ypdlw&feature=youtu.be

 

Thanks,

Randall

Vindfeld

have you attempted this??

 https://forums.lenovo.com/t5/Idea-Windows-based-Tablets-and/Lenovo-Yoga-13-Throttles-CPU-when-in-Tablet-mode-set-to-Portrait/m-p/914043#M5144

rfin16

I did the device driver update as recommended and the problem of frequent disconnects and refusal to reconnect still occurs. I am also using full power mode (and never had problems before on power saver). Why would this problem suddenly creep up after two years?

jefffehr

The realtek RTL8723 AU wireless network adapter provides unacceptable thruput speeds.  My router is fine.  If I disable the realtek and use ny Netgear wnda3100 in the usb port i get download speeds of 40 to 60 mbps.   The realtek produces less than 1 mbps download.    This has been a cronic problem since I have had this.  I have updated the driver and even had the card replaced to no avail.    Is there a replacement wireless lan I can install that will help the issue?

TomiK
Possible solution: set your router to manual channel selection and use one of the channels from 4 to 7. Why did I do that? I believe now that Yoga 13 (first generation) Realtek WiFi card and/or driver have problems dealing with interference from other networks, When I bought my Yoga in 2012 WiFi worked fine. With time however it started dropping off the network, for last year it was not able to connect at all, even if the router was right next to it. During that time number of WiFi networks in my vicinity increased. I noticed that my Apple AirPort Express router was set to automatic channel assignment and it always was using channel 11. I set it to manual and chose channel 6. My Yoga suddenly was able to connect to the network without problems and it maintains connection in the entire house. A bit of theory behind it. In North America 2.4 GHz network uses eleven channels numbered from 1 to 11. Each is assigned different frequency range but those ranges overlap between neighbouring channels. Logically the best channels to use are 1 and 11 because they have no other channels to interfere with on the left side of the spectrum for 1 and on the right side for 11. If your router is allowed to automatically select a channel then it will naturally pick either 1 or 11. Now if you have many routers in the area and all of them are set to automatic channel selection (which probably is the default manufacturer's option) then suddenly those best channels get crowded. I manually set my router to channel 6 because theoretically it is one of the worst channels to use, right in the middle of the spectrum facing interference from left and right. For that reason no router with"simplistic" auto mode will choose that channel. In the word of many "stupid" routers running on auto those channels 4 to 7 seem to be the best to use.
UrbanChick

Hi all. 

 

I have a NetGear router WNDR3400 and it works great for my connection to my Macbook, iPhone and wireless printer.

 

However, about a week ago, my work computer (Lenovo Yoga 2) stopped recognizing the connection and it will no longer connect. It recognizes the SSID but continues to have issues connecting. During this week, all the above devices continue to connect and work great with that router. It's just the Yoga 2. 

 

Any thoughts, tips, suggestions, etc., etc. would be very much appreciated. 


Thank you.