cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jcady92
Not applicable
Posts: 6
Registered: ‎06-28-2014
Location: California
Views: 7,152
Message 1 of 13

Yoga 2 Pro Disable Transitions

I've come to just about my wits end with the Yoga 2 Pro transitions.  The sensors are just far too touchy for my liking.

 

For example, If I lean forward at all with it or lay the screen flat, the keyboard and touchpad disables and/or the screen rotates 180 degrees because it thinks I'm in a different mode.  Sometimes I lay on my side and rotate the computer 90 degrees with me and the screen rotates, which is not what I want.

 

I am having extreme difficulty discovering where to disable the rotation and keyboard/mouse disabling.  Can anyone point me in the direction of where I can find the option to either alter this feature to my liking or shut it off completely?

 

Thanks.

indest
Not applicable
Posts: 1,639
Registered: ‎08-14-2011
Location: USA
Views: 7,127
Message 2 of 13

Re: Yoga 2 Pro Disable Transitions

You can use the rotation lock button (near the power button) to solve your 90 degree angle rotation problem. As for the rest, you can disable the rotation sensors via device manager.
jcady92
Not applicable
Posts: 6
Registered: ‎06-28-2014
Location: California
Views: 7,105
Message 3 of 13

Re: Yoga 2 Pro Disable Transitions

Thanks, that solves my rotation problem.  But it still doesn't solve the keyboard and mouse getting disabled problem.  Is there any way to fix that?

indest
Not applicable
Posts: 1,639
Registered: ‎08-14-2011
Location: USA
Views: 7,091
Message 4 of 13

Re: Yoga 2 Pro Disable Transitions

For the mouse, uninstall the synaptic driver and install a generic synaptic driver... Let me think about the keyboard for a while.
jcady92
Not applicable
Posts: 6
Registered: ‎06-28-2014
Location: California
Views: 7,019
Message 5 of 13

Re: Yoga 2 Pro Disable Transitions

Alright, still an issue.

 

I have two things listed in my device manager under sensors:

 

Simple Device Orientation Sensor

HID Sensor Collection

 

Disable the simple device orientation sensor, I can't really tell a huge difference. Perhaps it was the accelerometer.  But the keyboard disable still happens when I tilt the laptop screen and the screen rotation still happens when it shouldn't.

 

Disabling the HID sensor collection gets me most of the way to where I want.  The screen no longer rotates.  The keyboard works at first.  But when I put it into, say tablet mode, the keyboard gets disabled.  Then when I take it out of tablet mode into laptop mode, the keyboard stays disabled and I can't use it.  So this is obviously not ideal.

 

Any solutions?  I'd really like to just turn off automatic screen rotation and turn off the feature that automatically disables the keyboard.

indest
Not applicable
Posts: 1,639
Registered: ‎08-14-2011
Location: USA
Views: 7,007
Message 6 of 13

Re: Yoga 2 Pro Disable Transitions

Try to disable the ymc.exe service. See if that does it for you.

jcady92
Not applicable
Posts: 6
Registered: ‎06-28-2014
Location: California
Views: 6,989
Message 7 of 13

Re: Yoga 2 Pro Disable Transitions

ymc.exe doesn't appear to be running in my task manager.

DMarie
Not applicable
Posts: 8
Registered: ‎08-22-2014
Location: USA
Views: 6,854
Message 8 of 13

Re: Yoga 2 Pro Disable Transitions

Hi jcady92-

I'm also new to the YP2 & feel your pain with some of these quirks although, I do love this device! On the right side of the YP2, in front of where the usb 2.0 port is, there's a switch that enables/disables the screen rotation.

 

jcady92
Not applicable
Posts: 6
Registered: ‎06-28-2014
Location: California
Views: 6,850
Message 9 of 13

Re: Yoga 2 Pro Disable Transitions

Hi DMarie,

 

Thanks for the response.  Unfortunately, that button seems to only work if the laptop is in tablet mode.  I did try it and it didn't seem to have any effect in regular mode (there's not even any indication that something is happening).

 

After months of dealing with this, I think I found a solution though:

 

I disabled the Simple Orientation Sensor under sensors in the Device Manager.  And I also disabled Transition.exe in the startup programs.  Rebooting and it seems that the screen orientation only changes if put into tablet mode and keyboard and mouse remain functional in all orientations except tablet.  The disabling of the driver and program seems to make the transitions depend entirely on the bend of the screen and not the orientation of the device, which is exactly what I want.

 

Hope that helps others as well!

jcady92
Not applicable
Posts: 6
Registered: ‎06-28-2014
Location: California
Views: 5,635
Message 10 of 13

Re: Yoga 2 Pro Disable Transitions

Unfortunately none of the solutions here ended up doing the trick for me. After months of searching, however, I found the answer! Here's what I did:

Win + Q and search for 'services'. Click the 'View local services'. Find the service 'ymc' and right-click it and click Properties. Under the General tab, change the startup type to disabled and also stop the service. Save the changes. You may or may not have to restart your computer, but that should disable all the transitions! No more annoying screen flips and keyboard getting disabled.

Check out current deals!


Shop current deals

Top Kudoed Authors