cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
binder
Paper Tape
Posts: 1
Registered: ‎08-03-2016
Location: GB
Views: 284
Message 1 of 2

Yoga 2 Pro Wifi connection, dropped connection, slow performance fix

Hi,

 

I have installed Windows 10 Home within the last 3-4 months and I have been experiencing several issues. The one of concern is connecting to certain wifi networks. I am able to connect to my hotspot on my phone and certain wireless routers but I am unable to connect my home 5g router, well the 2g connection.

I have tried using the following links to solve the problem:
https://forums.lenovo.com/t5/Lenovo-Yoga-Series-Notebooks/Yoga-2-Pro-Wifi-connection-dropped-connect...
and 
https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/WiFi-problem-No-internet-DNS-Not-working...  (namely the "ipconfig /flushdns" cmd, which did get the connection to come with 'connected, secured', however I was still unable to use the browser.)

 

I have removed any vpn that I have been using and have updated by network driver via the device manager > network adapter > Intel(R) Wireless - N7260 > update driver software route have made no progress. 

Can anyone offer any assistance?

Gibraltar
Punch Card
Posts: 55
Registered: ‎11-06-2014
Location: PT
Views: 250
Message 2 of 2

Re: Yoga 2 Pro Wifi connection, dropped connection, slow performance fix

Hi,

 

Resolving wifi issues with the Y2P is a hit and miss exercise. But do try the usual suspects.

Regarding your home router, in what bands does it work? 2,4ghz, 5ghz, both? Since the 7260N only works in 2.4ghz you can try in the wifi network adapter settings (device manager) forcing the 2.4ghz only (not in auto).

And since you’ve got the network card options open, do check if:

  • uAPSD Support - disabled
  • 802.11n Channel Width for band 2.4GHz | 20Mhz
  • 802.11n Channel Width for band 5.2GHz | 20Mhz
  • 802.11n Mode | VHT
  • Fat Channel Intolerant | Disabled (allows 40MHz operation)
  • Roaming Aggressiveness | Lowest (disables roaming, see Intel support site)
  • Transmit Power | Medium
  • Wireless Mode | 802.11b/g
  • Disable in power option the “allow Windows to turn off device”

 

Extra option you can do, changing your WLAN settings channel on your router: try changing to channel 1, 6 or 11 (not auto). I noticed a big improvement with a channel forced on my router instead of auto, and this did indeed almost resolved all my issues at home. When away from home I’m still dependent on the provider’s router configuration, so can’t do much about that.

Top Kudoed Authors