cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Yazzy
Paper Tape
Posts: 5
Registered: ‎09-11-2015
Location: CH
Views: 723
Message 1 of 4

Yoga 2 Pro: Wireless Adapter not working, but Bluetooth does

After changing the broken fans on my Yoga 2 Pro (IDEAPAD 76) my Wi-Fi Adapter stopped working. Weird thing is though, that Bluetooth is still working - they're on the same card!

 

Details:

- Wi-Fi isn't shown anywhere in the OS. The Adapter is not even detected anymore in the Device Manager. (Currently, this hardware device is not connected to the computer. (Code 45) )

- Interesstingly I have a new AUX problem as well. Only the left speaker of any device (tried with different headphones) will work. I don't know if these things are related.

error.pngwifi not showing, bluetooth does

 

Alread tried and not working fixes:

- Updated all drivers

- Turn off/on Wireless in BIOS

- Reatached all plugs inside of the computer

- Bought a new Wi-Fi card (the old was crap anyway if you know what I mean)

 

I know that I could "just use a Wi-Fi dongle" like I am doing now. But I want a real fix not a workaround Smiley Happy

 

Any ideas? Help would be very much appreciated! Thanks in advance Smiley Happy

 

Or does anyone know where I can buy this thing? It might be this piece that is broken.

 

card.pngpart of the mainboard?

Social Support Agent
Social Support Agent
Posts: 217
Registered: ‎08-02-2018
Location: PH
Views: 701
Message 2 of 4

Re: Yoga 2 Pro: Wireless Adapter not working, but Bluetooth does

Hello Yazzy! Thanks for posting in our community, though we don't see any damages, the hardware might have been affected by the recent changes. I see that you have already tried all the necessary troubleshooting, I recommend to contact our service center in this link https://support.lenovo.com/us/en/solutions/ht118678 just filter it by the city nearest you. Thanks. 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Yazzy
Paper Tape
Posts: 5
Registered: ‎09-11-2015
Location: CH
Views: 665
Message 3 of 4

Re: Yoga 2 Pro: Wireless Adapter not working, but Bluetooth does

Hello Arjay! Thank you for answering.

 

I checked some of the companies that were close to me from the site you posted. None of them do anything remotely connected to repairing a computer. I don't know how any of these companies could help me with my problem. Is there a list of shops, where you can walk-in or send-in the computer and pay for a repair?

 

Anyways. I'm asking the community where exactly the hardware problem could be.

 

I have two theories:

a) Audio Board is broken

Due to my AUX headphone connector not working properly anymore I suppose that the whole Audio Board might be the source of the problem and thus needs to be replaced.

 

b) Something wrong with the Wi-Fi antenna

As the Bluetooth of the Wi-Fi card is working fine, it might just be the antenna that is broken. But I have no idea how to verify or fix that Smiley Sad

 

Has anyone in the community an idea what could be the problem or what my next steps should be?

 

Thanks and regards Smiley Happy

akung99
What's DOS?
Posts: 1
Registered: ‎01-01-2019
Location: US
Views: 615
Message 4 of 4

Re: Yoga 2 Pro: Wireless Adapter not working, but Bluetooth does

Oddly enough this is the exact same problem I had, which started about a month and half ago. I too purchased a replacement Intel n-7260 card and popped it into the slot and nothing had changed. My bluetooth is still working and it is on the same card. My sound card, speakers, and fans are all normal, and did not have any other hardware issues except for the WIFI adapter. I purchased a small USB wifi dongle and am currently using that. I even wiped my win10 OS to see if it was a software issue. I had to roll-back my windows10 update because the latest one kept causing my dongle WIFI to drop. 

 

My next step is to try the steps someone else had written on a separate forum. If that doesn't work I'm giving up: 

"I popped the back off and pulled out the CMOS battery (black disc located in the corner that the WiFi card is in) and left it out for about 20 minutes. Next I was in the BIOS and I used an option called something like "Reset to Secure Mode". I didn't realise it was working until I boot into Linux and it was suddenly offering me WiFi networks. Went back into Windows and noticed it was there in Device Manager but disabled. Re-enabled it and it was all good. I suspect the CMOS reset did it but I hadn't noticed as it was disabled."

Check out current deals!


Shop current deals

Top Kudoed Authors