cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
allquixotic1
Paper Tape
Posts: 50
Registered: ‎06-12-2012
Location: US
Views: 320
Message 1 of 4

Yoga 730 system hard lock with Thunderbolt eGPU

I have a brand new Yoga 730-15IWL, unboxed, fully updated via Windows Update, and manually installed drivers using Lenovo System Update and Windows Update (Device Manager).

 

I also have an Nvidia RTX 2080 Ti connected to a Sonnet Breakaway Box 650 (the 650 is the wattage of the PSU).

 

After connecting the eGPU and installing the latest Nvidia drivers, my system periodically experiences a permanent "hard lock" that can only be solved by power cycling the system. The mouse cursor, keyboard and screen all stop responding forever until power cycled.

 

Out of the box, I was using the latest 17.x Thunderbolt driver series (non-DCH). I upgraded my Thunderbolt driver to DCH. My Intel IGP and Nvidia graphics driver are both DCH now, as well as the Thunderbolt driver. But the problem still persists. The DCH drivers for the IGP and Nvidia card were automatically installed; I did not choose DCH specifically.

 

The Thunderbolt controller is PCI ID 15BF, and NVM version 11. Is there a newer NVM available for the 15BF? Out of curiosity, I tried the ThinkPad T480 firmware package for the 15BF, and it failed saying the PM driver is not loaded. I assume I can't install the power management driver in question because the Yoga 730 doesn't have the same PM chip as the ThinkPad T480.

 

Anything else I can do to troubleshoot this? I'm 99.9% sure this isn't the eGPU or Nvidia card, because they work fine (no stability issues) when attached to a 2018 Razer Blade 15.

allquixotic1
Paper Tape
Posts: 50
Registered: ‎06-12-2012
Location: US
Views: 277
Message 2 of 4

Re: Yoga 730 system hard lock with Thunderbolt eGPU

Bump, and more info:

 

I bought a brand new Razer Core X eGPU and Nvidia 2080 Super to try to rule out the problem being my GPU or eGPU enclosure. I also have two separate, high-quality (expensive) 2m StarTech Thunderbolt cables, and I've tried them both.

 

I've also been able to reproduce this problem on a MSI GS65 Stealth 9SG. So, in summary, I've tried all of the following configurations, and I always get whole system locks when using an eGPU:

 

Legend: G = GPU, S = System, E = Enclosure, C = Cable, M = Monitor, D = DisplayPort Cable, V = Driver Version

G1 = Nvidia RTX 2080 Ti

G2 = Nvidia RTX 2080 Super

S1 = Lenovo Yoga 730

S2 = MSI GS65 Stealth 9SG

E1 = Sonnet Breakaway Box 650

E2 = Razer Core X

C1 = Startech TB3 Cable #1

C2 = Startech TB3 Cable #2

M1 = Samsung CRG90

M2 = Acer Predator X34

D1 = CableMatters DisplayPort 1.4 cable

D2 = Club3D DisplayPort 1.4 (HBR3) cable

V1 = Latest Thunderbolt 3 DCH driver (1.x)

V2 = Latest Thunderbolt 3 Legacy driver (17.x)

 

I haven't tried every single one of the above with every single other device, as that would open up 128 possible configurations, but I've definitely tried each of the items listed above while swapping out multiple of the other components basically at random.

 

And in every, single, case, I get system hardlocks just by using an eGPU.

 

It isn't software I have installed, because the Yoga has extremely vanilla, uncustomized software -- it's not "lived in" at all. It has Firefox, Discord, and drivers. I'm not even playing any games, I'm just using apps like Powershell, Device Manager, Task Manager, and Firefox.

 

It isn't any specific piece of hardware, because like I said, I've tried 2 of every conceivable piece of hardware involved in the equation.

 

It isn't the OS version, necessarily, because on the Yoga I have Windows v1903 stable, but just "for kicks" to try and troubleshoot this, I upgraded my MSI GS65 Stealth to use the Fast Ring insider build, and the problem persists there. It could still be a software problem common to both 1903 and the Fast Ring, conceivably.

 

It isn't temperature, as I have monitored temps with GPU-Z and they're always normal. Just to make sure the problem isn't GPU-Z, I uninstalled it from the Yoga recently, but the problem persists, after ensuring GPU-Z isn't running.

 

I'm at wit's end. How does anyone use Thunderbolt 3 with an eGPU successfully? Is there a magic NVM firmware update for the Yoga 730 that isn't showing on the website? I'm on NVM version 11, but for most controllers version 20 or 43 is out. Lenovo hasn't released an NVM update for the Yoga 730 though, even though the same controller ID (15BF) has updates for ThinkPads. Maybe Lenovo doesn't care to support their Yoga products.

 

I keep asking for firmware because this is the only thing I haven't tried yet. And I can't actually update using a ThinkPad's 15BF firmware, because the FwUpdateCmd tool throws this error: Error: 0x21C SDK_VENDOR_MISMATCH - The image file is for another vendor product

 

This is so frustrating!

allquixotic1
Paper Tape
Posts: 50
Registered: ‎06-12-2012
Location: US
Views: 275
Message 3 of 4

Re: Yoga 730 system hard lock with Thunderbolt eGPU

Also, the instant I clicked "Post" in this thread, I got an nvlddmkm.sys BSOD, with my system having been awake for about 30 minutes at that point since the last crash. I'm using the latest stable Firefox as my browser. This is really incredible.

allquixotic1
Paper Tape
Posts: 50
Registered: ‎06-12-2012
Location: US
Views: 242
Message 4 of 4

Re: Yoga 730 system hard lock with Thunderbolt eGPU

I found a workaround to the problem that proves this is a driver issue. Upon uninstalling all Intel graphics drivers and disabling the IGP's now generic "Microsoft Basic Display Adapter", the stability issue is gone. So it seems this has been a bug with the Intel graphics driver. Thanks guys for all your help Smiley Very Happy

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors