cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
getdrunk
Paper Tape
Posts: 5
Registered: ‎04-04-2016
Location: DE
Views: 6,308
Message 1 of 8

Yoga 900 - Auto Rotation not working / present

Hi,

 

well after having my new Yoga 900 for a few days, I turned it off for the first time tonight. Afterwards the auto rotation feature was gone. No more option in the display settings and the registry keys for auto rotation were set to 0. The HID Sensors in the device manager are installed properly.

 

I tried reinstalling Windows 10 and it worked, but after rebooting once more, it stopped working again.

 

I have read that there are many people with this problem, maybe somebody has found a solution?

getdrunk
Paper Tape
Posts: 5
Registered: ‎04-04-2016
Location: DE
Views: 6,257
Message 2 of 8

Re: Yoga 900 - Auto Rotation not working / present

Resolved the issue: I used o&o 12 to keep my privacy to myself adding all recommended and partly recommended changes to windows 10. Well, that one prohibited the Sensor monitoring service to start. Reverting the changes and starting the services solved my problem. 

 

I hope it helps somebody!

Boothy999
Paper Tape
Posts: 4
Registered: ‎04-13-2016
Location: GB
Views: 6,136
Message 3 of 8

Re: Yoga 900 - Auto Rotation not working / present

Sorry, bit of a noob. Could you explain how to correct this issue, or point me in the right direction? I can't believe such a fundamental part of the laptop could be left unresolved by Lenovo.... Smiley Sad
getdrunk
Paper Tape
Posts: 5
Registered: ‎04-04-2016
Location: DE
Views: 6,132
Message 4 of 8

Re: Yoga 900 - Auto Rotation not working / present

It was really a self-induced problem. I used a program called o&o12 that rendered the internal windows service called sensor monitoring service to be inactive. 

 

I don't exactly what you're problem is, but you have to check that the following services are running:

 

Sensor Data Service

Sensor Monitoring Service

Sensor Service

 

(check in the services window)

MattDN93
802.11n
Posts: 142
Registered: ‎02-13-2016
Location: Durban, ZA
Views: 6,126
Message 5 of 8

Re: Yoga 900 - Auto Rotation not working / present

If anyone is having a similar problem and the solution given doesn't fix it, I found the Lenovo bundled graphics drivers were causing black screen issues as well as these autorotate fails. Manually installing the Intel ones via device manager solved the problem for me. Hope that helps.

RJS2
Paper Tape
Posts: 2
Registered: ‎06-27-2016
Location: UK
Views: 5,908
Message 6 of 8

Re: Yoga 900 - Auto Rotation not working / present

Hi getdrunk,
I am having this problem also with my new Yoga 900. Can you tell me how I check that the listed services are running?
Cheers!
Rosamund
Highlighted
MattDN93
802.11n
Posts: 142
Registered: ‎02-13-2016
Location: Durban, ZA
Views: 5,903
Message 7 of 8

Re: Yoga 900 - Auto Rotation not working / present

Hi Rosamund,

I'd imagine to check the services, you would open the Services Control Panel. To do this, right-click the start button, click "Run" then type "services.msc" in the run dialog. Once the services screen opens you'll be able to scroll to the aforementioned Sensor services. Click on each one, then check the left panel for a link that says "Start this service" or "restart this service". You can also right-click the service, click properties and adjust the start of the service in detail. Hope that helps.
RJS2
Paper Tape
Posts: 2
Registered: ‎06-27-2016
Location: UK
Views: 5,882
Message 8 of 8

Re: Yoga 900 - Auto Rotation not working / present

Hi Matt,

Thanks so much for that, much appreciated.

In fact, I managed to find a solution before you responded.  Thought I'd describe it here in case anyone else comes across this thread when investigating the same problem:

I did 2 things then re-started the computer and the problem seems completely resolved (all buttons relating to Rotaton Lock have reappeared and are not greyed out when in Tablet Mode). Annoyingly I don't know which of these 2 was the solution:

- installed most uptodate Lenovo Transition driver from Lenovo website (as discussed in this thread: https://forums.lenovo.com/t5/Lenovo-Yoga-Series-Notebooks/Yoga-13-Auto-Rotate/td-p/913997)

- went to Settings -> Privacy -> Location and turned Location 'on'   (as suggested in a thread in another forum that I annoyingly cannot re-find now...)

 

Hope that (and/or Matt and getdrunk's suggestions) might help someone facing the same problem....

 

Check out current deals!


Shop current deals

Top Kudoed Authors