cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gaga
What's DOS?
Posts: 2
Registered: ‎11-28-2015
Location: United States
Views: 1,525
Message 1 of 3

Yoga 900 High System Interrupts Issue

Hi,

 

My Yoga 900 is exeperiencing some serious redundant cpu usage caused by System Interrupts. The percentage is usually around 10-19%. It is constant and never goes away.

 

I'vde done some research, and analysed what exactly is causing this cpu usage. It turned out to be "Intel® Serial IO host controller driver", specifically this: iaLPSS2i_I2C.sys.

The version installed is 30.63.1519.07.

In this link I can find other versions, but it's not clear why there are 5 separate "latest" versions, nor it can be understood if they can be used here.

Regardess, I tried version 1.3, and tere was no change. The driver did not get replaced either.

I also tried to remove the Intel Serial IO from Control Panel, but uninstalling it did not remove the driver at all. I am still getting about 15%  of CPU wasted by system interrupts.

 

Is this a known issue? What can I do to fix this?

 

I know this is a long shot, but I'd like to get a techincal response if possible. This is an ultrabook, and wasting resources is not helping the cause.

 

Thanks

Community SeniorMod
Community SeniorMod
Posts: 3,998
Registered: ‎01-21-2010
Location: US
Views: 1,507
Message 2 of 3

Re: Yoga 900 High System Interrupts Issue

Hi gaga and welcome to the community,

 

I'm not seeing this issue of high cpu usage, but I do see 4 usages of your same driver in the system components in Device Manager.  If you knew which of these is causing the high usage, you can disable it in Device Manager and see if it improves.

 

 

io driver1.png

 

Regards,

Dave


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so.
gaga
What's DOS?
Posts: 2
Registered: ‎11-28-2015
Location: United States
Views: 978
Message 3 of 3

Re: Yoga 900 High System Interrupts Issue

Apologies to resurrect this thread, but I found the solution. Updating BIOS to latest version (C6CN39WW), which was released a year after posting this issue, removed the system interrupt issue.

Thought I would share it, in case someone else needs it.

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors