Showing results for 
Search instead for 
Did you mean: 
Views: 96,996

In response to customer requests for BIOS with an AHCI option on several Yoga and Ideapad systems, Lenovo has provided Linux Only BIOS for the following models:


YOGA 900-13ISK2:

YOGA 900-13ISK for BIZ:

YOGA 900S-12ISK:

Ideapad 710S Plus-13ISK:

Ideapad 710S-13IKB:

Ideapad 710S-13ISK:


Please note the following:

  • This BIOS is not intended to be used on machines running Windows operating systems.
  • No official support is provided for this BIOS.
  • The user assumes the risk of any un-intended or performance degradation risks that may be associated with using this BIOS.


Was this information helpful?


This is GREAT! Thanks to Lenovo for responding to user requests.


I am not a beginner Linux user but not an expert either. Has anyone tried out this BIOS with the yoga 900SK? I can see that this BIOS is 'not intended to be used on machines running Windows' but does that mean you CAN'T have a dual boot arrangement? Or just that such an arrangement 'won't be supported'? 


I have dual boot on my Lenovo Yoga 900 13ISK2 following this steps:

Of course I've updated my BIOS

Then I've followed this steps to force windows to work with AHCI configuration

Then I changed from RAID to AHCI in bios and windows works fine.

Finally I installed Ubuntu as a normal installation and dual boot (with GRUB) works fine!


I hope that the procedure of installing Linux on similar devices is pretty much the same.


Thank you for these BIOS updates.


Is there a plan to also provide an update for the Yoga 910?


Yes, thanks for the support on this. I'd also like to know if we can expect a similar release for the Yoga 910. 


Thanks so much to julian165 for the detailed instructions! I followed your directions to the letter & I got further with the Ubuntu installation than I did before. But I am stuck when I get to the Installation type screen - it says 'This computer currently has no detected operating systems. What would you like to do?' The last option is 'Something else' but I'm nervous about messing around & wiping my Windows OS completely.


When I run gparted, I can see that Ubuntu recognizes the Windows basic data partition & it also lists the unformatted partition I created for linux. If Ubuntu recognizes the main Windows partition I don't know why it can't recognize the OS during the install.


I hate to be a pest ... but do you have any other suggestions?



Yes @ginabennett! That happens because windows partitions are using the whole disk. What I did to solve it is shrink the C: partition in windows. In my case was a 420Gb partition and I shrugged it to 300Gb so that gave me 120 Gb of free space to my ubuntu. I did it in Control Panel > System and Security > administrative tools > create and format hard disk partitions.

After this when I started again the Ubuntu installation, it works perfectly. Start the installation with unallocated space also helps you if you want to manually build your ubuntu partitions.

Sorry for not comment this earlier!



THANK YOU, julian165! I now have a nice dual boot system, everything working as it should. 


I talked with someone testing Linux on the Yoga 910. He confirmed the option to change from RAID to AHCI is present in the BIOS. Here is what he said about his experience:
    I am using that laptop right now with Fedora 24. The 4.9 kernel
when it comes out will contain my patch. For the time being, I have to
run a kernel that I compiled myself in order to use WiFi.

   In order for Linux to see the hard drive, you'll need to go to the
BIOS and change the hard drive mode to AHCI. You can access the BIOS by
pushing the tiny recessed button next to the power button when the
system is turned off.


   There are two annoying things that I've encountered with the laptop
so far:

1) In order to use the F keys, I need to hold down the Fn key. So in
   order to close a window, I need to press Alt Fn F4. The BIOS does not
   expose a way to change the hotkey behavior. One of my coworkers has
   a Yoga 900 and it has the option to change the hotkey behavior. I
   tried remapping the keys in GNOME, however the keypresses did not
   make it to user space. I tracked it down to the ideapad-laptop
   platform driver in the kernel eating the keypress. I attached a
   patch that I use to allows the F4 keypress to come through to
   userspace. I can then remap the key in GNOME to use Alt F4

2) I sometimes have issues with the laptop locking up when I lock the
   screen. When I come back to it, the fans will be at full speed and
   the system won't respond to any key presses. I haven't tried to see
   if the system is accessible over the network. For the time being,
   I turned off the auto lock screen feature. I can let it sit overnight
   with the lid closed (but not suspended) with no issues.
The battery life hasn't been great under Linux so far since I have the
power management disabled in the BIOS due to the locking up issue. It'll
easily last 3-4 hours like I have it configured right now.
   i915.enable_rc6=0 appears to have fixed the freezing issue
when the laptop screen is locked. I also previously had an issue
with lots of PCI warnings from the kernel. Adding the boot option
'pci=noaer' fixes the issue.


Anyone got the trackpad working 100% on Linux?  The double-tapping is not working. Otherwise it's working fine but it's annoying having to click the trackpad buttons when you're used to double-tabbing the trackpad.


I installed :






Double tapping is enabled in the synaptics settings.




Double tapping works very well for me in Ideapad 710s. The only thing I had to do is adding "/usr/bin/synclient TapButton3=2" to ~/.bashrc in order to emulate middle button copy-paste functionality. 


Being able to flash the BIOS and installing Linux in AHCI mode for the SSD is great. It works fine (for the 900-13ISK2 here) and one can get a working dual boot setup with GRUB, after WIndows has been "told" to use AHCI mode as well. However, I still have trouble to get the touchpad and touchscreen being recognized, even with the latest stable kernel 4.8. These devices are not even seen by the kernel in my (amd64) configuration. Any idea how to enable them ? It looks from the Windows panel that synaptics_i2c should be used for the touchpad - the module loads but without any effect. It would be great if Lenovo/Synaptics/Elantech would provide linux source code - or at least technical info for the drivers !


Unable to update the BIOS. Please help!!




Can I adk a question?I am trying to chrage my nexus 5x woth the usb c exist, but it does npt work. Sonebody knows why? Somebody was able to chrage? 


Ideapad 710S-13IKB:


this link is dead, i cannot download linux bios for 710S-13IKB


@mesmer, that link works for me. Were you successful in updating your bios ?


@Sreddy, were you able to fix that bios update problem you had ? What is your device ?


I've been watching this thread and this one for a while now and am tempted to bite the bullet and purchase a 710s to replace my embarassing Lenovo 3000 N100 running LXDE. Thanks to all those who have reported problems and solutions.



What's the difference between the 710s13 IKB & ISK ?  



Ignore the last question. ISK is i5 (Silver Lake) and IKB is i7 (Kaby Lake) processor.



@ Sreddy

For that BIOS update error -   go into your BIOS and enable "Bios Back Flash", it will then let you flash this new bios.




I have a Yoga 710 15isk 80U0 and want to run linux on it, does this update apply to this model? If not is there an alternative? I've tried many methods and always ran into the AHCI issue with my SSD when I tried installing; once I saw this post I thought it was the answer but I didnt see this model in the list. 


Greetings everybody,

I'm a new owner of a Yoga 900-131SK, which is the bios to use to enable AHCI ? I see no specific verson for this model. Should  I use the 700-131sk or 900 biz version?

Kind regrds, David.


I bought a Yoga 710 15ISK back in September and struggled to install various linux distributions on it until I came to realize what Lenovo had done. It looks like you have remedied the situation for the 900s and the Ideapads, is there another update on the way for the Yoga 710s? Please let me know.


If there are other workarounds, those would also do

Does the bios for Ideapad 710S-13ISK work with yoga 710-11isk? If not, when can we have the update for such laptop? Thsnk you for the information.

Kkzfowl and hgtuvn, I also bought a Yoga 710-15isk, and was successfully able to get Ubuntu on it using standard bios. What you need to do is enable legacy booting from USB drives in the bios. It takes a ton of time and rebooting to get ubuntu installed, and ever since I got it I have not been able to get back into windows since it seems that grub has made itself the default bootloader on both legacy(which is where ubuntu is installed) and UEFI(which is where windows is). Also, rebooting is very tough, as it takes me five or six reboots before I actually get into the system. I have been able to get in ocasionally with a mix of these grub options:




If you get ubuntu installed and figure out how to get back to Windows, please let me know!!

plunkinguitar Thanks for your input. The problem that you are facing is my concern after reading lots comments from other about installing ubuntu into yoga 710s with windows 10 pre-installed (using UEFI not normal BIOS). Today, I happen to read the below articles from ubuntu forum which having a lots useful information - i think. and I'm not sure the info can help you to resolve your issue but you might find it useful or can connect to some experts to help the booting problem. I hope we can have solution for installing linux on yoga 710s in near future. Good luck.

Any chance we'll see a BIOS update for Linux for the Yoga 910 soon?




Any luck on resolving issue for your yoga 710?

Just want to let you know that I successfully installed ubuntu mate 16.04.1 (64 bits) to my yoga 710-11isk in UEFI mode. I didn't need to update bios at all. Basic fuctions (touch screen, sound, video seem to work ok. I did update wifi drive for the pc (following the suggestions for linux forum). 


By the way, the ubuntu 16.10 and 16.04 didn't work when using the original bios (black screen when booting from usb). Hope info help. 


Please post compatible linux bios update for model 710S Plus-13IKB which runs Kaby lake processor too! You did it for the skylake model, please do it for the kaby lake model as well!


 When I first got my Yoga 900-131SK I created some unallocated dik space to prepare for a dual boot linux installation, I thought I would need a bios update to complete this and nothing more happened as I could not find one for this model. I did try a USB flash disk install of Linux Mint but had limited success due to lack of suitable drivers for mouse and screen touch.


Recently I tried a Ubuntu live disk and the Mint problems were not evident, everything seemed to just work. I could access the windows drive and there was an option to install Linux onto the empty space on my disk drive, I acecpted this and I now have a fully working dual boot Windows / Ubunto system.


The windows boot is unaffected by the new installation, to boot into Ubunto I need to press the small botton and then boot from the disk drive where a Grub menu is installed. A great fully working solution just as I wanted.


hth David.


What about model 710S Plus-13IKB ? Why is this model not included in the list? Smiley Mad


Hello, i seem to have run into an issue trying to revert to windows on my yoga 900 isk2 (because i now need it for work i need it to run windows). I tried to install the previous windows bios but because of it being a .exe it wouldnt run on linux. So i wiped the drive and installed win10, which worked fine although it would crash after awhile, then i proceeded to install the windows bios, but now it doesnt find any drive (i suppose cos its not in raid anymore..)

So basically, Im stuck, bring help


In reply to Frank102,


Hi, you can try using WINPE to boot up into desktop and run the previous bios exe file, this will take you back to where your system works in ahci mode.



I have the Y910-17ISK Ideapad and I also want to install linux on my machine (e.g. Ubuntu).


Can I use the same BIOS update Ideapad 710S ?

If not, is there any plans from Lenovo to provide a BIOS update for the Y910 as well?


Thanks in advance,




I'm running a 900S (12-ISK). I've been able to flash the Linux Only BIOS and enable AHCI mode. But I'm unable to install a new OS (either Windows or Linux) because the SSD can't be read in AHCI mode (media driver not found).


Is there a driver available that enables the SSD to support AHCI? Or otherwise some other solution? It seems ridiculous to allow the BIOS to be flashed to enable AHCI when that mode can't actually be used.


can i keeping futuer BIOS update after applied this BIOS?


Hello, is there a way i can load windows in raid again? I'm on the linux bios and wanted to revert, however if i change the sata controller on the bios (from ahci to raid) windows doesn't work, i'm guessing because it doesnt recognize the drive, but even when changing registry settings (to raid) or booting windows in safemode it still wont recognize it. 

If i could load windows in raid i could then update the bios to the main ("windows only") one. However if i were to do that with the current settings the new bios (which only has raid) wont recognize my drive and id be back to square one.