English Community

Lenovo NotebooksLenovo Yoga Series Notebooks
All Forum Topics
Options

3 Posts

11-15-2015

New Zealand

5 Signins

21 Page Views

  • Posts: 3
  • Registered: ‎11-15-2015
  • Location: New Zealand
  • Views: 21
  • Message 1 of 13

Yoga 900 automatic screen rotation

2015-11-15, 19:05 PM

I updated my new Yoga 900 with the massive new Windows 10 "Threshold 2" update, and the automatic screen rotation stopped working.

 

Any advice would be appreciated!

 

 

 

 

Reply
Options

2425 Posts

08-11-2014

IN

1941 Signins

27001 Page Views

  • Posts: 2425
  • Registered: ‎08-11-2014
  • Location: IN
  • Views: 27001
  • Message 2 of 13

Re: Yoga 900 automatic screen rotation

2015-11-16, 10:40 AM

Hi Lindsay1 ,           

     

Welcome to the Forums  

 

As per the query we understood that you are facing issue with automatic screen rotation

 

 

If you go to Control Panel -> Display-> Change Display Settings, you can uncheck "Allow Autorotate". Does this issue occurs in all application?

 

Let us know the result.

 

Best regards,         

 

Ashwin.S



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Options

3 Posts

11-15-2015

New Zealand

5 Signins

21 Page Views

  • Posts: 3
  • Registered: ‎11-15-2015
  • Location: New Zealand
  • Views: 21
  • Message 3 of 13

Re: Yoga 900 automatic screen rotation

2015-11-16, 19:47 PM

Hi Ashwin,

 

I've done what you suggest, but there's no "Allow Autorotate" check button visible in Change Display Settings.

 

The screen doesn't rotate when I put the laptop into tent mode - the screen views upside down. 

 

It's the same for all programs.

 

Thanks,

Lindsay

Reply
Options

3 Posts

11-15-2015

New Zealand

5 Signins

21 Page Views

  • Posts: 3
  • Registered: ‎11-15-2015
  • Location: New Zealand
  • Views: 21
  • Message 4 of 13

Re: Yoga 900 automatic screen rotation

2015-11-17, 1:52 AM

Hi Ashwin,

I've solved the problem, at least temporarily, by reverting back to Windows 10 Build 10240.

Regards,

Lindsay

Reply
Options

2425 Posts

08-11-2014

IN

1941 Signins

27001 Page Views

  • Posts: 2425
  • Registered: ‎08-11-2014
  • Location: IN
  • Views: 27001
  • Message 5 of 13

Re: Yoga 900 automatic screen rotation

2015-11-17, 7:11 AM

Hi Lindsay1,

 

I am glad to know that your query has been answered. Please feel free to post in Lenovo Community Forums if you have any further queries!

 

Did someone help you today? Press the star on the left to thank them with a Kudo!

 

Cheers!:smileyhappy:

 

Ashwin.S



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Options

1 Posts

11-27-2015

California

4 Signins

28 Page Views

  • Posts: 1
  • Registered: ‎11-27-2015
  • Location: California
  • Views: 28
  • Message 6 of 13

Re: Yoga 900 automatic screen rotation

2015-11-27, 4:12 AM

I was having same problem, and found the auto-rotate setting in: Control Panel -> Appearance and Personalization -> Display -> Screen Resolution.

Reply
Options

1 Posts

12-27-2015

United States

1 Signins

6 Page Views

  • Posts: 1
  • Registered: ‎12-27-2015
  • Location: United States
  • Views: 6
  • Message 7 of 13

Re: Yoga 900 automatic screen rotation

2015-12-27, 18:22 PM

I was having the same issue, but there was no auto-rotate option availale through windows 10.... as in, the auto rotate button was missing from the action center...no button in the display settings...or in any other place.

 

I later found that the autorotation feature was being turned off in the registry. I updated the registry and I have this functionality back. However, randomly (it seems) the issue returns. I don't know if it's a windows problem or hardware issue. However, I find that if the sensor present setting in the registry isn't set to 1, windows isn't going to recognize the hardware and turns off all buttons for auto rotate. 

 

Lenovo - please figure this out!

 

Here's the link to instructions on the fix i found.

 

http://www.eightforums.com/tutorials/30587-screen-autorotation-lock-unlock-windows-8-a.html

 

 

Reply
Options

10 Posts

11-15-2015

US

9 Signins

82 Page Views

  • Posts: 10
  • Registered: ‎11-15-2015
  • Location: US
  • Views: 82
  • Message 8 of 13

Re: Yoga 900 automatic screen rotation

2016-01-21, 2:04 AM

Just ran into this problem today as well. Hopefully it will get an official fix.

Reply
Options

10 Posts

11-15-2015

US

9 Signins

82 Page Views

  • Posts: 10
  • Registered: ‎11-15-2015
  • Location: US
  • Views: 82
  • Message 9 of 13

Re: Yoga 900 automatic screen rotation

2016-01-21, 2:07 AM
I'll also note that in my registry, Enable was already set to 1. Tried setting it to 0 and back to 1, but this had no affect. Cannot get autorotation to work at all.
Reply
Options

10 Posts

11-15-2015

US

9 Signins

82 Page Views

  • Posts: 10
  • Registered: ‎11-15-2015
  • Location: US
  • Views: 82
  • Message 10 of 13

Re: Yoga 900 automatic screen rotation

2016-01-21, 2:22 AM
Interesting. Fooled around with a bit more and found setting SensorPresent=1 made autorotate work again. Though it keeps setting Enable back to 0 every restart. And the "Rotation lock" icon on the right-side slide-out Action Center is disabled. And neither windows+O or the physical rotation lock button work anymore.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete