cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MP500
Blue Screen Again
Posts: 2
Registered: ‎07-16-2018
Location: US
Views: 695
Message 1 of 2

Yoga 910 Totally Dead

This morning when I woke my computer from hibernate, it automatically went into a windows update.  I left the room and when I came back, everything is dead.  Not sure where it got during the update.  There is no power at all.  The LED light does not work.  

 

Tried the following: 

Held the power button down for all different lengths of time up to 80seconds. 

I tested a different power supply and does not turn on / LED does not work.

I tested current power supply on a different Lenovo and the LED does light up on the other machine with the existing power supply.

Removed the battery and tried to turn on power cord only.  No LED light / no power.

Removed SSD along with battery removed and no LED light / could not turn on.

 

With the AC Adapter plugged in, tried the following: 

Before removing the battery, checked with a DMM.  No voltage was seen across the + / - wires.  
Only saw a reading when checking the red (+) and white wire.  Voltage fluctuates from ~ 1.9 to 3.0V.  

Checked various locations on the mother board and can read 5V near the left fan in the photo below.  
When measuring at the battery connector (with AC adapter plugged in), see the same voltage flucations ~ 1.9 to 3V across the red and white wires.

When measuring near the WiFi module, cannot pickup any voltage near that part of the MB.  

 

Has anyone had a similar issue where they cannot get power at all?   

 

There is a small chip near the power supply connection that is laser marked with the initial part of the part number X5PT2 which looks like an NX5P3090 USB PD and Type C power switch.  Just wondering if this could be causing the issue.  

 

Thanks in advance.  

 

 

 

IMG_20170209_14125419611.jpg

 

 

MP500
Blue Screen Again
Posts: 2
Registered: ‎07-16-2018
Location: US
Views: 630
Message 2 of 2

Re: Yoga 910 Totally Dead

Laptop is working again. 

 

It was unplugged for an additional 36 hours. When the power supply was plugged back in, the indicator LED started flashing (would not do this before) and it booted up again. 

 

Perhaps the laptop had to fully drain beforw whatever was hung would reset. Not sure, but it works again 

Check out current deals!


Shop current deals

Top Kudoed Authors