English Community

Lenovo NotebooksLenovo Yoga Series Notebooks
All Forum Topics
Options

1 Posts

12-16-2017

IL

1 Signins

16 Page Views

  • Posts: 1
  • Registered: ‎12-16-2017
  • Location: IL
  • Views: 16
  • Message 1 of 11

Yoga 910 sleep mode isn't working

2017-12-16, 23:37 PM

Hi,

My Yoga 910 is set to fall into sleep mode after a few minutes or when closing the lid - it doesn't in both.

I closed every open window, exit every program on the taskbar corner, unplugged the mouse and all USB ports, got into airplane mode and canceled battery saving mode and yet it does not work.

The laptop was formatted and the problem did not go away.

You can see in the pictures what's still on.

Thanks.

Reply
Options

4 Posts

03-07-2018

US

6 Signins

52 Page Views

  • Posts: 4
  • Registered: ‎03-07-2018
  • Location: US
  • Views: 52
  • Message 2 of 11

Re: Yoga 910 sleep mode isn't working

2018-03-07, 8:18 AM

Did anyone reply? I have the same issue. I have barely used this laptop and its nothing but annoying issues. What is the fix for this? All updates are up to date, it will not sleep when closing the lid or after alloted time and it dies shortly afterwards which is bad for business and travel. What is the solution? I have verified all settings in Windows as well. It also gets very hot despite the latest updates I found on another forum. Not happy with this laptop at all. Thanks!

Reply
Options

1 Posts

04-03-2018

US

1 Signins

20 Page Views

  • Posts: 1
  • Registered: ‎04-03-2018
  • Location: US
  • Views: 20
  • Message 3 of 11

Re: Yoga 910 sleep mode isn't working

2018-04-03, 0:40 AM

I have the same question, anyone?

Reply
Options

1785 Posts

12-13-2016

US

4512 Signins

43386 Page Views

  • Posts: 1785
  • Registered: ‎12-13-2016
  • Location: US
  • Views: 43386
  • Message 4 of 11

Re: Yoga 910 sleep mode isn't working

2018-04-03, 2:09 AM

I think a Windows Update wrecked my lid closing function. My 910 no longer will respond to the lid closing no matter the setting. I've simply taken to pressing the power button when I close it. Since this works fine for me, I haven't spent much time trying to troubleshoot the lid closing issue. I've set the power button to put the computer to sleep. It's not a solve, but it's a pretty simple workaround.


____________________________________
I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo. I love beer.
Reply
Options

7 Posts

11-30-2011

NO

10 Signins

92 Page Views

  • Posts: 7
  • Registered: ‎11-30-2011
  • Location: NO
  • Views: 92
  • Message 5 of 11

Re: Yoga 910 sleep mode isn't working

2018-04-22, 6:38 AM

I have the same issue. The screen turns off, but the laptop is still running. Consequently, the battery gets drained quickly. It is also a sequrity risk since my setting is to require login upon wake up from sleep. Now the screen is black after some time but no password is required to 'wake' the laptop. I must try to manually lock the laptop or use the  Windows/Power/Sleep menu.

 

Although beautiful on the outside, this laptop is full of problems:

1) Upon delivery it welcomed me with a 4GB update download and a blue screeen.

2) The loud fan noise issue. Luckily it has been adressed in an update, but required manual investigation and update (https://forums.lenovo.com/t5/Lenovo-Yoga-Series-Notebooks/Yoga-910-crazy-loud-fan-even-when-CPU-at-lt-35/m-p/3552229#M47982).

3) The hang and freeze while browsing issue. Solved after a lot of reading thanks to other users efforts (https://forums.lenovo.com/t5/Lenovo-Yoga-Series-Notebooks/Yoga-910-frequent-stutter-hang-especially-with-Chrome-browsing/m-p/3932506/highlight/true#M59872).

4) This combined not sleep / no password issue.

 

I am really tired of the problems, especially since this is a high end and axpensive laptop...

 

Reply
Options

1785 Posts

12-13-2016

US

4512 Signins

43386 Page Views

  • Posts: 1785
  • Registered: ‎12-13-2016
  • Location: US
  • Views: 43386
  • Message 6 of 11

Re: Yoga 910 sleep mode isn't working

2018-04-22, 12:56 PM

Something's keeping your computer from going completely to sleep. 

 

Open an elevated command prompt and, at the prompt, type 

 

powercfg /requests

 

..and press enter. That should give you a list of programs that are preventing your computer from going to sleep. 

 

I discovered the same thing a couple of nights ago. I walked off and left my 910 running. Normally, it'll go to sleep in 10 minutes and hibernate in an hour. Got up to find that, like yours, screen was off but computer wasn't asleep. Culprit turned out to be Google Chrome. Somehow, Chrome had set itself to not only launch on startup, but continue running in the background after close. Changed a couple of settings in Chrome and all is now well.

 

 


____________________________________
I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo. I love beer.
Reply
Options

7 Posts

11-30-2011

NO

10 Signins

92 Page Views

  • Posts: 7
  • Registered: ‎11-30-2011
  • Location: NO
  • Views: 92
  • Message 7 of 11

Re: Yoga 910 sleep mode isn't working

2018-04-22, 18:46 PM

Thanks for the tip, that's somewhere to start the investigation. Btw. I did not mention that I have disabled all 'wake on...' activities.

 

The output from the command:

 

PS C:\WINDOWS\system32> powercfg /requests
DISPLAY:
None.

SYSTEM:
[DRIVER] Realtek High Definition Audio(SST) (INTELAUDIO\FUNC_01&VEN_10EC&DEV_0299&SUBSYS_17AA3801&REV_1000\4&22e7f418&0&0001)
An audio stream is currently in use.

AWAYMODE:
None.

EXECUTION:
None.

PERFBOOST:
None.

ACTIVELOCKSCREEN:
None.

ACTIVELOCKSCREEN:
None.

 

Does it make sense? I thought about Cortana, but all voice actions were already disabled. Any suggestions?

 

[UPDATE]

Searching for the driver message found this link:

https://www.reddit.com/r/Windows10/comments/7y1b63/realtek_audio_driver_prevents_laptop_from/

 

With a solution pointing to this comment:
https://superuser.com/questions/954867/keep-the-realtek-application-off-my-computer-in-windows-10#comment1902542_954867

 

Copied below:
Here's how to permanently get rid of the Realtek driver: ① disable, disconnect or unplug any internet connection to prevent Windows from reinstalling the driver, ② uninstall "Realtek High Definition Audio Driver" and restart to make sure it's gone, ③ go to C:\Program Files and create a new folder called "Realtek", ④ open the properties dialog, go to the "Security" tab and click on "Advanced", ⑤ click on "Change Permissions", then "Disable inheritance", and in the new dialog select "Remove all inherited permission from this object", ⑥ click on "OK" and "Yes" etc. to apply the changes. – Livven Jan 16 at 23:02

 

This actually seem to have solved the issue! And the sound is still there :) I will see how it goes for the next couple of days. Perhaps finally everything will work as it is supposed to!

 

Thanks again for the tip! 

 

New output:

PS C:\WINDOWS\system32> powercfg /requests
DISPLAY:
None.

SYSTEM:
None.

AWAYMODE:
None.

EXECUTION:
None.

PERFBOOST:
None.

ACTIVELOCKSCREEN:
None.

Reply
Options

1785 Posts

12-13-2016

US

4512 Signins

43386 Page Views

  • Posts: 1785
  • Registered: ‎12-13-2016
  • Location: US
  • Views: 43386
  • Message 8 of 11

Re: Yoga 910 sleep mode isn't working

2018-04-22, 19:25 PM

Yeah, something's not letting go of the audio driver.  Cortana is usually the culprit. You might also check Chrome (if you use it) and make sure it's set to NOT continue in the background after it's closed.  Open Settings in Chrome and navigate to Advanced Settings and look for "Continue running apps when Chrome is closed." Set that to "off." 

 

Now, if it still fails after doing those, you can use the nuclear option. Open an elevated command prompt and enter

 

powercfg -REQUESTSOVERRIDE DRIVER "Realtek High Definition Audio(SST)" SYSTEM

 

I think I have that right. This will tell the system to ignore the realtek driver when going to sleep/hibernate/etc. Naturally, create a System Restore point and backup the computer before doing anything. 


____________________________________
I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo. I love beer.
Reply
Options

7 Posts

11-30-2011

NO

10 Signins

92 Page Views

  • Posts: 7
  • Registered: ‎11-30-2011
  • Location: NO
  • Views: 92
  • Message 9 of 11

Re: Yoga 910 sleep mode isn't working

2018-04-22, 19:30 PM

Thanks for the effort. See the solution in my previous comment!

Reply
Options

7 Posts

11-30-2011

NO

10 Signins

92 Page Views

  • Posts: 7
  • Registered: ‎11-30-2011
  • Location: NO
  • Views: 92
  • Message 10 of 11

Re: Yoga 910 sleep mode isn't working

2018-04-26, 10:26 AM

I am sad to report that the issue is still not solved :(

 

The driver reinstalls itself repeatedly. I have also tried the "nuclear" option that you mentioned, and variants of it from this thread: https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_devices-insiderplat_pc/high-definition-audio-device-audio-stream-is/f3d7ef5e-ee78-4027-8635-46f0a9355505?auth=1 

 

However, still no permanent success. Perhaps I will try some more during the weekend...

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save