Showing results for 
Search instead for 
Did you mean: 
Blue Screen Again
Posts: 2
Registered: ‎03-21-2018
Location: NO
Views: 596
Message 1 of 4

Yoga 910 stuck in Conservation Mode (software blocking charging)

Greetings, I have confirmed that I have some software related setting that blocks my 1-year-old Yoga 910 from charging.


This was not a problem from before. Today, I got my Yoga 910 back from service. (replaced SSD under warranty) and thus I have a fresh Win 10 1709 installation.


Problem: The computer does not charge while plugged in and turned on.

1. In Windows: Shows as "Plugged in - Not Charging".

2. Turned off: When computer is left plugged in and turned off it will charge fine. 


I have tried:

1. In Vantage:  Does not state that the Conservation Mode is enabled, and I have tried toggling this back and forth while plugging and unplugging the charger - No change.

2. I rolled back to "Lenovo Settings" and used it in Flightmode (so that it would not ask me to switch to Vantage), to no avail. The setting there too is off, and toggling it back and forth do not change anything.


AFAIK, it is only Dell and Lenovo that ship computers with this kind of software, and since I have a fresh installation of Windows, and it charges when I have it shut-off; This must be Lenovo Software Related. 

I can even sense it is some kind of software, because immediately after boot it still shows that it is actually charging, but suddenly it stops. Probably after loading some of the Lenovo services.


I am at a loss. I find some threads about the topic, but no solutions.

The power settings in Windows is "Balanced", that is the only profile I have available. I saw some threads about a Lenovo Energy Management Profile under advanced power settings. I have not seen this.


I would really appreciate some help. I do use my laptop alot on the go, and this will become great annoyance for me.



Best regards,




Community Moderator
Community Moderator
Posts: 1,569
Registered: ‎12-13-2016
Location: US
Views: 587
Message 2 of 4

Re: Yoga 910 stuck in Conservation Mode (software blocking charging)

What percentage charge does it show the battery having when you see "plugged in, not charging?"  If it's over 90%, that's actually normal.


If not, you may need to either reset the CMOS or remove and reinstall Lenovo's ACPI from Device Manager.


Start by updating all the drivers and the BIOS.  Sometimes, that's all you need. Use Vantage. 


Next, clear the CMOS..

For the 910, since removing the battery isn't easy to do..

Press and hold the power button for a full minute after it shuts off. Then restart it and see if that resolves the issue.


If not, follow the directions for uninstalling and reinstalling the ACPI

This is from a Microsoft page. You're dealing with Lenovo's ACPI


Microsoft ACPI Compliant Control Method Battery listing

  1. Click Start and type device in the search field, then select Device Manager.
  2. Expand the Batteries category.
  3. Under the Batteries category, right-click the Microsoft ACPI Compliant Control Method Battery listing, and select Uninstall.
    • You may see more than one
    • WARNING: Do not remove the Microsoft AC Adapter driver or any other ACPI compliant driver.
  4. On the Device Manager Taskbar, click Scan for hardware changes.
    • Alternately, select Action > Scan for hardware changes.
  5. Windows will scan your computer for hardware that doesn't have drivers installed, and will install the drivers needed to manage your battery's power. The notebook should now indicate that the battery is charging.



I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo. I love beer.
Blue Screen Again
Posts: 2
Registered: ‎03-21-2018
Location: NO
Views: 543
Message 3 of 4

Re: Yoga 910 stuck in Conservation Mode (software blocking charging)

@Doctordon, thank you for your response!


Unfortunatly, this did not solve the problem.


- I did first clear the CMOS as you said. Holding for a good minute, at periodic intervals the battery icon blinked in response to holding down the power button.

- Secondly, I tried to reinstall MS ACPI and "look for new hardware".

- Finally, I also tried uninstalling the MC ACPI, and rebooting. Windows found the driver at start-up, but problem persists.


I have confirmed that it does not charge at 67 %. When I tested this, the charge was 89 %,


EDIT: I just let it discharge while watching a movie. It does not charge the computer while in Windows at 0 % either, so it is something stuck a level below "Conservation Mode" I reckon...


Another thing I notice, the %-meter only updates when waking the computer. It will not update/fall through regular use when in battery mode, consequently it just went straight to 0 % and died without giving any notice or hibernating. 



Best regards, 




What's DOS?
Posts: 1
Registered: ‎03-28-2018
Location: US
Views: 498
Message 4 of 4

Re: Yoga 910 stuck in Conservation Mode (software blocking charging)

Hi, did you solve this problem? I have exactly the same issue, and it appears exactly on 21st March, as you described. 


First I was thinking my charger is broken, but it seems it has nothing to do with it. 


Thank you!

Check out current deals!

Shop current deals

Top Kudoed Authors