cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Gbrayden
Fanfold Paper
Posts: 29
Registered: ‎08-13-2017
Location: US
Views: 1,079
Message 1 of 8

Yoga 920 sleep mode problems

When my Lenovo Yoga 920 is in sleep mode I have two problems which are probably related. 

 

The bluetooth doesn't turn off. All my devices will stay connected to the bluetooth. 

This can be really annoying because when I need to use a bluetooth device it will connect to my laptop which is not in use before I can get it to connect with my phone or other device. 

 

The other problem is my battery drains too fast when in sleep mode. With my other laptops you could hardly see the battery drain. And this one it drains like 10 percent a day in sleep mode. I am sure the bluetooth probems is mostly to blame. 

 

Is there any way to turn this feature off? When I shut the lid and it goes to sleep, I want it to be fully asleep.

Grazuncle9
Punch Card
Posts: 30
Registered: ‎06-15-2018
Location: GB
Views: 1,056
Message 2 of 8

Re: Yoga 920 sleep mode problems

I'm sure I have seen option like, allow this facility to power down or go to sleep.. WiFi comes to mind. 

I'll try and find it. 

Gbrayden
Fanfold Paper
Posts: 29
Registered: ‎08-13-2017
Location: US
Views: 1,047
Message 3 of 8

Re: Yoga 920 sleep mode problems

I have found an option to stay connected to the wifi while in sleep mode but not for the bluetooth. 

Community Moderator
Community Moderator
Posts: 1,314
Registered: ‎12-13-2016
Location: US
Views: 1,040
Message 4 of 8

Re: Yoga 920 sleep mode problems

There are a couple of things you can do. The easiest - which would cut your battery drain as well as the BT radio - would be to change the lid closing behavior to "hibernate" instead of sleep. As fast as the 920 is, it doesn't take it terribly long to boot up to begin with, let alone from hibernate.  And it appears you're letting the computer stay in Sleep for a long time. (I only use Sleep if I know I'm going to open it back up in 10-15 minutes, such as when they call my zone for boarding the plane. Anything longer than that and I generally go with hibernate. 

 

Win+X > Power Options

Image01

 

Then click on "Change what closing the lid does"

 

Image02

 

...and choose "hibernate." 

 

Image03

 

You can also change it under "plugged in" if you like. Or leave it to where it just sleeps when plugged in as battery drain isn't an issue, then.

 

The other thing you can do is go into Win+X > Device Manager > Bluetooth.  Right click on your Qualcomm Atheros bluetooth device and choose "properties." Under the "power management" tab, check "allow windows to turn off this device to save power."  While that should turn off the BT radio during sleep, the computer will still use power as the sleep function keeps the computer's state active, requiring power. Hibernate writes the computer's state to disk, requiring no power. 


____________________________________
I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo. I love beer.
Gbrayden
Fanfold Paper
Posts: 29
Registered: ‎08-13-2017
Location: US
Views: 1,034
Message 5 of 8

Re: Yoga 920 sleep mode problems

Thanks for the reply. 

 

I have been using your first method of changing it to hibernate. 

 

I just tried your second method and the box that allows the computer to turn off the bluetooth was already checked. 

Community Moderator
Community Moderator
Posts: 1,314
Registered: ‎12-13-2016
Location: US
Views: 1,028
Message 6 of 8

Re: Yoga 920 sleep mode problems

Stick with the first method, then. Especially if you're leaving it to sit for long periods of time. Sleep is best for short pauses, such as changing offices, boarding planes, etc.


____________________________________
I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo. I love beer.
Gbrayden
Fanfold Paper
Posts: 29
Registered: ‎08-13-2017
Location: US
Views: 1,026
Message 7 of 8

Re: Yoga 920 sleep mode problems

That's the plan for now. Thanks for your help.

The annoying part is even if I forget about battery life and just use sleep mode for short pauses. It still takes over all my bluetooth devices in my home.

Everytime I turn on any bluetooth device it instantly connects to the laptop.

I dont mind having this constant connect feature available, but there should be a switch in Lenovo vantage yo control it.
Community Moderator
Community Moderator
Posts: 1,314
Registered: ‎12-13-2016
Location: US
Views: 1,015
Message 8 of 8

Re: Yoga 920 sleep mode problems

There might be. I'll dig into it later. Meanwhile, there's always Airplane Mode. Smiley Very Happy Hit that key before sleep and you won't have to worry about that. 


____________________________________
I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo. I love beer.

Check out current deals!


Shop current deals

Top Kudoed Authors