cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
inveritas
Paper Tape
Posts: 2
Registered: ‎02-22-2019
Location: SG
Views: 539
Message 1 of 3

Yoga C930 - Ghost inputs on active pen

I recently purchased the Yoga C930 and am having some issues with the active pen.

 

Video: https://www.youtube.com/watch?v=-3NiRGB3zVk

 

When I am writing or drawing, the screen will freeze momentarily and a line (sometimes straight, sometimes curved) will appear across the screen, as if there was an accidental touch input. This happens once a minute or so and has made it impossible to use the pen to take notes or draw.

 

I initially thought it was a palm rejection issue, but the random pen inputs occur at random areas on the screen where I am not touching. 

 

I have tried:

  • Reinstalling Windows from a USB stick
  • Cleaning my screen to make sure it's not a foreign object causing the input
  • Static discharging my laptop
  • Activating and deactivating palm rejection in Windows settings
  • Reinstalling the Lenovo Pen application and Wacom drivers
  • Windows update and pen firmware update (both through Lenovo website and device manager)
  • Updating other firmware (BIOS / graphic drivers)
  • Changing pen sensitivity settings in Lenovo Pen app
  • Using different apps (Sketchpad, penbook, paint, illustrator)

Nothing seems to work - anyone has this problem and/or solved it? Thank you.

inveritas
Paper Tape
Posts: 2
Registered: ‎02-22-2019
Location: SG
Views: 527
Message 2 of 3

Re: Yoga C930 - Ghost inputs on active pen

Update: I may have found the solution, which is to uninstall the Lenovo Pen app. The glitching stopped and the pen input became more responsive.

Of course, gone is the battery indicator and also the radial menu feature, but at least the pen is usable now.
eshudnow
What's DOS?
Posts: 1
Registered: ‎03-18-2019
Location: US
Views: 314
Message 3 of 3

Re: Yoga C930 - Ghost inputs on active pen

I have the same problems with a Lenovo C930 I just bought yesterday. How have things gone now that you have uninstalled the app?  Talking with Lenovo support right now and they want to send me a new pen. I tried uninstalling the Lenovo Pen App but the problem still happens for me.

 

Check out current deals!


Shop current deals

Top Kudoed Authors