Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo Yoga Series Notebooks
All Forum Topics
Options

4 Posts

12-03-2019

United States of America

9 Signins

72 Page Views

  • Posts: 4
  • Registered: ‎12-03-2019
  • Location: United States of America
  • Views: 72
  • Message 21 of 41

Re:Yoga C940 Overheating in Sleep Mode

2021-02-23, 7:03 AM

@stsh That warranty bit is just being optimistic. I'm sure it works in some countries; where I'm from, this has user error plastered all over it.

Reply
Options

6 Posts

02-22-2021

United States of America

4 Signins

40 Page Views

  • Posts: 6
  • Registered: ‎02-22-2021
  • Location: United States of America
  • Views: 40
  • Message 22 of 41

Re:Yoga C940 Overheating in Sleep Mode

2021-02-23, 16:32 PM

@ woodsielord wrote:

@stsh That warranty bit is just being optimistic. I' sure it works in some countries; where I' from, this has user error plastered all over it.

I think we're in the same country and It is a bit optimistic, but what choice do we have unless lenovo decides to add the s3 sleep mode back to their firmware? You simply have no way to control modern sleep. All of these registry "fixes" and powercfg commands don't do a thing to it. All you can do with it is disable it and have no standby mode at all. 

 

Reply
Options

38 Posts

02-02-2014

Canada

56 Signins

413 Page Views

  • Posts: 38
  • Registered: ‎02-02-2014
  • Location: Canada
  • Views: 413
  • Message 23 of 41

Re:Yoga C940 Overheating in Sleep Mode

2021-02-24, 2:33 AM

@ stsh wrote:

@ woodsielord wrote:

@stsh That warranty bit is just being optimistic. I' sure it works in some countries; where I' from, this has user error plastered all over it.

I think we' in the same country and It is a bit optimistic, but what choice do we have unless lenovo decides to add the s3 sleep mode back to their firmware? You simply have no way to control modern sleep. All of these registry "fixes" and powercfg commands don' do a thing to it. All you can do with it is disable it and have no standby mode at all. 

 

 

Using the registry edit I posted restores S3 when it disables S0 on my 15" C940 9750h, no problem. Wakes up from sleep a little slower but that's about it.

Reply
Options

6 Posts

02-22-2021

United States of America

4 Signins

40 Page Views

  • Posts: 6
  • Registered: ‎02-22-2021
  • Location: United States of America
  • Views: 40
  • Message 24 of 41

Re:Yoga C940 Overheating in Sleep Mode

2021-02-24, 2:58 AM
nice. must be the difference in hardware. on mine powecfg shows just hibernation and everything else not supported by firmware regardless of the s0 state.
Reply
Options

1 Posts

03-04-2021

United States of America

1 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎03-04-2021
  • Location: United States of America
  • Views: 0
  • Message 25 of 41

Re:Yoga C940 Overheating in Sleep Mode

2021-03-04, 22:41 PM

I've had this problem with two different 940's, what I've found is that if I turn off intelligent cooling, it seems to solve the problem. I've had my current unit for months and recently did the firmware update. After the update it happened again and on reboot I checked and found that intelligent cooling was on again. Recently it did it another time and on checking intelligent cooling was once again on (don't know how that happened). So I've had this laptop for several months without it happening and in the last week it happened twice and both times intelligent cooling had been switched on.

 
Reply
Options

1 Posts

04-17-2021

United States of America

1 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎04-17-2021
  • Location: United States of America
  • Views: 15
  • Message 26 of 41

Re:Yoga C940 Overheating in Sleep Mode

2021-04-17, 13:55 PM

Well...same experience.   Sleep mode is not sleeping- It’s overheat mode.   And it’s significant, crucial overheat.  My laser thermometer showed it at 160 degrees and at the battery 181 degrees after appearing “off” sitting on a desk, plugged in.   There is no safe product that should ever achieve temperatures at this level.

(Medium rare steak is 135 degrees).        After a bout in the freezer- it turned back on.  Last night same- I closed the screen onto the keyboard. Plugged in to charge overnight and went to bed.  I awoke to the smell of hot electronics/plastic only to find yet again- the Yoga “closed” and no fans running- was exceptionally hot.

LENOVO- THIS IS A SAFETY RECALL ISSUE.   FIRE ?  BURNS?  Equipment damage?  Shorten battery life?  Shorten equipment life?  I spent a month researching and now very disappointed in no solution other than “I” have to disable sleep mode?  

 

Reply
Options

38 Posts

02-02-2014

Canada

56 Signins

413 Page Views

  • Posts: 38
  • Registered: ‎02-02-2014
  • Location: Canada
  • Views: 413
  • Message 27 of 41

Re:Yoga C940 Overheating in Sleep Mode

2021-04-17, 21:21 PM

@ CKLenovo wrote:

Well...same experience.   Sleep mode is not sleeping- It’s overheat mode.   And it’s significant, crucial overheat.  My laser thermometer showed it at 160 degrees and at the battery 181 degrees after appearing “off” sitting on a desk, plugged in.   There is no safe product that should ever achieve temperatures at this level.

(Medium rare steak is 135 degrees).        After a bout in the freezer- it turned back on.  Last night same- I closed the screen onto the keyboard. Plugged in to charge overnight and went to bed.  I awoke to the smell of hot electronics/plastic only to find yet again- the Yoga “closed” and no fans running- was exceptionally hot.

LENOVO- THIS IS A SAFETY RECALL ISSUE.   FIRE ?  BURNS?  Equipment damage?  Shorten battery life?  Shorten equipment life?  I spent a month researching and now very disappointed in no solution other than “I” have to disable sleep mode?  

 

 

Read my post about disabling S0 and getting S3 sleep mode back.

Reply
Options

8 Posts

09-19-2020

United States of America

9 Signins

65 Page Views

  • Posts: 8
  • Registered: ‎09-19-2020
  • Location: United States of America
  • Views: 65
  • Message 28 of 41

Re:Yoga C940 Overheating in Sleep Mode

2021-04-27, 21:27 PM

Ok update a few months later:

 

I have it set to hibernate when I close the lid and just make sure to NEVER leave it plugged in unattended, which is annoying and not ideal and it pisses me off every time I check this thread to see if there have been any other fixes, but I don't see any other option. 

 

A new issue has arisen however, which perhaps is related?

 

As I said, I never leave it charging unattended, so what I'll do is have it plugged in while I'm using it and when I'm done for the day I'll unplug it and set it on my desk, with a FULL charge. Every once in a while when I open it up the next day to use it, the battery is fully drained. 

 

Not sure how this possible since I have it set to hibernate, have disabled sleep timers, etc. For all I know it could be heating itself up, and draining the battery, as this happens when I have it unattended in another room, usually overnight. 

 

Like I've said previously, the laptop works great for my needs in every other way, but this is still VERY worrisome. 

Reply
Options

11350 Posts

08-17-2015

Slovakia

26926 Signins

591608 Page Views

  • Posts: 11350
  • Registered: ‎08-17-2015
  • Location: Slovakia
  • Views: 591608
  • Message 29 of 41

Re:Yoga C940 Overheating in Sleep Mode

2021-05-07, 14:26 PM

Hi all,

 

I'm sorry to hear that you are experiencing an this symptom with your machine. As noted by marakalastic, the symptom could be very likely caused by modern standby:

 

@ marakalastic wrote:

PSA to everyone experiencing this issue which should be every owner of this laptop as its a Window' feature.

 

Look up disabling "Modern Standby" or S0, that' what' causing the issue and should just require a registry edit to disable S0 and enable S3.

 

Open command prompt in admin mode and enter reg add HKLM\\\\ /v PlatformAoAcOverride /t REG_DWORD /d 0

Remove this entry in regedit to regain modern standby (although not sure why you' want to cook your laptop TBH. 

 

This issue is affecting most Dell', Lenovos, and I believe Acers or Asus laptops, spread this as its clear the manufacturers are not interested in fixing this. 

 

Please note, that the modern standby sleep state is not meant for transporting your laptop in a backpack or similar enclosed space. In such case, you need to either use hibernate or fully shut down the machine, as noted in many other discussions in connection with modern sleep state around the web. If you are encountering high laptop temperatures even while the machine is sitting on a desk during the whole time and experience issues with turning it back on after modern sleep state, I would strongly recommend getting in touch with our support to have your machine diagnosed and examined by our technicians at service.

 

Best regards,

 

Juraj
German, Czech & Slovak Community Lead


EN : Welcome to the Community! Have you already participated in the forum survey? Please, let us know what you like about our forum and what we can improve. We listen to your feedback!

DE : Willkommen in der Community! Hatten Sie bereits an der Foren Umfrage teilgenommen? Wir benötigen die folgenden Informationen. Wir hören zu und lesen Ihre Kommentare gerne!

CZ/SK : Vítejte v Komunitě! Už jste se zúčastnili našeho průzkumu fóra? Potřebujeme následující informace. S radostí posloucháme a čteme vaše komentáře!
_
Communities: English Deutsch Español Portugues Русскоязычное Česká Slovenská Українська Moto English
_

Reply
Options

12 Posts

10-30-2020

United States of America

19 Signins

75 Page Views

  • Posts: 12
  • Registered: ‎10-30-2020
  • Location: United States of America
  • Views: 75
  • Message 30 of 41

Re:Yoga C940 Overheating in Sleep Mode

2021-05-14, 23:55 PM

Your registry command worked for me as well on a Lenovo Yoga C940 15"! Thanks so much!

 

I typed: reg add HKLM\System\CurrentControlSet\Control\Power /v PlatformAoAcOverride /t REG_DWORD /d 0

in an administrator cmd window and now the fan turns off properly and the system enters S3 just like it should.

You can check the currently supported modes using: powercfg /a

And the following will show up:

 

The following sleep states are available on this system:
    Standby (S3)
    Hibernate
    Hybrid Sleep
    Fast Startup

The following sleep states are not available on this system:
    Standby (S1)
        The system firmware does not support this standby state.

    Standby (S2)
        The system firmware does not support this standby state.

    Standby (S0 Low Power Idle)
        The system firmware does not support this standby state.

 

Which indicates the system actually does go into S3 instead of S0. This just saved me from a lot of trouble, thanks!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms