cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
schogobong
Paper Tape
Posts: 5
Registered: ‎01-11-2018
Location: CH
Views: 550
Message 1 of 9

Yoga920 Palm Rejection not working

Hi,

 

I recently purchased 2 Yoga 920s from Lenovo. On one of them I am having serious issues with palm rejection and none of the solutions I can find on the various forums seem to resolve my issue.

 

When writing (e.g. in One Note) and resting my palm on the screen, the cursor keeps "jumping" between my palm and the tip of the pen. This leads to any of the following behaviors:

- Not writing at all (e.g. Hello turns into H    l  o)

- "writing" where my palm is located

- doing some freaky stuff and just creating random lines in the area of my palm and pen

 

 

How could I resolve this issue?

Social Support Agent
Social Support Agent
Posts: 139
Registered: ‎08-01-2018
Location: PH
Views: 523
Message 2 of 9

Re: Yoga920 Palm Rejection not working

Hi schogobong! 

 

Welcome to the community forums! 

 

See first the settings of your laptop, go to settings-bluetooth-pen and ink. There is a toggle that says, "Ignore touch screen when I'm using my pen."

 

If that didn't fix the problem, see the solution from this forum thread: [https://forums.lenovo.com/t5/Lenovo-Yoga-Series-Notebooks/Lenovo-yoga-920-pen-problems/td-p/3939531].

Let us know if that works.

 

Regards,

Matt_lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

schogobong
Paper Tape
Posts: 5
Registered: ‎01-11-2018
Location: CH
Views: 519
Message 3 of 9

Re: Yoga920 Palm Rejection not working

Hi Matt,

Thanks for the kind words.

 

I tried both these things before posting here. The setting you mentioned is active, holding the pen differently did nothing.

 

Thanks for your support!

schogobong
Paper Tape
Posts: 5
Registered: ‎01-11-2018
Location: CH
Views: 489
Message 4 of 9

Re: Yoga920 Palm Rejection not working

Does anybody have any other ideas? Because one of the main reasons for buying this laptop has been to use it both as a laptop as well as for digital note taking with a pen. This issue renders it pretty much useless unfortunately.

Social Support Agent
Social Support Agent
Posts: 98
Registered: ‎08-02-2018
Location: US
Views: 485
Message 5 of 9

Re: Yoga920 Palm Rejection not working

We've checked the touchpad driver and it can only be updated through Windows update and it doesn't have a standalone driver.

 

Having said that, there's no option to change the settings aside from the "Ignore touch screen when I'm using my pen."

 

If that is already activated and the issue still remains, you can use a third party software called TouchFreeze to automatically disables the touchpad while you are typing in text. However, since this is a third party software, we cannot guarantee it's full functionality.

 

Regards,



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

schogobong
Paper Tape
Posts: 5
Registered: ‎01-11-2018
Location: CH
Views: 482
Message 6 of 9

Re: Yoga920 Palm Rejection not working

I assume this has nothing to do with the touchpad, as the issue is between the pen and the hand touching the screen.

 

If there is nothing else that can be done from Lenovo's side. What can be done? ^^ Because this isn't really what I wanted / paid for.

Social Support Agent
Social Support Agent
Posts: 98
Registered: ‎08-02-2018
Location: US
Views: 473
Message 7 of 9

Re: Yoga920 Palm Rejection not working

Sorry for the confusion. Since you've mentioned that you have another Yoga 920, does the same issue happen when using the Pen on the other unit?

 

Also, please try to Disable the touchscreen driver to isolate if this is a hardware or software issue with the touchscreen panel. Go to device manager > Human interface devices> right click on HID -compliant touch screen >Disable.

 

Once done, try to use the Pen and see if the issue will remain.

 

Regards,



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

schogobong
Paper Tape
Posts: 5
Registered: ‎01-11-2018
Location: CH
Views: 413
Message 8 of 9

Re: Yoga920 Palm Rejection not working

Thank you for your suggestion and sorry for the delay - the laptop that is experiencing issues is my sister's (not living at the same place), so I have limited opportunities to test things.

 

I finally got a chance to disable the touchscreen. Unfortunately, the issues persist.

 

The other unit (mine) does not have the same issue (at least I haven't experienced the issue so far).

K-007
Paper Tape
Posts: 1
Registered: ‎03-09-2017
Location: US
Views: 229
Message 9 of 9

Re: Yoga920 Palm Rejection not working

Any update on this?  I tried all that and still having issue. 

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors