Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo Yoga Series Notebooks
All Forum Topics
Options

19 Posts

05-13-2018

Germany

26 Signins

221 Page Views

  • Posts: 19
  • Registered: ‎05-13-2018
  • Location: Germany
  • Views: 221
  • Message 1 of 7

eGPU Docking error - keeps connecting and directly disconnecting

2021-02-18, 17:51 PM

Hello everyone,

 

I have a problem with my new Lenovo Yoga 7 Slim 14ITL05 and my Gigabyte Gaming Box with a RX 5500XT.

Whenever I try to connect the eGPU it will connect, laptops get charged by it, AMD driver will recognize the card, but then it will directly disconnect - just to reconnect and so on in a loop until sometime there will occassionally be a BSOD due to driver-errors after all this hotplugging.

 

The eGPU works wonderful with a older Zenbook 3 Deluxe, that I unfortunately have to return for another reason.

 

I am on Windows 10 20H2 19042.804, newest BIOS firmware and Thunderbolt drivers installed. I have tried to deactivate virtualization features in the BIOS, as I've read that this might solve the problem - without any difference in behaviour.

Reply
Options

4397 Posts

11-04-2019

United States of America

354 Signins

33652 Page Views

  • Posts: 4397
  • Registered: ‎11-04-2019
  • Location: United States of America
  • Views: 33652
  • Message 2 of 7

Re:eGPU Docking error - keeps connecting and directly disconnecting

2021-02-18, 20:21 PM

 

Hello @Astfgl!

 

Nice to have you here!

 

Can you please provide us the Yoga Slim 7's MTM (machine type-model) number for us to check its specifications?

We'll be waiting for your response.


Thanks,

Adriel_lenovo

Lenovo Support

 



Did someone help you today? Press the thumbs-up icon below to thank them.!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
This will help the rest of the Community with similar issues identify the verified solution and benefit from it.


Using Browser Search to find your answers in Lenovo and Moto Community
<

Reply
Options

19 Posts

05-13-2018

Germany

26 Signins

221 Page Views

  • Posts: 19
  • Registered: ‎05-13-2018
  • Location: Germany
  • Views: 221
  • Message 3 of 7

Re:eGPU Docking error - keeps connecting and directly disconnecting

2021-02-19, 7:38 AM

I think you mean this one, right? 82A3002RGE - it's the Lenovo Slim 7 with i7-1165G7 & 16 GB RAM

 

And btw. weirdly enough it briefly worked for a short time. I was able to use the eGPU and its graphic cards until I disconnected and restarted the notebook. After that again same behaviour as mentioned above.

Reply
Options

4397 Posts

11-04-2019

United States of America

354 Signins

33652 Page Views

  • Posts: 4397
  • Registered: ‎11-04-2019
  • Location: United States of America
  • Views: 33652
  • Message 4 of 7

Re:eGPU Docking error - keeps connecting and directly disconnecting

2021-02-19, 20:40 PM

 

Thanks for the response @Astfgl!

 

Usually, it is required to use or connect an external monitor in order to have the eGPU to work with the Yoga Slim 7 laptop.

It would be advisable to get in touch with the eGPU manufacturer to inquire the list of compatible devices as well as cables that will surely work with the Yoga Slim 7 laptop.

 

You may check page 15 of your Yoga Slim 7 laptop's User Guide to see the steps on how to connect an external monitor.

 

Thanks,

Adriel_lenovo

Lenovo Support

 



Did someone help you today? Press the thumbs-up icon below to thank them.!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
This will help the rest of the Community with similar issues identify the verified solution and benefit from it.


Using Browser Search to find your answers in Lenovo and Moto Community
<

Reply
Options

19 Posts

05-13-2018

Germany

26 Signins

221 Page Views

  • Posts: 19
  • Registered: ‎05-13-2018
  • Location: Germany
  • Views: 221
  • Message 5 of 7

Re:eGPU Docking error - keeps connecting and directly disconnecting

2021-02-21, 9:30 AM

External monitor is connected to the eGPU - still does not change a thing, unfortunately. Manufacturer says that I just need a TB3-compatible device. Strangely enough it worked at some point - with the same drivers and everything. Is there maybe a safety featur, that prevents the eGPU to stay connected and I should deactivate?

Reply
Options

19 Posts

05-13-2018

Germany

26 Signins

221 Page Views

  • Posts: 19
  • Registered: ‎05-13-2018
  • Location: Germany
  • Views: 221
  • Message 6 of 7

Re:eGPU Docking error - keeps connecting and directly disconnecting

2021-02-22, 14:31 PM

Yesterday I have again been able to use the eGPU (without an external monitor), now today (after at least one hard reboot) - it is again the same like mentioned above:

Charges, GPU connects, disconnects, repeat.

 

The only thing that I did yesterday was trying to get the internal microphone to work, which I did by deinstalling the drivers and reinstalling them via Windows Update. Somehow the microphone isn't working again and I'll do the same, but I do not think that is the problem here.

 

Also just discovered that there's another BIOS-update. I flashed it, but still not change in behaviour - but I have the feeling, that I will BSOD much faster.

Reply
Options

19 Posts

05-13-2018

Germany

26 Signins

221 Page Views

  • Posts: 19
  • Registered: ‎05-13-2018
  • Location: Germany
  • Views: 221
  • Message 7 of 7

Re:eGPU Docking error - keeps connecting and directly disconnecting

2021-02-26, 9:54 AM

So I figured out, when it works and when it does not:

I can only connect the eGPU, when the battery is over 95%.

 

However there is some other problems that occur when pulling heavy load: In the event manager the thunderbolt devices still connect and disconnect every 30s or so. It doesn't show while doing Premiere/Photoshop work and not even while gaming, but every now and then Wifi goes out. So I'm guessing there is still something fishy with the overall PCIe-bridging. I have attached the event log ...

 

And another observation: When connected there is a highly-pitched sizzling noise or hum right at the TB4-port. Weird things ...

 

I would be very happy, if someone from Lenovo would once again look into this ...

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms