cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
saltim
Fanfold Paper
Posts: 12
Registered: ‎10-07-2015
Location: GB
Views: 1,614
Message 1 of 2

yoga 900 13ISK2 - No storage controller driver

Hi guys, i have a yoga 900 13ISK2. i used a program unfamiliar to me, to create a partition on the drive, getting rid of all the other partitions, so i only have 2 partitions.

Windowes became unbootable and unrepairable, as all data was removed.

When i try and install windows it can't see the hard drive. and says 'we couldn't find any drives. to get a storage driver, click load driver'

so here's what i know so far;

the bios shows the hard drive as a samsung MZV...... but only when i put it in UEFI mode. if i put it in legacy the bios shows the hard drive as 'none'.

I've tried to load windows 10 in both legacy and UEFI modes and and it can't see the hard drive in either at the point where windows asks where to load windows.

 

At this stage, i've tried loading all 8 of the inf files from Intel Serial-IO Driver for Windows 10 (64-bit) - Notebook

and the drivers from this file Intel Rapid Storage Technology Driver for Windows 10 (64-bit) - Yoga 900-13ISK

but it just scrolls for a while, goes back to the load windows screen and shows nothing even after i click refresh.

 

Any ideas where to go from here, would be gratefully welcomed.

p.s i have the bios version 2UCN06WW, which is not the latest, but the new bios is an executable from windows, so i can't install it at this stage.

ramk13
Punch Card
Posts: 43
Registered: ‎11-05-2013
Location: US
Views: 1,546
Message 2 of 2

Re: yoga 900 13ISK2 - No storage controller driver

Try this driver (13isk2 and not 13isk). It worked for me. You have to extract them from the Lenovo and Intel exe files:

 

http://support.lenovo.com/us/en/products/laptops-and-netbooks/yoga-series/yoga-900-13isk2/downloads/...

 

Edit: I added more details at this blog post:

http://www.ramk.net/2016/07/yoga-900-windows-10-clean-install.html

Holiday Deals
HAPPENING NOW!

Get the best deals on PCs and tech now during the Holiday Sale
Shop the sale

Top Kudoed Authors