Showing results for 
Search instead for 
Do you mean 
Reply
jtk
Fanfold Paper
Posts: 5
Registered: ‎10-31-2011
Location: us
Message 1 of 20 (15,970 Views)

64-bit Linux, W520 & nVidia

[ Edited ]

It's not clear where the bug exists, but utilizing a 64-bit Linux kernel appears to be a problem with the W520's and the NVIDIA graphics card. Enabling virtualization, but particularly VT-d seems to be one way to reproduce this bug. Try to boot up with a Ubuntu 64-bit 11.10 CD for instance or try to install Debian with an amd64 kernel and X will not load. Ubuntu bug #776999 shows a long thread about it. It seems just running 32-bit is the easiest trade-off for now. BIOS 1.32 does not see to have fixed this issue. If anyone has any additional information about where exactly this bug is located and how to fix or work around it, that would be helpful. John

 

Moderator note; subject edited

802.11n
Posts: 334
Registered: ‎03-02-2010
Location: Dublin
Message 2 of 20 (15,917 Views)

Re: 64-bit Linux, W520 & nVidia

I can confirm that the 64bit + VT-d + discrete graphics hangs pretty early on during Linux boot on my W520, right around when udev is started. You can work around with passing noacpi on the kernel command line but then thats not a setup that you want to run on a daily basis. 

MTJ
Fanfold Paper
Posts: 21
Registered: ‎09-28-2011
Location: Sweden
Message 3 of 20 (15,905 Views)

Re: 64-bit Linux, W520 & nVidia

Confirmed that it happens also on a T420s with Kubuntu's default nvidia driver or nouveau or Nvidia driver from their own site. Basically only driver that works with option "discrete" in BIOS is the vesa.

 

Using an on-screen system monitor (when I _could_ bring up a graphical environment... Lots of tests, don't remember all the scenarios) I could see that the machine was running, but keyboard+any mouse were dead. Hitting Fn+End for brightness down and the whole machine froze. Perhaps by writing a complete xorg.conf one could get back kbd etc, but nowadays I'm too lazy.

 

So I ended up using the "Optimus" BIOS entry and running the Bumblebee/Ironhide solution for GPU switching (now on Kubuntu's default nvidia driver; work's splendidly - granted there are bugs in the Ironhide graphical configuration utilities etc).

 

/MTJ

 

jtk
Fanfold Paper
Posts: 5
Registered: ‎10-31-2011
Location: us
Message 4 of 20 (15,876 Views)

Re: 64-bit Linux, W520 & nVidia

There seems to be handful of issues related to 64-bit on this platform, including an odd screen brightness-related bug. See: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/776999 The safest way forward seems to be to simply sticking with 32-bit. John
Paper Tape
Posts: 3
Registered: ‎11-04-2011
Location: United States
Message 5 of 20 (15,828 Views)

Re: 64-bit Linux, W520 & nVidia

Does this happen with other 64 bit Linux OS's?  Give Fedora a shot.  They usually have more upgraded driver packages since its a 'bleeding edge' distro.

Paper Tape
Posts: 3
Registered: ‎11-04-2011
Location: United States
Message 6 of 20 (15,826 Views)

Re: 64-bit Linux, W520 & nVidia

Does this happen with other 64 bit Linux OS's?  Give Fedora a shot.  They usually have more upgraded driver packages since its a 'bleeding edge' distro.

 

Looks like this thread might help:

 

http://www.nvnews.net/vbulletin/showthread.php?t=163153

 

Do for Fedora 15 x64 OS and Let me know the results 

- Set Discrete Graphics in BIOS
- Set runlevel 3 with `ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target`
- Pass kernel parameter in /etc/grub.conf rdblacklist=nouveau nouveau.modeset=0
- Create file - 

cat /etc/modprobe.d/nvidia-installer-disable-nouveau.conf
# generated by nvidia-installer
blacklist nouveau
options nouveau modeset=0

- Reboot and startx

lwh
Punch Card
Posts: 21
Registered: ‎12-01-2011
Location: Canada
Message 7 of 20 (15,462 Views)

Re: 64-bit Linux, W520 & nVidia

It hangs for me on Fedora 15 and 16 64-bit , with NVIDIA driver installed, discrete or optimus selected and VT-d enabled. If I disable VT-d it boots and works. 

 

Token Ring
Posts: 68
Registered: ‎12-08-2009
Location: US
Message 8 of 20 (15,460 Views)

Re: 64-bit Linux, W520 & nVidia

I can report a lockup using the Nvidia binary driver, discrete graphics mode, VT-d, and 64-bit Ubuntu 11.10.  My workaround is to disable VT-d, and run virtual machines in 32-bit mode with single core. It's slow, but at least it works for my particular needs.

 

With respect to Windows, I'm seeing some unexpected (and rather surprising) effects with the Nvidia driver and an external monitor connected via display port. But that's a whole other issue Smiley Wink

Fanfold Paper
Posts: 13
Registered: ‎12-29-2011
Location: UK
Message 9 of 20 (15,160 Views)

Re: 64-bit Linux, W520 & nVidia

 

I am using 64bit Kubuntu 11.10 on my Lenovo laptop - but I am using the built-in graphics card and I did have a complete crash once when I had installed the Nvidia drivers etc through the ubuntu repositories.

 

More importantly this problem seems to be there in different models as well.

 

Mine is a B570. After the crash due to Nvidia drivers I had to re-install Kubuntu completely.

 

Token Ring
Posts: 68
Registered: ‎12-08-2009
Location: US
Message 10 of 20 (15,136 Views)

Re: 64-bit Linux, W520 & nVidia

Good news regarding VT-D and Nvidia on 64 bit Ubuntu 12.04 alpha. VT-D can be enabled and using the Noveau driver, and there is no lockup at boot time on a W520 at least. I have no idea how well or not the binary Nvidia driver works, because I can't get it work. Of course the Noveau graphics performance is no where near as good (e.g. no acceleration in Flash video), but on the plus side, the regular Gnome applets like Display and Color work as intended. 

Top kudoed Authors