Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
Posts: 2
Registered: ‎05-05-2016
Location: FR
Message 1 of 1 (275 Views)

CPU speedstep on T540p (Linux)

[ Edited ]

Hello everyone,

 

I have been trying to get Linux running correctly on my T540p without success so far.

The issue is that the CPU keeps on overheating and then throttles itself. It is an Intel i7-4710MQ model. I also have a NVIDIA GT730M in the laptop.

I haven't met this issue on Windows during the few months I've had the computer.

 

I've spent a lot of time on this and worked with other people too, here's what came up: the CPU is constantly running at maximum clock speed, which generates more heat and thus triggers throttling. It also makes it use a lot more power, which drastically reduces battery life (from 6 to 2 hours).

 

SpeedStep is properly set in the BIOS, and the BIOS itself is up to date.

I have tried different Linux distributions (Debian, Ubuntu LTS, Arch Linux). I've set up thermald, enabled the microcode updates, used intel_pstate, read the whole Archwiki page and basically tried all of it. Even using more "manual" modes such as acpi-cpufreq with "ondemand" doesn't help.

The only thing that helped was manually setting the frequency to a low value, which increased the autonomy at the cost of performance.

 

Having Linux running is essential for my professional work, and one of the reasons why I choose Lenovo.

I would appreciate any help.

 

Thanks for reading !

Top kudoed Authors
User Kudos Count
3
3
1
1
1