Support in other languages: 
Showing results for 
Search instead for 
Do you mean 

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team

Community Spotlight

Visit the Community Blog
Reply
What's DOS?
Posts: 2
Registered: ‎05-10-2012
Location: United States
0 Kudos

How do I disable the touchpad on a Lenovo V570 in Ubuntu 11.10?

I have a Lenovo V570. I am running Ubuntu 11.10.

 

Until a few days ago, I could disable my touchpad with the following command:

 

xinput set-prop 12 "Device Enabled" 0


But now when I try that command, my system acts like something is holding down the Return key, and I have to restart the system to make it stop (e.g., constant scrolling in shell or gedit; hovering the cursor over an icon or menu using the mouse instantly activates it).

 

Here's what I get when I do "xinput list":

 

⎡ Virtual core pointer          id=2     [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer  id=4     [slave pointer (2)]
⎜ ↳ Logitech USB Optical Mouse  id=9     [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad  id=12    [slave pointer (2)]
⎣ Virtual core keyboard         id=3     [master keyboard (2)]
↳ Virtual core XTEST keyboard   id=5     [slave keyboard (3)]
↳ Power Button                  id=6     [slave keyboard (3)]
↳ Video Bus                     id=7     [slave keyboard (3)]
↳ Sleep Button                  id=8     [slave keyboard (3)]
↳ Lenovo EasyCamera             id=10    [slave keyboard (3)]
↳ AT Translated Set 2 keyboard  id=11    [slave keyboard (3)]
↳ Ideapad extra buttons         id=13    [slave keyboard (3)]


I'm guessing that this has something to do with one of the updates I installed the day or two prior to this problem cropping up.

 

Any ideas would be appreciated!


Posts: 2,919
Topics: 106
Kudos: 159
Blog Posts: 0
Solutions: 123
Registered: ‎02-22-2008
Location: US
0 Kudos

Re: How do I disable the touchpad on a Lenovo V570 in Ubuntu 11.10?

I found another program on the ubuntu site,these are keyboard shortcuts.hopefully they help you out

sudo add-apt-repository ppa:atareao/atareao
sudo apt-get update
sudo apt-get install touchpad-indicator


More info here

https://help.ubuntu.com/community/SynapticsTouchpad




Cheers and regards,
• » νιנαソѕαяα∂нι ѕαмανє∂αм ™ « •
●๋•کáŕádhí'ک díáŕý ツ


I am a volunteer here. I don't work for Lenovo
Highlighted
What's DOS?
Posts: 2
Registered: ‎05-10-2012
Location: United States
0 Kudos

Re: How do I disable the touchpad on a Lenovo V570 in Ubuntu 11.10?

Thank you, I'll give it a try.