cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kylemfry3
What's DOS?
Posts: 2
Location: US
Views: 8,612
Message 1 of 4

Ideapad 320 touchpad not working in Linux

Hi all

 

I recently installed Elementary OS 0.4.1 Loki on my Ideapad 320-15ABR. I can dual boot both Windows and Linux fine, it's just that the touchpad does not work. I can only use a wireless mouse, and if I do

xinput --list

the touchpad does not even show up.

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                   	id=9	[slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                   	id=10	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ EasyCamera                              	id=11	[slave  keyboard (3)]
    ↳ Ideapad extra buttons                   	id=12	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]
    ↳ Logitech USB Receiver                   	id=14	[slave  keyboard (3)]

The touchpad works fine on Windows, it's linux that's the problem. I've installed and updated to the latest kernal, but that still hasn't fixed the issue.

 

Any help is appreciated. Happy holidays!

Srajan_asq
Punch Card
Posts: 7
Location: IN
Views: 8,243
Message 2 of 4

Re: Ideapad 320 touchpad not working in Linux

I had a similar problem earlier. After I installed Ubuntu Linux on my laptop, the touchpad wasn't working, but it was working on Windows 10, which meant that there was no issue with the hardware of the touchpad.

Then to solve the problem, what I did was, I updated the kernel version and after restarting the laptop, the touchpad started to work.

 

wget https://launchpad.net/~hanipouspilot/+archive/ubuntu/ppa/+files/elantech-0608-dkms_0.2_all.deb
sudo dpkg -i elantech-0608-dkms_0.2_all.deb

Try running these two commands and restart the system. 

kylemfry3
What's DOS?
Posts: 2
Location: US
Views: 7,841
Message 3 of 4

Re: Ideapad 320 touchpad not working in Linux

Hi, I tried doing what you did, and to no avail... Once I ran it in terminal, everything was OK until I was given the message "Secure Boot is not enabled on this device", so I rebooted my system and went into BIOS and enabled it. After running the command again, I was presented with an option to disable UEFI Secure Boot, which I did. After restarting once more, still not working.

 

I am using Linux Kernal v4.10.2 I believe... Is this up to date?

 

(Also, sorry for the time it took to reply, It's been a really long and busy holiday for me)

Reynaldo_Porras
Paper Tape
Posts: 1
Location: NI
Views: 2,719
Message 4 of 4

Re: Ideapad 320 touchpad not working in Linux

I am on Fedora 28. I got the touchpad working by installing xorg-x11-drv-synaptics-legacy.x86_64 package.

 

$ sudo dnf install xorg-x11-drv-synaptics-legacy.x86_64

 

xinput --list
⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ Synaptics TM3336-001                        id=11    [slave  pointer  (2)]
⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    ↳ Power Button                                id=6    [slave  keyboard (3)]
    ↳ Video Bus                                   id=7    [slave  keyboard (3)]
    ↳ Power Button                                id=8    [slave  keyboard (3)]
    ↳ EasyCamera: EasyCamera                      id=9    [slave  keyboard (3)]
    ↳ Ideapad extra buttons                       id=10    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=12    [slave  keyboard (3)]

 

Top Kudoed Authors