Showing results for 
Search instead for 
Did you mean: 
Posts: 66
Registered: ‎05-23-2011
Location: Germany
Views: 20,956
Message 1 of 9

Ideapad S205: GRUB+EFI trouble

Hi Smiley Happy


i have some trouble setting up a "Dualboot" with Windows 7 and Debian on my S205.

I got my S205 with FreeDOS. I replaced the HDD with a Samsung 470 Series SSD.

Then i installed Windows:

Hitting F12 (e.g. Fn+F11); selecting my external USB DVD drive; waiting until the first "press any key to boo from cd/dvd........." prompt expired. Then a second one - this time in german since i have a german Windows 7 - appeared.


When i enter the Windows setup from the first prompt, the installer complains about unsupported storage media - maybe this is because my SSD is preformatted with an MBR partition table and the first prompt enters the EFI+GPT Windows installer.

So i guess the first prompt does not come from my Windows CD, maybe some EFI program?


Anyway, when i entered the setup from the second, german prompt (which comes from the CD i think), i was able to install Windows like i used to do on "normal" PCs with BIOS. So i think this is the BIOS emulation mode.


Windows works well, including Shutdown, Hibernate, WLAN. But i wanted a dualboot setup, so i shrinked the Windows C: partition, maintaining the correct alignment (partition offsets) to preserve health and performance of my SSD.

Then i created 3 new partitions - one for /boot (/dev/sda3), one for / (/dev/sda5) and one for swap (/dev/sda6).


After that, i installed Debian Sid to /dev/sda5 (which is btrfs) and GRUB (grub-legacy, 0.97) to /dev/sda3 because /boot shouldn't be on a btrfs.

First i tried GRUB2, but it doesn't work. I found some advice in forums. They say i had to use GRUB instead of GRUB2. So i did...

I chrooted in my installed Debian using a Live-CD, purged every single grub package and installed grub-legacy.

As root, i entered

# grub

 to get a grub shell. Then

root (hd0,2)


setup (hd0,2)

 to install GRUB to my /boot partition. Of course, /dev/sda3 (which is (hd0,2)) was marked as active.

When i turned my S205 on after that, it gave me "loading GRUB.." and then immediately restarted, and so on (infinite loop).


The same happened when i tried to install GRUB to (hd0,0), which is the Windows 7 boot partition.


I know that you normally install GRUB to the MBR of the disk, but that didn't work at all:

When i tried to install GRUB to (hd0) in the beginning, when booting all i got was "BOOTMGR missing, press ctrl+alt+del to restart" from Windows.

I had to boot the Windows CD, execute 'bootrec /fixmbr', 'bootrec /fixboot', 'bootsect /nt60 C: /mbr' and set the first partition (Windows Bootloader) as active to fix that.

But directly after that, GRUB worked, which is quite surprising since the mentioned Windows commands normally overwrite everything related to foreign bootloaders.


Now i can boot my Debian, that works like a charm. But i can't boot Windows.

I have the following entry in my /boot/grub/menu.lst:

title        Windows 7
root         (hd0,0)
chainloader +1

 Normally this works when Windows (or, here, its bootloader) is on the first partition. Of course i tried (hd0,1) as well since this is the "C:" partition (/dev/sda2). /dev/sda1 has only 100MB and contains the Windows Bootloader.


What can i do? Smiley Sad

Posts: 66
Registered: ‎05-23-2011
Location: Germany
Views: 20,864
Message 2 of 9

Betreff: Ideapad S205: GRUB+EFI trouble



1. boot a Linux Live-CD

2. mount /dev/sda5 to /mnt, /dev/sda3 to /mnt/boot. bindmount /dev and /sys and mount /proc to their places in /mnt.

3. chroot /mnt

4. purge every grub related package

5. install grub-pc (it's GRUB2) and os-prober

6. grub-install /dev/sda --> update-grub

7. boot the Windows CD, enter the console

8. bootsect /nt60 C:

9. diskpart --> select disk 0 --> select partition 3 --> active --> exit

10. repeat 1.-3.

11. grub-install --force /dev/sda3 (warinings about blocklists, ignore that. Should finish with "ok, no errors". Problems with core.img? Post them here!)

12. update-grub (should find Windows 7 Loader)

13. reboot into your working GRUB2 Smiley Happy

Paper Tape
Posts: 6
Registered: ‎06-27-2011
Location: France
Views: 20,121
Message 3 of 9

Betreff: Ideapad S205: GRUB+EFI trouble

Hi, I have the same kind of problem but I'm Ubuntu only.

When I tried grub-install /dev/sda1 (my /boot), I got plenty of error saying it won't install on it.

I was afraid (and still) to go further...

Posts: 66
Registered: ‎05-23-2011
Location: Germany
Views: 20,008
Message 4 of 9

Betreff: Ideapad S205: GRUB+EFI trouble

Hi sioban,


if you want to use Ubuntu only, you can avoid this kind of trouble. Just install Ubuntu 11.04 using the "Desktop" CD, preferrably 64bit. It should produce a working grub2 installation.


I guess you installed Ubuntu using the netinstall image "mini.iso" or the "Alternate"-CD?


Anyway, if you want to continue: Be sure to have backups of your data on the S205.


Don't worry about warnings when doing 'grub-install --force /dev/sda1'. the --force option was necessary for me.


The worst-case-scenario when this leads to errors: You can't boot your Ubuntu anymore and have to wipe your disk (including MBR!) and start again, using the "Desktop"-CD.



Paper Tape
Posts: 6
Registered: ‎06-27-2011
Location: France
Views: 19,964
Message 5 of 9

Betreff: Ideapad S205: GRUB+EFI trouble

Thanks for the answer. I'm not feeling ok to wipe the disk, lasted to much time on tweaking Smiley Wink Anyway since the last bios suspend is working with GRUB Legacy, hibernate still not however... I haven't used Netinstall, but a full install from USB key. Why do you prefer 64bits ? I'm still wondering what are the real gains besides the memory problem which can be solved with -pae kernel. At first I was afraid about some driver not available under 64bits.
Paper Tape
Posts: 6
Registered: ‎06-27-2011
Location: France
Views: 19,623
Message 6 of 9

Betreff: Ideapad S205: GRUB+EFI trouble

Just a head up : My SSD crashed so gone for a full reinstall on a new one. I've tried the process with grub2 and --force options but with no success.
Posts: 66
Registered: ‎05-23-2011
Location: Germany
Views: 19,620
Message 7 of 9

Betreff: Ideapad S205: GRUB+EFI trouble


i'm using another Setup now, Suspend To Disk/Shutdown is working now.

First i installed Windows 7 (MBR, BIOS), then i continued with Ubuntu. Ubiquity installed GRUB 2, an EFI version. It doesn't work because of the fall-back-EFI-loader (Windows installs two loaders: a normal one and a fall back loader).


Because of this i created an entry in the Windows boot menu that loads GRUB 2. You can do this with EasyBCD.

Blue Screen Again
Posts: 1
Registered: ‎07-30-2011
Location: italy
Views: 19,424
Message 8 of 9

Betreff: Ideapad S205: GRUB+EFI trouble

Hello guys,

I just got the same laptop I wiped out the HD and i installed a fresh copy of Ubuntu 11.04. The ISO downloaded from the website was carrying the kernel 2.6.38 and the grub-efi bootloader. Once installed Ubuntu run a distro upgrade that also installed grub-pc and of course the laptop is not able to boot.

As far as i understood the problem is caused by the S205 Bios that doesnt recognize the GPT partition. Reading your posts didnt really help, i-m not a pro in this business so Id like to understand if there is an easy workaround for that.

Would it be possible to upgrade the BIOS? If so, it is possible to do it within Ubuntu since i dont have Win7?

If not, how can i preserve grub efi during the upgrade process adn avoid the installation of grub-pc?

Any help would be highly appreciated...

Thank you.

Community SeniorMod
Community SeniorMod
Posts: 6,829
Registered: ‎01-13-2008
Location: US
Views: 7,575
Message 9 of 9

Betreff: Ideapad S205: GRUB+EFI trouble

Check out current deals!

Shop current deals

Top Kudoed Authors