Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 3
Location: North Carolina
Message 1 of 18

New T500 no wifi drivers

So I just received my brand new T500 today.  I've been the proud owner of a T60 for 3 years and the only thing I've regretted was getting the intel graphics.   I digress.


I was under the impression that the Thinkpad b/g/n miniPCI WLAN card was an atheros chipset, which was why I picked it over  the intel card.  Unfortunately it would appear that lenovo has changed this.  As far as I can tell the card is a realtek 8192se.  I can find nothing what so ever about this card.  I especially can't find linux drivers.  


Here is the output from lspci -vv:


 03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8172 (rev 10)
        Subsystem: Realtek Semiconductor Co., Ltd. Device e020
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 11
        Region 0: I/O ports at 3000 [size=256]
        Region 1: Memory at f4200000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000  Data: 0000
        Capabilities: [70] Express (v1) Legacy Endpoint, MSI 00
                DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
                        MaxPayload 128 bytes, MaxReadReq 512 bytes
                DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
                        ClockPM- Suprise- LLActRep- BwNot-
                LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
        Capabilities: [100] Advanced Error Reporting <?>
        Capabilities: [140] Virtual Channel <?>
        Capabilities: [160] Device Serial Number 00-e0-4c-ff-fe-22-55-88


I even tried installing the Windows XP driver through ndiswrapper, but I couldn't make that work either.


Does anyone have any experience getting this to work under linux.


I'm currently running Ubuntu 9.04.




Paper Tape
Posts: 2
Location: Mount Dora, Florida
Message 2 of 18

Re: New T500 no wifi drivers

You're not alone! I just got a T500 with the same card, under the same impression about the previous Atheros driver. It appears to be Realtek now.


After some investigating, I attempted using Ubuntu backports / restricted modules, as well as installing the windows driver using ndiswrapper Smiley Happy


After some frustration, I boxed the laptop back up, but found after calling Lenovo that they were going to charge me a 15% restocking fee as well as shipping to take the laptop back. So I installed Windows XP to try and confirm that the wifi card even existed!


After installing Windows XP and a very particular driver (This one: linked to from this forum post: the wifi worked!


I still haven't gotten it to work in Ubuntu. If anyone does, please document it somewhere!

Paper Tape
Posts: 3
Location: North Carolina
Message 3 of 18

Re: New T500 no wifi drivers

I'm wondering if it would be possible to get a replacement card, and what that might cost.  As a last resort I tried to switch cards between my old T60 and this machine.  Unfortuneately the miniPCI wifi card from the T60 isn't in the BIOS's whitelist.  So it would not boot with the new card. 


I'd love it if there was a way to order the Atheros card and replace this realtek.  



Paper Tape
Posts: 2
Location: Mount Dora, Florida
Message 4 of 18

Re: New T500 no wifi drivers

I'd be happy to switch out the wireless too, if I can avoid sending this laptop in.


Looking at the parts available from Lenovo, they only seem to be selling the card we're having trouble with ( ) in parts, and there doesn't seem to be a way of differentiating between Atheros v Realtek chipsets (the product info doesn't mention either of these)

Punch Card
Posts: 54
Location: Canada
Message 5 of 18

Re: New T500 no wifi drivers

I'm not sure how Ubuntu plays.  But if possible, can you open a console and post the output of running ifconfig and iwconfig?
Paper Tape
Posts: 3
Location: North Carolina
Message 6 of 18

Re: New T500 no wifi drivers

I'd be glad to.  However, I can tell you that it's not there.  No driver is actually loading to create an interface.


ifconfig -a:



eth0 Link encap:Ethernet HWaddr 00:22:68:0c:ae:5e inet addr: Bcast: Mask: inet6 addr: fe80::222:68ff:fe0c:ae5e/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:362977 errors:0 dropped:0 overruns:0 frame:0 TX packets:226587 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:100 RX bytes:496498654 (496.4 MB) TX bytes:20510069 (20.5 MB) Memory:fc200000-fc220000 lo Link encap:Local Loopback inet addr: Mask: inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:36 errors:0 dropped:0 overruns:0 frame:0 TX packets:36 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:2040 (2.0 KB) TX bytes:2040 (2.0 KB) pan0 Link encap:Ethernet HWaddr 12:5a:45:cf:40:37 BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) vboxnet0 Link encap:Ethernet HWaddr 00:76:62:6e:65:74 BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)




Paper Tape
Posts: 1
Location: Beaverton, OR
Message 7 of 18

Re: New T500 no wifi drivers

You just saved me a lot of time. I did the backports update and was on the verge of struggling with NDIS to attempt to get it working on my newly received R500. Part of the problem is simply the poor documentation from Lenovo on what it is that they actually sent you! I wasn't sure what windows driver I even needed to attempt to install.


I ordered one of the AZIO USB wireless devices that seem to be very well supported with Ubuntu. The aren't fast or graceful, but are cheap at $16.99 at NewEgg (


One of the things that attracted me to the Thinkpad series is how well they are supported with linux. My T42 had all of its features immediately recognized. So, I'm assuming that, in time at least, this new Realtek card will have drivers included with some new kernel revision and I won't have to resort to being "wired" or using the USB thingy.


I'll update here if I find another solution. Good luck.


Fanfold Paper
Posts: 2
Location: Waco, TX
Message 8 of 18

Re: New T500 no wifi drivers

Here is the steps that I used to get ndiswrapper working in Linux (opensuse latest milestone) and a very specific rtl8192se driver.


The driver link is here:

I used wine to extract the exe directly in linux as i didn't have a usbkey handy to copy it over.

Same ndiswrapper commands as before, brought up wlan0 (not using Ubuntu, but the latest OpenSUSE milestone). Looks like encryption does not work, but I'll tinker a bit.

Lenovo TP T400

uname -a
Linux linux-cijc #1 SMP 2009-07-20 20:31:16 +0200 i686 i686 i386 GNU/Linux

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8172 (rev 10)

ndiswrapper -l
net8192se : driver installed
device (10EC:8172) present

[ 8433.024724] ndiswrapper version 1.53 loaded (smp=yes, preempt=no)
[ 8433.040021] ndiswrapper: driver net8192se (Realtek Semiconductor Corp.,05/20/2009,1080.7.0520.2009) loaded
[ 8433.040604] ndiswrapper 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 8433.041406] ndiswrapper 0000:03:00.0: setting latency timer to 64
[ 8433.376098] ndiswrapper: using IRQ 17
[ 8433.752147] wlan0 (ndiswrapper): not using net_device_ops yet
[ 8433.754259] wlan0: ethernet device 00:24:2c:e7:24:5a using NDIS driver: net8192se, version: 0x500a5, NDIS version: 0x500, vendor: 'Realtek RTL8192SE Wireless LAN PCI-E NIC ', 10EC:8172.5.conf
[ 8433.754304] wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK

wlan0 IEEE 802.11g ESSIDff/any
Mode:Managed Frequency:2.457 GHz Access Point: Not-Associated
Bit Rate:130 Mb/s Tx-Power:20 dBm Sensitivity=0/3
RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Token Ring
Posts: 71
Location: Argentina
Message 9 of 18

Re: New T500 no wifi drivers

Hello, first at all, sorry my poor english.

I will try to speak simply and correctly.
I have a thinkpad t500 (with the same realtek card) running Archlinux x86_64.
After unpacking I get the following directories:
+ 91_92_SE_Driver
--> VistaX64
--> VistaX86
--> Win2K
--> WinX64
--> WinXP
I use the folder Win2K to try install the driver, but appear dont work.
Describe the commands that I use:

bash-4.0# ndiswrapper -i net8192se.inf
installing net8192se ...

bash-4.0# ndiswrapper -l
net8192se : driver installed
device (10EC:8172) present

bash-4.0# ndiswrapper -m
module configuration already contains alias directive

bash-4.0# depmod -a
bash-4.0# modprobe ndiswrapper
bash-4.0# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

I'm doing something wrong?
Can someone help me?
I think my problem is the 64bits kernel
Message Edited by takedown on 08-02-2009 03:32 PM
What's DOS?
Posts: 2
Location: USA
Message 10 of 18

Re: New T500 no wifi drivers



I just got an R500 with the same Realtek WLAN chip (lspci says the same as for the T500). The Windows drivers identify it as a Realtek 8192se. I've tried the ndiswrapper that comes with Ubuntu 9.04 Jaunty Jackalope (v 1.53 ndiswrapper) with the Windows XP and Vista drivers from Lenovo but no working wireless networking. I even tried compiling and installing v 1.55 ndiswrapper as suggested by the Ubuntu Wifi Docs for Ndiswrapper,, and it work with any of the Windows drivers. Any suggestions?




Top Kudoed Authors