Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
Posts: 4
Registered: ‎05-08-2010
Location: Fredericksburg VA US
Message 1 of 5 (5,192 Views)

T410 + Ubuntu Lucid: Two Weeks of Use (the Good, the Bad, the Ugly)

System

 

Lenovo ThinkPad T410 laptop, Integrated Intel Graphics, Intel Centrino Advanced-N 6200 wireless.

 

Fixed

  • Resume did not work after second suspend. Fixed by updating BIOS. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/532374

  • Font antialiasing misconfiguration that made small fonts look bad; had to edit ~/.fonts.conf manually to defeat the system preventing antialiasing at small font sizes. Screen is small (14") but has very high resolution (1440x900), so this seems to work ok here.

  • Evolution doesn't autocomplete the email addresses of people you communicate with regularly. Fixed: turn on automatic contacts and autocomplete.

  • Printer config didn't work til I changed system-config-printer to not use the Python on the user path: https://bugs.launchpad.net/ubuntu/+source/system-config-printer/+bug/328657

  • Emacs copy/cut (meta-W, ctrl-W) doesn't put the text being operated on into the X clipboard. Likewise, putting something into the X clipboard doesn't make it possible to paste it into Emacs via ctrl-Y. Fixed via:

    (global-set-key "\C-w" 'clipboard-kill-region)
    (global-set-key "\M-w" 'clipboard-kill-ring-save)
    (global-set-key "\C-y" 'clipboard-yank)

    See also http://www.emacswiki.org/emacs/CopyAndPaste#toc2

  • Toggle state of hardware mute button and software mute button not synchronized. If you hit the hardware mute button, it lights. If you subsequently unmute via software, the sound is umuted, but the hardware mute button remains lit. Pressing the lit hardware mute button in that state will result in the hardware mute button becoming unlit but the sound muted. Seems to have gotten fixed in upgrade to 2.6.34-999-generic kernel while trying to fix USB resume issue.

  • USB broken after resume: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/566149 . (Installed http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2010-05-06-lucid/ aka kernel version 2.6.34-999-generic as per the instructions in https://wiki.ubuntu.com/KernelTeam/MainlineBuilds while waiting for "official" kernel update from Ubuntu).

Outstanding

  • Sometimes Bluetooth icon in indicator applet shows a red X next to it, sometimes it doesn't. I haven't bothered with Bluetooth yet, so I don't know why it's changing state.

  • Sometimes audio mute button stops working. What's in syslog: keyboard.c: can't emulate rawmode for keycode 240 for each button press. Not sure why it works sometimes and not others.

  • HDMI audio probably busted with installation of http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2010-05-06-lucid/ to fix https://bugs.launchpad.net/ubuntu/+source/linux/+bug/5661492. KDE came up and warned me the device had disappeared when I rebooted with the new kernel.

  • Complete system lockups at various points (maybe once every couple days) requiring a hard power reset. I haven't been able to distinguish a pattern yet. Might be related to the wireless errors below; someone else claimed that a similar wireless card got hot enough under Linux to cause disconnects and weird system behavior. I haven't seen crazy temperatures yet though.

  • Wireless network card (Intel Centrino Advanced-N 6200, using the iwlagn driver) freaks out every 20 minutes or so and "restarts" (whatever that means). Seems to be a firmware problem. Symptom: Microcode SW error detected.  Restarting 0x2000000. in syslog. sudo iwconfig wlan0 power off doesn't fix it, upgrade to 2.6.34.99 kernel didn't fix it, can't seem to find any newer firmware to try than what's in http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-6000-ucode-9.193.4.1.tgz. Reported bug at http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2205 as per http://www.intellinuxwireless.org/?n=fw_error_report

    Some potentially related Ubuntu info: http://ubuntuforums.org/archive/index.php/t-1142917.html

  • WTF in syslog, every so often: wpa_supplicant[1196]: CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys plus about 10 other lines of gibberish. Probably related to the microcode problem above, no use trying to figure it out until that gets fixed. See also https://bugs.launchpad.net/ubuntu/+source/linux/+bug/548992

  • At boot time, xdpyinfo | grep resolution still reports wrong DPI (reported: 96x96; actual: 120x120) and screen size (reported: 381x238mm; actual: 300x190mm) even after generating an xorg.conf and adding a DisplaySize 300 190 to the single Section "Monitor" in the config. This doesn't seem to be harming anything, but I don't know really what uses this info. Using xrandr -dpi 120 fixes the resolution and screen size reported by xdpyinfo.

  • Firefox is a problem child for display at 120DPI (native screen DPI); some fonts are huge or tiny when they shouldn't be. Setting the layout.css.dpi in about:config to 120 seems to have no effect. This makes Firefox unusable for me on this system. Thankfully, Google Chrome doesn't have the same problem.

  • Fingerprint reader unsupported.

  • When bringing up a backgrounded Emacs window, sometimes Emacs refuses to give me control of the point in that window until I sacrifice the chicken of selecting any item from that window's menu bar.

  • Emacs acts upon first click of any frame; clicking in a background emacs window reposititions the point in that window. I tried to fix this by adding (setq x-mouse-click-focus-ignore-position t) to my .emacs file as per http://www.gnu.org/software/emacs/manual/html_node/emacs/Mouse-Commands.html. This actually solved the problem: the first click of a window no longer repositioned the point. Unfortunately, contrary to the docs and contrary to the experience of somebody else in #emacs on freenode IRC, this setting also makes the mouse useless for selecting text, moving the point, or scrolling the window text in emacs. It just won't do any of those things for me anymore when this option is set. I can't even shift click on a window to set the font size. This symptom is worse than the problem I was trying to solve by doing it, so I left it off.

  • Audio CD burning doesn't work from Rhythmbox: https://bugs.launchpad.net/ubuntu/lucid/+source/brasero/+bug/543892

  • Pulse Audio advertises airport express send capability; it doesn't actually work (very choppy playback, unlistenable). http://pulseaudio.org/ticket/495#comment:23

  • Opening Rhythmbox from the applications menu doesn't actually open the main window, it just creates a toolbar icon. You then need to know enough to go click on "Show Rhythmbox" in the toolbar icon dropdown.

  • Konversation: sometimes the mouse pointer "disappears" while hovering over the nick list and the channel list. Only fixed by a restart of Konversation (closing the window and restoring it from the system tray doesn't help).

  • Cut and paste is, as always, horrific. You need to use Shift-Ctrl-C in the Gnome terminal vs. Ctrl-C in other Gnome apps; Emacs meta-W doesn't put things onto the X clipboard by default, etc. I really don't understand why you can't remap cut copy and paste under Gnome. If you could remap the Gnome keybindings for cut, paste, copy, etc, I'd bind copy to Windowskey-C, paste to Windowskey-V, cut to Windowskey-X, and Undo to Windowskey-Z. Then at least for all Gnome apps that followed the system keybindings, most of the pain would disappear, because the cutnpaste shortcuts wouldn't step on alternate meanings.

  • Still doesn't look quite as nice as the Mac does, dispite newer and better video and display hardware, no matter how many hours I spend messing around with display settings, font settings, etc.

802.11n
Posts: 334
Registered: ‎03-02-2010
Location: Dublin
Message 2 of 5 (5,131 Views)

Re: T410 + Ubuntu Lucid: Two Weeks of Use (the Good, the Bad, the Ugly)

T410s + Fedora 13 with 2.6.33 kernel here:

 

* Advanced-N Wireless 6200 works, your problem seems to be a bug with a special router.

* Haven't seen any system lockups except for compiz/desktop-effects (which locks up X but computer keeps running). 

 

Fanfold Paper
Posts: 4
Registered: ‎05-08-2010
Location: Fredericksburg VA US
Message 3 of 5 (5,125 Views)

Re: T410 + Ubuntu Lucid: Two Weeks of Use (the Good, the Bad, the Ugly)

Not sure how you figure it's an "advanced router" problem.  I'd be happy to buy a different router, but I'd need to be told which one to buy. The router I'm connecting to is a barebones Linksys WRT54G (the blue and black one with the two antennas that you see everywhere).  These routers are maybe the most common router on the planet, AFAICT.

 

I have also seen Compiz lockups, but I didn't mention those in the above; the lockups I'm seeing are true system lockups.  The system stops responding to any input on network, so it cannot even be restarted remotely.

802.11n
Posts: 334
Registered: ‎03-02-2010
Location: Dublin
Message 4 of 5 (5,111 Views)

Re: T410 + Ubuntu Lucid: Two Weeks of Use (the Good, the Bad, the Ugly)

I've been connected to a WRT54GL for hours (definitely more than 20mins) without problem. Checking my system log, I did get "Microcode SW error" errors on some days with that router. Might be a traffic problem? 

Fanfold Paper
Posts: 4
Registered: ‎05-08-2010
Location: Fredericksburg VA US
Message 5 of 5 (5,102 Views)

Re: T410 + Ubuntu Lucid: Two Weeks of Use (the Good, the Bad, the Ugly)

It's a firmware problem; the firmware crashes.  I'm in the process of trying to help Intel isolate it via their bug tracker.

Top kudoed Authors