English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

1 Posts

01-07-2014

United States

2 Signins

17 Page Views

  • Posts: 1
  • Registered: ‎01-07-2014
  • Location: United States
  • Views: 17
  • Message 1 of 7

T540p - BIOS reliably bricks when installing Linux

2014-01-11, 0:14 AM

My computer bricked itself last week when I tried to install Linux. I didn't know what was wrong, but apparently it's a common issue when installing Linux in UEFI mode:

 

https://plus.google.com/+MarcMERLIN/posts/4RDPCGYCDWq

https://github.com/leoluk/thinkpad-stuff/wiki/Haswell-ThinkPad-problems#linux-bios-corruptionbrick

 

The last BIOS update was months ago. When is Lenovo going to fix this? They usually have extremely good Linux support.

Reply
Options

7634 Posts

11-19-2007

US

10101 Signins

400183 Page Views

  • Posts: 7634
  • Registered: ‎11-19-2007
  • Location: US
  • Views: 400183
  • Message 2 of 7

Re: T540p - BIOS reliably bricks when installing Linux

2014-02-07, 21:13 PM

Slabity,

 

Did your config include an SSD?   Please see this thread including the solution post which includes some interrip tips to avoid this situation.  http://forums.lenovo.com/t5/W-Series-ThinkPad-Laptops/HOWTO-Brick-a-W540-in-easy-steps/m-p/1400393#M43210

 

Lenovo is working on an update (I would assume BIOS) to resolve this.

 

I know there is wider discussion with the belief that this is tied to Linux installs, but I'm not sure that Linux is truly the key as this can happen with other OS under the right conditions.  We'll continue to monitor this.

 

Thanks! 

 

Mark

Reply
Options

4 Posts

03-07-2013

Finland

7 Signins

31 Page Views

  • Posts: 4
  • Registered: ‎03-07-2013
  • Location: Finland
  • Views: 31
  • Message 3 of 7

Re: T540p - BIOS reliably bricks when installing Linux

2014-04-03, 10:25 AM

Are you sure you bricked your bios  and not just messed iuo the UEFI HD partition ?


1. There is no spoon, I mean BIOS, on Lenovo 540 series machines.. 540 Lenovo series does not have BIOS instead those  MBs have UEFI.


2. The machine is not  "bricked".  You just  messed up  your harddrive partitions.


BIOS is replaced by EUFI and unlike BIOS the EUFI is located on    YOUR HARDDRIVE !!!!!

 

When you f-up your harddrive installing a operating system. You did not "brick" anyhitng.
Use installation mediem or recovery that than restore or create completely new UEFI partition on the harddrive.

SUSE 13. (released few months ago) was first ever Linux distro with full UEFI support and it can create a completely new EUFI partition on your harddrive.

In UEFI  settings  (just like bios) on 540 mahines you can choose "BIOS or UEFI" but you can not really choose BIOS. That is a Legecy BIOS support provided by the UEFI  itself. So still no BIOS.

 

Reply
Options

9 Posts

02-24-2014

Iran

39 Signins

160 Page Views

  • Posts: 9
  • Registered: ‎02-24-2014
  • Location: Iran
  • Views: 160
  • Message 4 of 7

Re: T540p - BIOS reliably bricks when installing Linux

2014-04-18, 8:30 AM

After this issue, my laptod always hangs at Thinkpad splash screen no matter what. I can't enter setup, or boot from any device. I changed my HDD to test it but still no diferrence.

Do you mean I can fix it bu taking HDD out, installing SUSE and placing it back?

Btw I changed bios mode to legacy before.

Reply
Options

4 Posts

03-07-2013

Finland

7 Signins

31 Page Views

  • Posts: 4
  • Registered: ‎03-07-2013
  • Location: Finland
  • Views: 31
  • Message 5 of 7

Re: T540p - BIOS reliably bricks when installing Linux

2014-04-21, 15:34 PM

AFAIK there should not be any way your could brick Lenovo by installing OS on harddrive.
(excluding coreboot etc. which modify the BIOS itself and flashing the bios upgrade.) 

installing opensuse on lenovo 540 (repairing): 

First set lenovo T540  to "UEFI only"  and disable that other legacy subsystem  (CMP I think it was). 
so it is PURE forwardlooking UEFI system. None of the backward compatipility stuff.. 

Check that HD settings are ACHI (though I do not think there even was any settings for that) .

check boot order 

 

Boot from OpenSUSE 13.1  and tell the installed to "nuke" the whole disk:

 

Delete all partition, MBR  etc. from the disk (make sure you commit the changes to disk) 

and let the installer do a completely new HD makeup from scratch.

 

That should do it, unless it is hardware issue.

les or more related rant on Lenovo HW QC and design:
In my Lenovo W530 (= chinese cheap-o version od IBM thinkpad) I had strange problem in linux (opensuse also) that the disk dropped offline after a few days. When I diagnosed it I noticed the HD performance fluxuating from normla to like less than 1% eventually it dropped so low smartcontrolle and OS dropped to HD to read only mode as a failing disk.. Reason was physical contact failures in SATA conenctors caused by these red plastic crappy cheap-o HD mounting rails. They had all kinds of molding leftover plastic crap on them and those were "attached" to HD with 4 screws ut the joke was that screw holes on them were too large so the base of the screw did not actually touch the rails or hold them in any way. You could take the rails out and put them on with the screws screwed on the HD. While I was testing other HD on the laptop, I left out the **bleep** rails to make switching HD easier and to my suprise failures stopped. I disagnosed this for months and only thing that affected the  outcome was those **bleep** rails. taking them out and stuffing in same paper to prevent the HD from moving ALL HD problems stopped. 


Reply
Options

4 Posts

03-07-2013

Finland

7 Signins

31 Page Views

  • Posts: 4
  • Registered: ‎03-07-2013
  • Location: Finland
  • Views: 31
  • Message 6 of 7

Re: T540p - BIOS reliably bricks when installing Linux

2014-04-21, 15:57 PM

If it still does not boot the installed OS.

Next booting from the suse install DVD (ubs) and choosing "boot installed system form HD" if it boots ok this way then you know problem is lenovo boot & HD settings. most likely boot order. 

Reply
Options

1 Posts

11-27-2014

Northern Hemisphere

3 Signins

17 Page Views

  • Posts: 1
  • Registered: ‎11-27-2014
  • Location: Northern Hemisphere
  • Views: 17
  • Message 7 of 7

Re: T540p - BIOS reliably bricks when installing Linux

2014-11-27, 5:27 AM

Has this issue been resolved?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete