cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
EricKit
Serial Port
Posts: 36
Location: Florida
7,517 Views
Message 1 of 6

Twist - Ubuntu with new BIOS update

Has anyone attempted to install Ubuntu after the most recent bios installation for the Lenovo Twist?  I'm wondering if others are having the same issue that a few are having now, some with an SSD installed and some without.

 

Here is a link to the question on Ask Ubuntu

http://askubuntu.com/questions/445309/unable-to-find-a-medium-containing-a-live-file-system-with-ssd

 

After selecting Install Ubuntu from booting from a USB key it shows the loading Ubuntu screen for about 30 seconds then gives the error initramfs "Unable to find a medium containing a live file system" on a Lenovo Twist laptop.

 

What is unique about my error is that Ubuntu was installed and running fine on a partition of the my 500 GB Hard Drive. I had an SSD 24GB Cache. I replaced my normal HD with an SSD and installed Windows 8 on it. I then formatted the cache with FAT32 planning on putting Ubuntu on that 24GB. But now I can't boot from the same USB I used before with Linux. My boot order is USB HD, SSD Hard Drive, then Cache.

 

I have checked the MD5, used multiple tools to make the boot key, made sure I'm booting with AHCI, tried all USB ports, disabled USB 3.0, and tried everything from this bug report:

https://bugs.launchpad.net/ubuntu/+source/casper/+bug/1241589

Also when I type "blkid" from the initramfs it does not show my USB key.

So I'm unable to boot from a Linux live USB key after changing my harddrive.

This question is asked before, but this is different than the others because it's unique to a SSD and the "solutions" to others do not work in this case. There are lots of causes of this error where when installing you get a "Unable to find a medium containing a live file system" but none of the solutions work and I believe this is unique to replacing my HD with an SSD.  However someone has reported that they have the same issue without the SSD which makes me wonder if it's a function of the BIOS.

 

Moderator Note; subject edited

Community Moderator
Community Moderator
Posts: 6,016
Location: US
7,485 Views
Message 2 of 6

Re: Twist - Ubuntu with new BIOS update

Hi,

 

I spent yesterday beating on what seems to be the same issue.  I have a stock Twist with latest BIOS 1.65.  I get the same error you do.  Happens in UEFI mode or legacy mode.

 

If I revert the BIOS to 1.62 I can boot Ubuntu 12.10 64 and later fom a USB flash drive in UEFI mode or any of several distros in legacy mode.  I still have an issue where some of my flash drives aren't shown in the boot menu at all unless I revert to an even older BIOS.

 

As I said, it's a stock Twist running 8.1+ from an HDD + cache SSD as shipped.

 

[edit] For clarity - I hope.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored. ... GeezBlog

 

Communities:    English English   Deutsche Deutsche    Español Español    Português Português    ru.gif Русскоязычное





EricKit
Serial Port
Posts: 36
Location: Florida
7,458 Views
Message 3 of 6

Re: Twist - Ubuntu with new BIOS update

It's good to have that data.  Hope we can figure this one out.

Lenovo Staff
Lenovo Staff
Posts: 4,144
Location: NC
7,428 Views
Message 4 of 6

Re: Twist - Ubuntu with new BIOS update

EricKit

 

I see this issue also on the latest released BIOS 1.65.  There's a new BIOS (1.66) currently being tested that fixes this problem, but it's not ready for public release yet.  My advice is to stay on the previous working BIOS for now.  

EricKit
Serial Port
Posts: 36
Location: Florida
7,406 Views
Message 5 of 6

Re: Twist - Ubuntu with new BIOS update

Yep 1.62 works.  Thanks!

kimbwallace
Paper Tape
Posts: 4
Location: Cleveland, Ohio
7,281 Views
Message 6 of 6

Re: Twist - Ubuntu with new BIOS update

Here is a workaround:

 

When booting off the Ubuntu USB, hit Space as soon as the keyboard symbol appears at the bottom of the screen. This brings up the Ubuntu boot menu. Hit F6 and toggle ACPI OFF, then Escape.

 

After I did that, I chose Try Ubuntu. Got to the desktop and ran the install (on a spare drive I swapped in). Install ran, rebooted and it's booting Ubuntu fine. Now, to play with getting the screen to auto-rotate Smiley Happy

 

Top Kudoed Authors