English Community

Linux Operating SystemsDebian
All Forum Topics
Options

16 Posts

10-13-2014

Paris (FR)

18 Signins

195 Page Views

  • Posts: 16
  • Registered: ‎10-13-2014
  • Location: Paris (FR)
  • Views: 195
  • Message 1 of 3

X1 5th and Thundebolt3 dockstation no ethernet with Debian

2017-07-07, 15:22 PM

Hi,

 

I've just got my hands on my brand new X1 Carbon 5Th gen with its TB3 docking station. I'm using it with Debian installed.

Everything works well except the docking station ethernet port. I can't even see it with ip a lsusb or lspci.

The display port is working well but neither the Ethernet or USB do. I've tried with Fedora same result. Anyone got it working ?

Solved! See the solution
Reply
Options

16 Posts

10-13-2014

Paris (FR)

18 Signins

195 Page Views

  • Posts: 16
  • Registered: ‎10-13-2014
  • Location: Paris (FR)
  • Views: 195
  • Message 2 of 3

Re: X1 5th and Thundebolt3 dockstation no ethernet with Debian

2017-07-10, 14:35 PM

I have finally managed to make everything work.

First step is to set the security to No Security in the Config => Thunderbolt3  bios item.

It makes the dock's USB ports work and the network card to appear in dmesg but with this error :

  [  10.455099] usbcore: registered new interface driver r8152
  [   10.605127] r8152 6-1:1.0 (unnamed net_device) (uninitialized): Unknown version 0x6010
  [   10.605128] r8152 6-1:1.0 (unnamed net_device) (uninitialized): Unknown Device

The genuine Debian module lacks the 6010 version of the driver. I fetched it on the Realtek website :

driver

 

Compiled it with a single make and replace the original r8152.ko by mine. Working !

 

[ 1638.930694] r8152 6-1:1.0 eth0: v2.08.0 (2016/12/09)
[ 1638.930700] r8152 6-1:1.0 eth0: This product is covered by one or more of the following patents: 
[ 1638.930866] usbcore: registered new interface driver r8152
[ 1638.942182] r8152 6-1:1.0 enx0050b6880d5e: renamed from eth0

0 person found this solution to be helpful.

This helped me too

Reply
Options

14 Posts

08-27-2015

RU

73 Signins

517 Page Views

  • Posts: 14
  • Registered: ‎08-27-2015
  • Location: RU
  • Views: 517
  • Message 3 of 3

Re: X1 5th and Thundebolt3 dockstation no ethernet with Debian

2018-05-05, 6:13 AM

> First step is to set the security to No Security in the Config => Thunderbolt3 bios item.

This shouldn't be necessary anymore with Gnome Shell 3.28+ and bolt daemon, both available in Ubuntu 18.04 or newer:

https://www.omgubuntu.co.uk/2018/03/top-gnome-3-28-features

 

https://fosdem.org/2018/schedule/event/hwenablement_thunderbolt_3_and_linux/attachments/slides/2534/export/events/attachments/hwenablement_thunderbolt_3_and_linux/slides/2534/Thunderbolt_3_FOSDEM_2018.pdf 

> Compiled it with a single make and replace the original r8152.ko by mine. Working !

pciid of dock's integrated Ethernet adapter is included in Linux since 4.13 release, so this part should work with Ubuntu 17.10 or newer:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/drivers/net/usb/r8152.c?h=v4.13-rc5&id=65b82d696b9e84fda6dd7df61801b57d3e7fb976

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete