Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 1
Registered: ‎09-16-2008
Location: australia
Views: 2,537
Message 1 of 3

wireless on r61 (8933 b51)

Hi all,


I've read some encouraging posts here and elsewhere on getting the wireless to work on the r61. I've previously used an r51 and it worked flawlessly with pclinuxos 2007.


This time it just doesn't want to do anything. It's the  "Intel(R) Wireless WiFi Link 4965AG" i'm trying to get to work.


I'm using pclinuxos 2007 again and have tried using the ndiswrapper and it keeps telling me i've invalid drivers. I've followed instructions on setting up ndiswrapper from other guides and i'm getting nowhere.


It's very frustrating.


Would some kind person who has managed to get r61 wireless functionality in linux please post a step by step guide?

Retired Moderator
Retired Moderator
Posts: 1,184
Registered: ‎11-20-2007
Location: Iowa, USA
Views: 2,520
Message 2 of 3

Re: wireless on r61 (8933 b51)

I run Linux Mint and my intel 4965 in my R61 works right out of the box with no special anything. I just told it to connect to my AP, typed in the WPA password and surf's up.


edit: clickable link.

Message Edited by carbon_unit on 09-16-2008 08:35 PM
T60 2623-D7U, 3 GB Ram. Dual boot XP and Linux Mint.
T400 2765-T7U Windows 7

Registered Linux User #160145

FYI: I am not employed by Lenovo
Token Ring
Posts: 218
Registered: ‎09-12-2008
Location: Atlanta, GA USA
Views: 2,271
Message 3 of 3

Re: wireless on r61 (8933 b51)

you shouldn't have to use ndiswrapper, intel has provided an open source driver for those cards.  I'd recommend downloading all the updates (through wired ethernet I guess) and installing packages through synaptic that might have the driver.  Just for a sanity check, download an ubuntu livecd and see if your wireless magically works.  It should.
Lenovo SL300 Owner
earning an MSECE at GATech, with undergrad in BME.

Holiday Deals

Get the best deals on PCs and tech now during the Holiday Sale
Shop the sale

Top Kudoed Authors