Motorola Community

Wearables and AccessoriesMOTO 360™
All Forum Topics
Options

4 Posts

09-30-2014

Brazil

0 Signins

0 Page Views

  • Posts: 4
  • Registered: ‎09-30-2014
  • Location: Brazil
  • Views: 0
  • Message 1 of 5

Messed up display!

2014-12-13, 0:18 AM

I left my Moto 360 on the OEM charger overnight as I often do. When I took it off this morning, this is what I see. I have rebooted, powered off and on, and reset with no change. I emailed Motorola support earlier today, but wondering if anyone else has had this problem.

Reply
Options

8 Posts

09-07-2014

United States

0 Signins

0 Page Views

  • Posts: 8
  • Registered: ‎09-07-2014
  • Location: United States
  • Views: 0
  • Message 2 of 5

Re: Messed up display!

2014-12-15, 5:38 AM

Yikes, haven't seen this on any of the places I visit regarding the Moto 360.



On which firmware is your device?

Reply
Options

4 Posts

09-30-2014

Brazil

0 Signins

0 Page Views

  • Posts: 4
  • Registered: ‎09-30-2014
  • Location: Brazil
  • Views: 0
  • Message 3 of 5

Re: Messed up display!

2014-12-15, 6:06 AM

Ves said:


Yikes, haven't seen this on any of the places I visit regarding the Moto 360.



On which firmware is your device?


View original


I keep checking for the update, but I'm still on 4.4W2. I'm pretty sure this was caused by overheating in the dock. If I remember right, when I took it off the dock it was warmer than usual and still at less than 90% charged after being on the charger all night. What's really weird is that it has seemed to heal itself over the last couple days. The clouding got less and less until it's gone now. I could still see it and some burn in of the Motorola logo on the light setting screens but even that is gone now.



Motorola support has agreed to replace it, so I will let them. I'm afraid of this watch now, as it might happen again and possibly even get hot enough to start a fire while I'm sleeping.

Reply
Options

2733 Posts

03-08-2010

United States

1 Signins

4 Page Views

  • Posts: 2733
  • Registered: ‎03-08-2010
  • Location: United States
  • Views: 4
  • Message 4 of 5

Re: Messed up display!

2014-12-16, 22:46 PM

Wow,



Very strange... I am glad it kind of went away and even more glad you are getting a replacement. Just out of curiosity, were you using the wall plug that came from motorola or a plug from another device/manufacturer?



 

Reply
Options

4 Posts

09-30-2014

Brazil

0 Signins

0 Page Views

  • Posts: 4
  • Registered: ‎09-30-2014
  • Location: Brazil
  • Views: 0
  • Message 5 of 5

Re: Messed up display!

2014-12-16, 23:24 PM

drago said:


Wow,



Very strange... I am glad it kind of went away and even more glad you are getting a replacement. Just out of curiosity, were you using the wall plug that came from motorola or a plug from another device/manufacturer?



 


View original


Yes, I have always used the OEM charger and wall plug that it came with. It's plugged into a power strip with surge suppression too. As of today, the clouding has completely gone away even on the light screens, so I hope Motorola doesn't deny my claim if/when they examine it. I did finally get the update this afternoon and it's installing as I type.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete