Motorola Community

Moto E PhonesMOTO E™ 4th Gen / MOTO E™ 4th Gen Plus
All Forum Topics
Options

2 Posts

01-26-2018

US

5 Signins

45 Page Views

  • Posts: 2
  • Registered: ‎01-26-2018
  • Location: US
  • Views: 45
  • Message 1 of 288

Moto E4 wifi connection problems

2018-01-26, 10:57 AM

This problem (or at least a similar one, the causes are unknown) has been described before . The "solution" in the linked post is to turn off and on your phone everytime you lose WiFi connectivity, which happens a lot. There are a lot of users that complain about the problem, and the solution, under the linked post, but Motorola seems to ignore the issue, so I'd like to reopen this issue to make Motorola actually work on this. 

 

In short, the WiFi connectivity on the E4 (Plus, in my case) is terrible. Either my phone doesn't connect at all, or it connects and states "No internet connection", or it connects normally but doesn't actually have internet connection, or it connects, has internet for a few minutes but then loses the connection.

 

There are a bunch of suggestions what one could do in the linked post, including restarting the phone, restarting the WiFi, turning off Bluetooth, going in and out flight mode, turning off Bluethooth and WiFi scanning in Location settings, but none of those is an acceptable solution. 

Reply
Options

3 Posts

10-24-2017

GB

6 Signins

58 Page Views

  • Posts: 3
  • Registered: ‎10-24-2017
  • Location: GB
  • Views: 58
  • Message 2 of 288

Moto E4 Plus not connecting to Wifi

2017-10-24, 15:02 PM

The Phone has been dropping the Wifi out at home ove the last week. All other devices are fine but e4plus will now not connect to my hub. It looks to connect but in the settings says the Wifi is disconnected. Help please  

Reply
Options

5405 Posts

07-12-2014

US

925 Signins

79600 Page Views

  • Posts: 5405
  • Registered: ‎07-12-2014
  • Location: US
  • Views: 79600
  • Message 3 of 288

Re: Moto E4 Plus not connecting to Wifi

2017-10-25, 17:37 PM

wrote:

The Phone has been dropping the Wifi out at home ove the last week. All other devices are fine but e4plus will now not connect to my hub. It looks to connect but in the settings says the Wifi is disconnected. Help please  


Hi Alan106,

 

Does this happen to all wifi networks you connect to with your Moto E4 Plus, or is it just limited to your home network? Does a reboot of your phone and router help?

 

Regards,

JM

Motorola Support

Reply
Options

3 Posts

10-24-2017

GB

6 Signins

58 Page Views

  • Posts: 3
  • Registered: ‎10-24-2017
  • Location: GB
  • Views: 58
  • Message 4 of 288

Re: Moto E4 Plus not connecting to Wifi

2017-10-25, 18:36 PM

Home hub has been re booted and it is now connected to the hub but there is no wifi. All other devices work ok off the home hub. The phone does connect to the internet when out and about, ie shops and bt hotspots etc and bt are saying it is all ok on there end,

Reply
Options

3 Posts

10-24-2017

GB

6 Signins

58 Page Views

  • Posts: 3
  • Registered: ‎10-24-2017
  • Location: GB
  • Views: 58
  • Message 5 of 288

Re: Moto E4 Plus not connecting to Wifi

2017-10-25, 19:14 PM
Hi JM, I have spent over 2hrs on to my mobile provider, BT who tried to say that their end was ok. I had my ideas that it was their problem as I could connect to BT hotspots and other wifi when I was out and about.
I persisted and low and behold, its now resolved due to the tinkering they have done at their end. I think it must have been some update they had done as they are always at it. I have lost 2 vision boxes in the past after they had run software updates. Well, just in case anyone else has the same issue. Many thanks, Alan
Reply
Options

3 Posts

10-25-2017

CA

5 Signins

29 Page Views

  • Posts: 3
  • Registered: ‎10-25-2017
  • Location: CA
  • Views: 29
  • Message 6 of 288

Moto E4 wifi connection problems

2017-10-25, 23:06 PM

I have have just setup the phone but it keeps kicking me off from my home wifi connection. If I go very close to the router (a couple of meters) the signal is very weak but it is connected. If I move away  from the router (next level up ~10 meters) ) it immediately disconnects. I cannot believe the problem is due to weak signal from the router because I have other devices (tablet, desktop PC, laptop and another cell phone which is much older) and I never had a problem.

 

I turned the moden off and then back on but it keeps doing the same.

 

Any suggestion?

 

Thanks.

Reply
Options

5405 Posts

07-12-2014

US

925 Signins

79600 Page Views

  • Posts: 5405
  • Registered: ‎07-12-2014
  • Location: US
  • Views: 79600
  • Message 7 of 288

Re: Moto E4 wifi connection problems

2017-10-27, 15:27 PM

Hi Patoruzu45,

 

Have you tried connecting to other wifi networks? Did you experience the same thing?

 

Regards,

JM

Motorola Support

Reply
Options

3 Posts

10-25-2017

CA

5 Signins

29 Page Views

  • Posts: 3
  • Registered: ‎10-25-2017
  • Location: CA
  • Views: 29
  • Message 8 of 288

Re: Moto E4 wifi connection problems

2017-10-27, 22:06 PM

Thanks for your reply.

 

No I had not. But the problem has been fixed. I followed some recommendations given to somebody that reported the same problem somewhere else a few days ago..

 

The steps to fix the problems are:

1) "Forget" the network SSID  that one is trying to connect to (in my case my home network)

2) Turn-off wifi

3) Turn-off the phone for 5 seconds.

4) Turn the phone back on

5) Turn-on wifi

6) Reconnect to the network (in my case my own home network)

 

Regards.

Reply
Options

4 Posts

11-03-2017

RU

11 Signins

80 Page Views

  • Posts: 4
  • Registered: ‎11-03-2017
  • Location: RU
  • Views: 80
  • Message 9 of 288

Re: Moto E4 wifi connection problems

2017-11-03, 10:28 AM

Hi, Patoruzu45 ,
I've started having same issue after last FW update.
wifi connected. But shows limited connection or show normal connection but in fact there is no internet link.

After smartphone restart wifi works well. But after some time (maybe after reconnection to wifi) same issue. untill next restart.

B.R.

Reply
Options

1 Posts

11-08-2017

US

6 Signins

53 Page Views

  • Posts: 1
  • Registered: ‎11-08-2017
  • Location: US
  • Views: 53
  • Message 10 of 288

Re: Moto E4 wifi connection problems

2017-11-08, 15:25 PM

My wifi calling is not working need wifi calling setting app

 

Reply
Options

2 Posts

11-08-2017

GB

2 Signins

53 Page Views

  • Posts: 2
  • Registered: ‎11-08-2017
  • Location: GB
  • Views: 53
  • Message 11 of 288

Re: Moto E4 wifi connection problems

2017-11-08, 17:37 PM

I'm very puzzled that this problem is showing up as "solved". The solution involves restarting everything and would only be useful if it only had to be done once and for all. I've had this problem repeatedly over the last 24 hrs. Every time it happens I restart my phone and the wifi connection resumes, only to drop again in a short while. Can someone suggest a more lasting solution?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete