cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
m_g_2
Paper Tape
Posts: 1
Registered: ‎12-27-2017
Location: US
Views: 866
Message 1 of 2

Moto G2 -> Settings -> Data Usage -> "Unfortunately, settings has stopped."

Several days ago, I was in a low signal area when the problem started. Simply tapping on Settings -> Data Usage results in an abnormal termination message: "Unfortunately, Settings has stopped."

 

And I haven't been able to access the "Data Usage" Settings menu since then, either from the main dropdown menu or from the Settings app.

 

The abnormal termination message sometimes appears immediately after tapping "Data Usage". Sometimes the screen is painted white with the title bar "Data Usage", and then the abnormal termination. Sometimes the Data Usage menu begins to be partially painted before the abnormal termination message. But there is never any info shown about data use, and the slide switch to be able to turn off network data is never visible. The bottom line is that the "Data Usage" Settings menu does not work. Other than that, the phone works fine.

 

The following information could be of help to identify the cause of the bug/issue:

 

  • Model: MOTO G (2nd Generation, global 3G type)
  • Hardware Version: p4
  • Android Version: 6.0
  • Build number: MPBS24.65-34-4
  • Settings App Version: 6.0-6

 

These are the solutions that have been tried up to now:

 

  • Booted the phone. Several times. Fails anyway.
  • Booted the phone in safe mode, fails in safe mode as well.
  • Cleared the Settings app data. Fails anyway.
  • Tried to clear the Settings app cache (doesn't seem to actually clear anything). Fails anyway.
  • Deleted APN configuration. Fails with no APN configured.
  • Reconfigured APN data. Fails again after reconfiguration.
  • Reported the issue to Google. Was told that they cannot reproduce the issue in nexus/pixel devices, and that I should contact the OEM.

 

I have yet to try a factory reset, but would like to avoid going to all the trouble. Does anyone else have the same issue? Anyone out there have a solution?

 

Best regards

Senior MotoAgent
Senior MotoAgent
Posts: 4,534
Registered: ‎12-04-2017
Location: IN
Views: 823
Message 2 of 2

Re: Moto G2 -> Settings -> Data Usage -> "Unfortunately, settings has stopped."

Hi, m_g_2.

 

Thank you for letting us know, as you have already performed clear cache and data along with the safe mode.

 

We want to look further into this, if you can update your profile with the IMEI of your device, this can help us investigate and see what's causing the disconnect. Also, kindly send a bug report regarding this. Bug report will collect information about your current device state.

Here's how:
Note: Capture the report right after the issue happened.

1. Go to Settings -> About Phone -> Tap on Build number 7 times on the build number to go into the developer options mode]
2. After the above steps, Developer options will be enabled.
3. Go to Settings ->Developer options -> Enable USB debugging > Toggle On
4. Enable Settings -> Developer options -> Enable Bug Report shortcut > Toggle On
5. Enable Settings -> Developer options -> Enable Wi-Fi Verbose Logging > Toggle On
6. Once the issue is reproduced, Go to Settings -> Developer options -> Click on take bug report or Press Power button and then choose Bug Report from the Power down menu.
7. Wait for some time until the bug report is collected. It takes around 3 to 4 minutes to collect the Bug Report.
8. Then upload the Bug Report to your personal Google Drive and then share the link to the BugReport on the forums in a reply or via a private message.
9. Provide observations of what you saw happen right before the bug report was taken. Please indicate the time that you observed the behaviour in local time.

 

Thanks,

Swaraj

-Motorola Support