Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Paper Tape
Posts: 1
Registered: ‎05-10-2017
Location: GB
Message 1 of 4 (588 Views)

Moto G2 will not charge

My phone died yesterday. When I've gone to charge it the LED on the front will either show solid white or will flash every 3 seconds.

 

If you press the power button the LED goes off, the screen shows 0% battery and charging. A second later the screen will go black and the LED will go solid white again and this process just repeats.

 

It won't hard reboot and won't let me get into the boot options menu. I have left it charging over night and I woke up to it still showing 0% battery with the LED flashing every 3 seconds.

 

Does anybody know how I can fix this issue please?

 

Thank you 

Senior MotoAgent
Posts: 3,423
Registered: ‎10-05-2016
Location: PH
Message 2 of 4 (554 Views)

Re: Moto G2 will not charge

Hi DannyJW,

 

 Have you tried to use different chargers? Have you tried use wiggle the charging cord while plugged into the charger? How did you try to get into boot options menu?

 

Regards,
Jess
Motorola Support

Blue Screen Again
Posts: 2
Registered: ‎08-18-2017
Location: IN
Message 3 of 4 (323 Views)

Re: Moto G2 will not charge

I have the same problem since yesterday. Please get it solved.asap.

 

I am disconnected from my daily life activities. Please di the needful. Thanks

Blue Screen Again
Posts: 2
Registered: ‎08-18-2017
Location: IN
Message 4 of 4 (323 Views)

Re: Moto G2 will not charge


DannyJW wrote:

My phone died yesterday. When I've gone to charge it the LED on the front will either show solid white or will flash every 3 seconds.

 

If you press the power button the LED goes off, the screen shows 0% battery and charging. A second later the screen will go black and the LED will go solid white again and this process just repeats.

 

It won't hard reboot and won't let me get into the boot options menu. I have left it charging over night and I woke up to it still showing 0% battery with the LED flashing every 3 seconds.

 

Does anybody know how I can fix this issue please?

 

Thank you 


I am facing the same problem. Please get it solved.

Top kudoed Authors
User Kudos Count
1
1